NO JOY VOIPMS hangs up call during voicemail after exactly 1 minute

kyle95wm

Phone Genius Owner
Joined
Apr 16, 2016
Messages
519
Reaction score
88
Location
Midhurst, ON, Canada
So today I discovered that VOIPMS has been hanging up on callers when they leave voicemail messages. I got in touch with support who said it's on their end (they hang up after 1 minute of no RTMP on the other end). I've tried everything on my end like enabling silence while recording, RTMP keep alive, etc. Nothing worked.

Support is currently looking into the issue. I was wondering if anyone had any ideas on how to combat this.
 

kyle95wm

Phone Genius Owner
Joined
Apr 16, 2016
Messages
519
Reaction score
88
Location
Midhurst, ON, Canada
Okay so some more info so that its easier to help me.

The problem is only apparent on the Raspberry Pi 3. It's running the latest image from March (I think) with Asterisk 13.12.2 with Incredible GUI 12.0.39

I have a VM that has CentOS 6.8 running the latest IPBX build - Asterisk 13.13.1 with Incredible GUI 12.0.39

Both servers are using SIP (the Pi had SIP enabled out of the box but the VM had to be switched from PJSIP to SIP through modifying the bind ports)

Calls going to the Pi 3 hang up only if there is silence on the PBX's end for 1 minute exactly. This impacts voicemails

On the VM, calls are treated just fine.

The Raspberry Pi is in the DMZ with the TM whitelist enabled so it's getting a good connection to my provider. The VM is however not in the DMZ but is still able to register.
 

kyle95wm

Phone Genius Owner
Joined
Apr 16, 2016
Messages
519
Reaction score
88
Location
Midhurst, ON, Canada
So I moved all my Pi extensions over to a new VM with the exact same trunk settings. Still have this issue. What gives?
 

kyle95wm

Phone Genius Owner
Joined
Apr 16, 2016
Messages
519
Reaction score
88
Location
Midhurst, ON, Canada
Okay so after days of pulling my hair out, I think I found a solution. The issue was with Asterisk 13 - or so I suspect. I was able to install the official FreePBX 12 with Asterisk 11 on a Pi 3 which includes Ward's firewall albeit not very flexible like in TM3 but it works. I think 13 is messed up where it doesn't "transmit" silence when recording voicemails. It's only been 12 hours but I'm keeping my fingers crossed that Asterisk 13 was the issue here.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,274
Messages
136,540
Members
14,505
Latest member
athan