NO JOY Vitality(now Voyant)

Brianmac

Member
Joined
Oct 7, 2014
Messages
206
Reaction score
20
Over the last two weeks, I cannot get a Did to call directly into the extension on my local PBX. The issue is, Voyant is not making the connection to my PBX(router passing UDP 5060:5060 and 10000:20000 to the proper IP of PBX). So when someone outside, dials the Did, it doesn't ring the extension and instead goes to the failover(on the did in Voyant) and hits the mail line(ringing all phones).
Nothing has changed(no updates or manual changes) on our end and we are using IP endpoint for registration.

any ideas off the top of anyones head?

SIP incoming:
User context: acme123


User Details:
username=acme123
type=friend
t38pt_udptl=no
t38pt_tcp=no
t38pt_rtp=no
secret=mypassword
insecure=port,invite
host=inbound33.vitelity.net
dtmfmode=auto
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw


Register String: acme123:[email protected]:5060
 

Attachments

billsimon

Experienced in Asterisk, FreePBX, and SIP
Joined
Jan 2, 2011
Messages
947
Reaction score
294
we are using IP endpoint for registration
What does this mean? Either you are asking Vitelity to send the calls to your static, public IP, or you are using registration - but not both. If they are sending to your public IP address, then you should remove the registration line.

You will need to pull up Asterisk verbose logs and/or enable SIP debugging in order to see what's going on. The problem should be evident from one of those two sources. Post some of the logs/debugs here if you need help.
 

Brianmac

Member
Joined
Oct 7, 2014
Messages
206
Reaction score
20
understood about registration, it was removed... Checking router logs as i do not see any traffic from Vitality..
Thanks,
Brian
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
926
Reaction score
167
For Vitelity to work properly, you need an inbound and outbound definition. First, you need to know which server the DID is coming from. For example, my DID's come from inbound4.vitelity.net. Log into your Vitelity account and go to Support > FreePBX support and the examples actually show you how to set up your inbound and outbound trunks in FreePBX. On the inbound trunk side, it will show you which inbound server you need to register with.

You also need to know or set the format of the incoming DID number. In the voice number settings, you can set it to 1+did number or just the 10-digit number or whatever number you want it to send the PBX. Whatever is being sent must be matched with your inbound route for that number in FreePBX.

Here is what my FreePBX settings look like.

Outbound:
2393

Inbound
2394
 
Last edited:

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
926
Reaction score
167
One other thing: If you have multiple sub-accounts, make sure you have routed the DID to the correct sub-account that connects to your system.

2398
 
Last edited:

jerrm

Guru
Joined
Sep 23, 2015
Messages
505
Reaction score
209
Registration is not necessarily needed for Vitelity (we generally don't use registration with them) . Unclear how the @Brianmac is actually setup. A screen shot of the Vitelity routing page would clear things up.
 
  • Like
Reactions: billsimon

Brianmac

Member
Joined
Oct 7, 2014
Messages
206
Reaction score
20
Thanks for all the help(along with vitality support). I don't think its the PBX settings. I am not seeing any traffic hitting my router from vitality servers(not receiving, dropping, or rejecting any traffic).. Waiting to hear back from them
 

Brianmac

Member
Joined
Oct 7, 2014
Messages
206
Reaction score
20
Fixed, the PBX did NOT have a rule for Vitality in iptables(weird as this has been working...). Now incoming is working fine....
Thanks for the help!
Brian
 

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,319
Messages
137,021
Members
14,550
Latest member
treimers