TIPS The number you have dialled is not in service. GS Wave Android Client

yuljk

New Member
Joined
Apr 30, 2018
Messages
15
Reaction score
2
Hi guys - I’m unable to make any calls either to external numbers or FreePBX itself using the Android Grandstream Wave client. The client registers with FreePBX fine.

When calling any number I receive ‘the number you have dialled is not in service’

If I use the same extension on a desktop client (MicroSIP) I can place calls without issue.

/var/log/asterisk/full shows this at the time of placing the call.

[2019-03-22 16:35:39] WARNING[23328][C-00000045] Ext. s: “Rejecting unknown SIP connection from 192.168.5.181”

The IP address logged is the IP address of the PBX server and not the client oddly. Is the GS Wave re-writing the packets incorrectly?.

I’m using voipfone UK as my trunk. These are the settings provided by the SIP provider for FreePBX which I have.

host=sip.voipfone.net
username=someusername
secret=somesecret
qualify=yes
nat=yes
insecure=very
type=peer
fromuser=someuser
dtmfmode=rfc2833
disallow=all
allow=alaw
context=from-pstn
authuser=someuser

I also have ‘Allow SIP Guests’

It seems to be an issue with the GS Wave client - does anyone know what might be causing this?

Many thanks
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,008
Reaction score
205
I just loaded it on my Android phone and created a sip account on my PBX. It worked immediately on my internal network. I set the userid and authid both to the extension number I had created. One thing I noticed is that it selected a port ID outside the normal range. On the GS Wave app, I went to settings >Advanced Settings>Random Port and turned it off. Depending on your firewall settings, that may have been your problem.

You need to have a dynamic DNS client running on your phone to tell the PBX's ipchecker to accept the IP address of your phone when outside your local network. I just added my phone's external IP address and it now registers outside my local LAN as well.

Also, I don't think you want to enable Allow Sip Guests or you'll find your system overloaded with hackers.
 
Last edited:
  • Like
Reactions: wardmundy

yuljk

New Member
Joined
Apr 30, 2018
Messages
15
Reaction score
2
Thanks for the reply kenn10. I already have both userid and authid set to my extension number. I've just tried disabling 'random port' in advanced settings and I'm seeing the same issue in my asterisk log.

The phone is not connecting from outside my network. I have DHCP lease on my LAN, so that's unlikely to be the cause. What seems odd is that the IP logged when placing a call from my phone is the IP of the PBX itself, which makes zero sense.
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,008
Reaction score
205
When I set up my account on GS Wave, I did not select any of the commercial accounts. I set it up using Generic Accounts > SIP account. In the creation, I set the SIP account to my server address, SIP user ID to the extension I created, SIP Authentication ID to the extension, the Password to the password I set for the extensino, voicemail UserID to *97. I did not set anything in the Dialplan. Under SIP Port, I left 5060. I set Check Sip User ID for Incoming Invite to on. On Network Settings, I set Proxy-Require to my server address. Under Preferred Vocoder, I made sure to check PCMU under Wifi and 2G/3G/4G.

After all those settings, I simply clicked the check mark in the upper right to save the entries and the phone registered instantly and I can make and receive calls. At that point, enter an extension number on your system and press send. You should at least be able to call extension to extension. If you can dial an extension but not make an outside call, you need to look at your outbound routes and what that trunk is expecting.

If your phone is showing up on your router as the same IP address as your PBX, you may have IP conflicts or your DHCP server has issues. Perhaps your PBX IP address has not been reserved in your router and is being handed out to a client.

If all else fails, uninstall GS Wave from your phone including settings and cache and reinstall. Try setting up your SIP account again.

As a note, I'm running on IncrediblePBX 13-13-10 and I am not using PJSIP. Chan_SIP is much more trouble-free.
 
Last edited:
  • Like
Reactions: wardmundy

yuljk

New Member
Joined
Apr 30, 2018
Messages
15
Reaction score
2
Tried all of the settings you mentioned as well as clearing the DNS cache on the phone and re-installing the app. Phone registers fine as before and still get 'the number you have dialled is not in service' when attempting to call the voicemail number, other extensions or external numbers.

I definitely do not believe this is related to IP conflicts. There is no other device on my network with the same static IP address as my PBX. Besides, if this was the case none of the other clients would work - two other extensions using MicroSIP work perfectly as does Linphone on the same Android device.

I'm starting to wonder if this is an issue with LineageOS 16.0. I'm running the latest firmware, however this could well be a bug. I'm going to try another Android phone with the stock cell providers firmware and see if it also has the issue.
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,008
Reaction score
205
I'm running stock Android 8.1.0 on a Motorola G5 Plus unlocked phone. Perhaps LineageOS 16.0 is a little too bleeding edge for the app.
 
Last edited:
  • Like
Reactions: wardmundy

yuljk

New Member
Joined
Apr 30, 2018
Messages
15
Reaction score
2
The problem is now resolved. Turns out there was a bug in the Unofficial LineageOS 16 build I was running which caused an issue with the way SIP packets were written. I've performed a clean install of LineageOS 16 Official and I can now place and receive calls.
 
  • Like
Reactions: krzykat

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,444
Messages
137,972
Members
14,611
Latest member
rampageai