TIPS SMS with your Skyetel account: Postcards

Jacob Reider

New Member
Joined
Aug 5, 2018
Messages
5
Reaction score
1
Skyetel has quietly released a tool that interacts with their SMS API called Postcards.

Setup instructions here. I got it up and running in about 20 minutes on a Digital Ocean VM without much difficulty.

Testing this afternoon for a few hours ..

a) It works!
b) Good for desktop or laptop - but this won't really work as a messaging client on a phone.
c) Some latency. It seems to take a minute or two for the SMS to traverse ..
 
  • Like
Reactions: wardmundy

phinphan

Active Member
Joined
Oct 19, 2007
Messages
430
Reaction score
40
Jacob - I have tried this on several different vm's and docker will never start. What OS and version are you using and did you do anything special to get it going?
 

Skyetel

New Member
Joined
May 6, 2019
Messages
11
Reaction score
6
@phinphan make sure your host server has greater than 4GB of RAM. Postcards is really memory hungry.

We also recommend CentOS 7
 

Skyetel

New Member
Joined
May 6, 2019
Messages
11
Reaction score
6
Hi All,

We just released an update to Postcards that lets you easily rebrand it. Enjoy!
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,625
Reaction score
448
Location
South Florida
Hi All,

We just released an update to Postcards that lets you easily rebrand it. Enjoy!
Can you include a link to this product so others that aren't aware of it can have a look? Also - if you have a youtube demo - would be interested in seeing that as well.
 

phinphan

Active Member
Joined
Oct 19, 2007
Messages
430
Reaction score
40
Skyetel - I got a new VM with 4gb ram and it still fails to install on Centos 7. Here is the error log

[[email protected] postcards]# systemctl status docker.service
* docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; disabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Wed 2019-05-08 15:51:25 UTC; 2min 8s ago
Docs: https://docs.docker.com
Process: 1250 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 1250 (code=exited, status=1/FAILURE)

May 08 15:51:23 Jltpa systemd[1]: Failed to start Docker Application Container Engine.
May 08 15:51:23 Jltpa systemd[1]: Unit docker.service entered failed state.
May 08 15:51:23 Jltpa systemd[1]: docker.service failed.
May 08 15:51:25 Jltpa systemd[1]: docker.service holdoff time over, scheduling restart.
May 08 15:51:25 Jltpa systemd[1]: Stopped Docker Application Container Engine.
May 08 15:51:25 Jltpa systemd[1]: start request repeated too quickly for docker.service
May 08 15:51:25 Jltpa systemd[1]: Failed to start Docker Application Container Engine.
May 08 15:51:25 Jltpa systemd[1]: Unit docker.service entered failed state.
May 08 15:51:25 Jltpa systemd[1]: docker.service failed.

prior to running the install I did yum -y update and that is it.
 

Skyetel

New Member
Joined
May 6, 2019
Messages
11
Reaction score
6
@phinphan For the sake of testing, would you please try spinning up a Digital Ocean droplet with CentOS 7 and see if it works there? There may be something in the kernel of the image you are using, or something configured by the host that prevents virtualization.
 

Skyetel

New Member
Joined
May 6, 2019
Messages
11
Reaction score
6
I am afraid I'm not able to duplicate the error you are having. I just installed Postcards on a fresh CentOS 7 server on Digital Ocean:
(note I shortened this with ... in the code)

Code:
[[email protected] ~]$ sudo su -
[[email protected] ~]# mkdir -p /opt/postcards
[[email protected] ~]# curl https://bitbucket.org/skyetel/postcards-installer/get/master.tar.gz | tar xvz --strip 1 -C /opt/postcards
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0skyetel-postcards-installer-44eb7ed9dc3c/.gitignore
skyetel-postcards-installer-44eb7ed9dc3c/Dockerfile
skyetel-postcards-installer-44eb7ed9dc3c/LICENSE.md
skyetel-postcards-installer-44eb7ed9dc3c/README.md
skyetel-postcards-installer-44eb7ed9dc3c/config-check.env
skyetel-postcards-installer-44eb7ed9dc3c/database.sql
skyetel-postcards-installer-44eb7ed9dc3c/docker-compose.debug.yml
skyetel-postcards-installer-44eb7ed9dc3c/docker-compose.override.yml
skyetel-postcards-installer-44eb7ed9dc3c/docker-compose.yml
skyetel-postcards-installer-44eb7ed9dc3c/docs/
skyetel-postcards-installer-44eb7ed9dc3c/docs/postcards-example1.png
100  182k  100  182k    0     0   258k      0 --:--:-- --:--:-- --:--:--  258k
skyetel-postcards-installer-44eb7ed9dc3c/run.sh
[[email protected] ~]# cd /opt/postcards
[[email protected] postcards]# ./run.sh
The command 'wget' is required for this aplication
[[email protected] postcards]# yum install wget -y

....                                                                                                                             1/1

Installed:
  wget.x86_64 0:1.14-18.el7                                                                                                                                            

[[email protected] postcards]# ./run.sh
2019-05-08 18:47:55 URL:https://get.docker.com/ [13063/13063] -> "-" [1]
# Executing docker install script, commit: 2f4ae48
+ sh -c 'yum install -y -q yum-utils'
Package yum-utils-1.1.31-50.el7.noarch already installed and latest version
+ sh -c 'yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo'
Loaded plugins: fastestmirror
adding repo from: https://download.docker.com/linux/centos/docker-ce.repo
grabbing file https://download.docker.com/linux/centos/docker-ce.repo to /etc/yum.repos.d/docker-ce.repo
repo saved to /etc/yum.repos.d/docker-ce.repo
+ '[' stable '!=' stable ']'


.....
 

phinphan

Active Member
Joined
Oct 19, 2007
Messages
430
Reaction score
40
Kind of bizarre. I just opened a new DO droplet with 4gb ram and I had the issue I described. i will wipe and try again.

Solved the problem by expanding the putty window of all things. Apparently it was creating extra space / new line that messed it up.
 
Last edited:

Skyetel

New Member
Joined
May 6, 2019
Messages
11
Reaction score
6
Are you copying and pasting? or are you typing it out manually? Perhaps there's a rouge character being copied?
 

phinphan

Active Member
Joined
Oct 19, 2007
Messages
430
Reaction score
40
I finally got postcards to work (mostly). There are certificate and https errors that prevent using the site via https and it has yet to send or receive an sms or mms message but the webpage is running.
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,625
Reaction score
448
Location
South Florida
I've got postcards loaded up and running, however I'm having issues with Send/Receive that I'm 95% sure is a Skyetel issue. Does anyone know if after you grab a DID from them that the SMS is enabled or must you wait? I've sent in a ticket yesterday, but as of now ... no reply.
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,625
Reaction score
448
Location
South Florida
Postcards working fine ... Now to have fun and hack around with it. Wonder how hard it is to take it outside docker so I can play easier.
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,625
Reaction score
448
Location
South Florida
Is anyone having issues with their Postcards app or is it still working properly? I THINK that it is broke from Let'sEncrypt Acme Level 1.
Can anyone confirm or deny my claim on their setup?
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,581
Messages
138,982
Members
14,676
Latest member
BluePeter