NEED MORE INFO Skyetel - Outbound works, inbound doesn’t hit Asterisk

deputyrover

New Member
Joined
Jan 30, 2018
Messages
6
Reaction score
0
Hello,

I have Incredible PBX 13-13 on Ubuntu 18.04 set up on my box. I installed Skyetel trunks and set up inbound and outbound routes exactly to Ward Mundy’s specifications on his guide. The endpoint is set up on Skyetel’s side.

I can make outbound calls — works great. But I can’t make calls to my phone number. The call does not even appear to hit Asterisk. I get the generic Skyetel error. I’ve tried restarting the box, restarting Asterisk, deleting the routes and re-adding them, etc. the issue persists.

Using netstat to check ports, Asterisk does not show as listening on 5060. However I’m not sure if this is a problem or not. And I have tried disabling iptables which did not make a difference.

What steps can I take to resolve this problem? FWIW, I actually had this exact same setup working a week ago, and I did nothing special except following the Nerd Vittles tutorial, under an older install, but of course I decided it was time for a fresh install... now I’m stuck with this mess.

Thanks!
 
Last edited:

deputyrover

New Member
Joined
Jan 30, 2018
Messages
6
Reaction score
0
Update: So I actually did get this working, it was assigned the wrong IP address internally and I did not realize. However it stopped working a few days ago after a short internet outage. Now I cannot receive calls once again. Does anyone have any suggestions? Nothing else has changed.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,415
Reaction score
2,736
Does your server have a public dynamic IP address? Has it changed? Have you modified the address on the Skyetel side? Have you whitelisted ALL of the Skyetel IP addresses on your new server?
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,571
Messages
138,925
Members
14,674
Latest member
gnordli