FOOD FOR THOUGHT Should I upgrade my RentPBX or leave well enough alone?

Joined
Sep 29, 2014
Messages
259
Reaction score
13
Location
Montreal
Hello:
I have a RentPBX Incredible PBX 12.0.70 which has been working perfectly since 03/02/2016.
Is there any reason why I should upgrade to PBX in a Flash Incredible PBX 13-12 with Incredible GUI (Centos 6.6)?
Thanks,
Rob.
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,513
Reaction score
401
Location
South Florida
Why do you want to upgrade? If it does everything you want with no issues, then I see no reason. If there is something you can/want to do in the new version, then look at it.
 
  • Like
Reactions: randy7376

billsimon

Experienced in Asterisk, FreePBX, and SIP
Joined
Jan 2, 2011
Messages
947
Reaction score
294
Is there any reason why I should upgrade to PBX in a Flash Incredible PBX 13-12 with Incredible GUI (Centos 6.6)?
"Upgrading" at this point to CentOS 6 is like upgrading your 1992 Honda Civic to a 2002 model. You could do it but you would still have an outdated car. (FWIW, cars age a lot better than operating systems.)

It is already many versions behind on packaged software and major version 6 will be end-of-lifed in 2020.
 

Eliad

Member
Joined
Aug 13, 2017
Messages
166
Reaction score
23
As far as I understand Rentpbx uses 32 bit version Centos 6 and current Incrediblepbx is 64 bit only. Also, current Incrediblepbx stable version is still Centos 6.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,079
Reaction score
2,601
Incredible PBX 13-13.10 supports BOTH CentOS 6 and 7.
 
Joined
Sep 29, 2014
Messages
259
Reaction score
13
Location
Montreal
"Upgrading" at this point to CentOS 6 is like upgrading your 1992 Honda Civic to a 2002 model. You could do it but you would still have an outdated car. (FWIW, cars age a lot better than operating systems.)

It is already many versions behind on packaged software and major version 6 will be end-of-lifed in 2020.
Thanks, Bill. :)

I read somewhere that the later versions of Incredible are not all that stable - I think above 13-13. Also, there seems to be issues with non-CentOS systems, like Ubuntu.

I guess that if I don't *** NEED *** to do any upgrading, I'll just sit tight. If I need to change, I guess I'll pick one of RentPBX's offerings.
 

Attachments

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,079
Reaction score
2,601
I read somewhere that the later versions of Incredible are not all that stable - I think above 13-13. Also, there seems to be issues with non-CentOS systems, like Ubuntu.
13-13 is the latest and 13-13.10 for CentOS has zero reported issues that we're aware of. New issues with Ubuntu 18.04 popped up last week. But, after testing, it turns out there was nothing wrong with the Ubuntu build either.
 
Last edited:

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,319
Messages
137,010
Members
14,549
Latest member
mawa1213