PIONEERS RasPi 16-15 NOW

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
@Larry Marshall: Set the GUI password for the admin account by running /root/admin-pw-change. Then use your browser to login as admin with the new password you just set.
 

hawk#1

Member
Joined
Nov 3, 2015
Messages
83
Reaction score
29
I like your determination on this project, and hope to have some time in a couple days to give it a workout.
 
  • Like
Reactions: wardmundy

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
A couple more fixes that we'll add to 16-15.1.5 next week...

32GB SD cards apparently trigger a "too small swap file" warning in FreePBX. Fix is here: http://nerdvittles.com/?p=30403#comment-178713

If you experience one-way audio on external calls, be sure to set NAT=YES for affected extensions. We will set this as the default in release 5.
 

Aaron Outhier

Member
Joined
Dec 11, 2016
Messages
42
Reaction score
6
A couple more fixes that we'll add to 16-15.1.5 next week...

32GB SD cards apparently trigger a "too small swap file" warning in FreePBX. Fix is here: http://nerdvittles.com/?p=30403#comment-178713

If you experience one-way audio on external calls, be sure to set NAT=YES for affected extensions. We will set this as the default in release 5.
Odd, I’m using a 32 GB card, and am not having such issues.
 

Aaron Outhier

Member
Joined
Dec 11, 2016
Messages
42
Reaction score
6
Also, for me knockd was failing to startup. Upon investigation, I found it was trying to listen on eth0, but I was using wlan0 only. I have it working now.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
Release 5 is now available, but SourceForge is (no longer) having issues with uploads.

To eliminate one-way audio issues, it sets all of the extensions to NAT=yes. It also doubles the size of the swapfile (now 512MB).
 
Last edited:

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
If you'd like the Blinkt rainbow light show whenever a non-blacklisted incoming call arrives, here's the code to do it. Demo video below doesn't do it justice.
Code:
cp -p /root/rainbow.py /usr/local/sbin/.
echo "asterisk ALL = NOPASSWD: /usr/local/sbin/rainbow.py" >> /etc/sudoers
echo '[app-blacklist-check]
include => app-blacklist-check-custom
exten => s,1(check),GotoIf($["${BLACKLIST()}"="1"]?blacklisted)
exten => s,n,Set(CALLED_BLACKLIST=1)
exten => s,n,System(/usr/bin/sudo /usr/local/sbin/rainbow.py &)
exten => s,n,Return()
exten => s,n(blacklisted),Answer
exten => s,n,Set(BLDEST=${DB(blacklist/dest)})
exten => s,n,ExecIf($["${BLDEST}"=""]?Set(BLDEST=app-blackhole,hangup,1))
exten => s,n,GotoIf($["${returnhere}"="1"]?returnto)
exten => s,n,GotoIf(${LEN(${BLDEST})}?${BLDEST}:app-blackhole,zapateller,1)
exten => s,n(returnto),Return()

;--== end of [app-blacklist-check] ==--;

' >> /etc/asterisk/extensions_override_freepbx.conf
asterisk -rx "dialplan reload"
 
Last edited:

hawk#1

Member
Joined
Nov 3, 2015
Messages
83
Reaction score
29
I have installed the 5th release on a new pi 4 and am not able to get ssh working on it. I checked the md5 and verified the download is correct. I have tried re-installing it numerous times with the same issue each time. During the install process the screen displays that the 3 ssh keys are being generated, and then the screen displays rescue-ssh.target is a disabled or a static unit, not starting it. I'm currently downloading the first release to install it and see if ssh works on it. I will post the results once I have installed it. I'm open to suggestions if someone has some ideas that may be causing the ssh failure.
 

hawk#1

Member
Joined
Nov 3, 2015
Messages
83
Reaction score
29
I tried some of the previous releases to see if SSH worked on the and it still does not, so I will iinstall a clean version of Rasbian 10 and check on ssh. Will post results later.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
Is your RasPi on a private network? Are you completing the second phase of the install from a desktop PC on the same network? What are the IP addresses? Sounds like a network failure to me.
 

hawk#1

Member
Joined
Nov 3, 2015
Messages
83
Reaction score
29
Hi Ward,
Yes, the raspi is on a private network and the pc is on the same network. The raspi local ip is 192.168.0.106 and the pc local ip is 192.168.0.126, and is able to ping raspi without any problem. I am able to use the pc to ssh other pc's, but can't even get ssh enabled on the raspi-config menu, so needless to say I can't even get to the second phase of install. Since my last post, I downloaded raspbian 10 Buster from raspberrypi.org and installed it on the raspi. I am able to enable ssh on the raspi-config and also can use my pc to ssh to the raspi on the same network as earlier. I guess I need to find out what network files are different on the working raspbian and the non working raspbian. If I come up with anything, I'll post an update here. Thanks for your suggestion.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
@hawk#1 You shouldn't have to enable SSH at all in raspi-config. Just expand the disk and do nothing else in raspi-config and see how it goes. Phase I install gets SSH properly configured without user intervention.
 

hawk#1

Member
Joined
Nov 3, 2015
Messages
83
Reaction score
29
Thanks for the updated info, I had read someplace that ssh needed to be turned on in raspi-config. Okay, I'll give it a try with a fresh SD card. Will post the results in a few minutes.
 
  • Like
Reactions: wardmundy

hawk#1

Member
Joined
Nov 3, 2015
Messages
83
Reaction score
29
@wardmundy Sorry it took so long for me to post the results. I thank you for your time and help in resolving my problem.
Earlier when I installed the complete Buster, I found that I could ssh in to the pi, so I started comparing the differences and found that the sd card with Incredible PBX was missing the moduli file. So I copied it over from the Buster sd card. That got ssh working. Then when you told me that I did't need to enable ssh from the raspi-config I started with a new sd-card and I found out that on the initial phase one install, the screen displays the log-in prompt and the cursor stays there like it is waiting for log-in. Don't try to log in or ssh in at this point because phase one has not finished installing. Let it sit there and eventually it will finish with phase one install and then display the log-in prompt again. At the second log-in prompt, it is safe to ssh in and finish the rest of the install. Ignore the first Log-in prompt is how to solve the issue.
 
  • Like
Reactions: wardmundy

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,137
Reaction score
2,627
@hawk#1: When you expand your SD card using the option in raspi-config, there will be a choice when you exit the utility to REBOOT YOUR SERVER. Choose YES and you'll avoid the extra steps you've mentioned above. Once the RasPi reboots, login with SSH from your desktop PC and the Phase 2 install will complete the setup.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,367
Messages
137,355
Members
14,575
Latest member
Issue