1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TIPS Raspberry Pi Network Issues

Discussion in 'PIAF 3 Add-On Install Instructions' started by wardmundy, Feb 28, 2016.

  1. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    13,819
    Likes Received:
    2,293
    Just reran the RasPi 3 image through its paces (including new Incredible Fax install) to be sure nothing has come unglued.

    Status: Nothing has come unglued

    [​IMG]

    [​IMG]
     
  2. qtlnx

    qtlnx Member

    Joined:
    Mar 9, 2016
    Messages:
    68
    Likes Received:
    2
    Does incredible PBX (on any platform) support a TAPI USB adapter?
    Intended purpose is an IVR system connected to an incoming analog telephone line.
    So far I only seen asterisk supported PCI telephony boards from Digium.
     
  3. foxglove

    foxglove New Member

    Joined:
    Jun 28, 2016
    Messages:
    9
    Likes Received:
    1
    I've installed the image into my new Raspberry Pi 3 and am having an issue with the lan port seeing the internet. eth0 is assigned an IP by DHCP and is accessible via SSH, but Pi doesn't see a public IP at all and has no internet connectivity at all. Nothing on the router side is blocking it, I don't think. When I installed Raspberian 8 on the Pi3 internet connectivity was immediate through eth0.

    I cannot figure it out for anything. Any ideas?

    [​IMG]

    ip addr results:
    Code:
    root@raspberrypi:~ $ ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether b8:27:eb:b6:1b:48 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.141/24 brd 192.168.1.255 scope global eth0
           valid_lft forever preferred_lft forever
        inet6 fe80::45fb:bac0:178a:1c05/64 scope link
           valid_lft forever preferred_lft forever
    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether b8:27:eb:e3:4e:1d brd ff:ff:ff:ff:ff:ff
        inet 172.20.20.20/24 brd 172.20.20.255 scope global wlan0
           valid_lft forever preferred_lft forever
        inet6 fe80::ba27:ebff:fee3:4e1d/64 scope link
           valid_lft forever preferred_lft forever
    WARNING: Always run Incredible PBX VM behind a secure hardware-based firewall.
    IP route:
    Code:
    root@raspberrypi:~ $ ip route
    default via 172.20.20.1 dev wlan0
    default via 192.168.1.1 dev eth0  metric 202
    default via 172.20.20.1 dev wlan0  metric 303
    172.20.20.0/24 dev wlan0  proto kernel  scope link  src 172.20.20.20  metric 303
    192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.141  metric 202
    WARNING: Always run Incredible PBX VM behind a secure hardware-based firewall.
    I almost wonder if it isn't trying to use the wlan0 or something to connect and not being able to? No idea.

    Thank you!
    foxglove
     
  4. dav3m

    dav3m New Member

    Joined:
    Jun 18, 2016
    Messages:
    2
    Likes Received:
    3
    I had the same problem a few weeks back, had me scratching my head and chasing firewall rules... Just turn down the wlan0 interface with "ifconfig wlan0 down" to test it out and then everything should work fine - it did for me.

    If that works change it from auto to manual in /etc/network/interfaces - assuming you don't need it.
     
    RoboLord, foxglove and wardmundy like this.
  5. foxglove

    foxglove New Member

    Joined:
    Jun 28, 2016
    Messages:
    9
    Likes Received:
    1
    Thanks for the advice. I'm going to try this out over the weekend and see. I have since scrapped that box and put it back into raspberrian8 land, but I have another rpi3 coming today and I'll try it out. Overall I am really liking the pi3! Glad PIAF is on it!
     
  6. ostridge

    ostridge Guru

    Joined:
    Jan 22, 2015
    Messages:
    293
    Likes Received:
    54
    Does the following code show a 'default via' [gatewayIP] (where gateway example here is at 254 and src points to a pi server at 64)
    Code:
    root@pi3:~# ip route
    default via 192.168.1.254 dev eth0  metric 202
    192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.64  metric 202
    Also the below routing table showing 254 as Up Gateway eth0
    and lan 192.168.1.0 as Up also eth0
    Code:
    root@pi3:~# route -n
    Kernel IP routing table
    Destination  Gateway  Genmask  Flags Metric Ref  Use Iface
    0.0.0.0  192.168.1.254  0.0.0.0  UG  202  0  0 eth0
    192.168.1.0  0.0.0.0  255.255.255.0  U  202  0  0 eth0
     
    #106 ostridge, Jul 2, 2016
    Last edited: Jul 2, 2016
  7. foxglove

    foxglove New Member

    Joined:
    Jun 28, 2016
    Messages:
    9
    Likes Received:
    1
    Thank you very much! I finally tried this and it worked immediately. Turning the wifi port off immediately allowed the system (which has eth0 plugged into the LAN) to see it was connected to the internet.

    quick note on the auto -> manual change in interfaces - I didn't see it marked as auto in there, so I entered it as manual myself.

    thanks!
     
    wardmundy likes this.
  8. matteos1

    matteos1 New Member

    Joined:
    Jul 18, 2016
    Messages:
    1
    Likes Received:
    1
    hi,there is a installation script of
    Incredible PBX for Raspbian Jessie in one existent intallation of raspbian jessie? thank a lot
     
    wardmundy likes this.
  9. miguel

    miguel Member

    Joined:
    May 22, 2013
    Messages:
    275
    Likes Received:
    8
    Hi ward happy new year! by the way to login without a usb keyboard? I thought I had one but I dont anymore, is there a way to do this via ssh?
     
  10. RSDunn

    RSDunn New Member

    Joined:
    Aug 4, 2013
    Messages:
    4
    Likes Received:
    1
    Here are the steps to modify SendMail to use an existing Gmail account as a SmartHost. Log into your RasPi as root and issue the following commands:
    Code section:
    echo AuthInfo:smtp.gmail.com \"U:smmsp\" \"I:user_id\" \"P:password\" \"M:pLAIN\" > client-info
    echo AuthInfo:smtp.gmail.com:587 \"U:smmsp\" \"I:user_id\" \"P:password\" \"M:pLAIN\" >> client-info
    echo AuthInfo:smtp.gmail.com:465 \"U:smmsp\" \"I:user_id\" \"P:password\" \"M:pLAIN\" >> client-info
    nano -w client-info


    since smtp.gmail.com is an CNAME alias the auth never occurs since there's no match for the return smtp server...

    using nslookup on smtp.gmail.com
    smtp.gmail.com is a canonical name for gmail-smtp-msa.l.google.com

    I couldn't get sendmail to ever auth to google and ended up installing Exim4 as people provided the fix.
    http://pkg-exim4.alioth.debian.org/README/exim4-config_files.5.html#/etc/exim4/passwd.client

    above link provides the details of why you must know the proper DNS name of the smtp forwarder to allow the auth to occur.

    If SendMail has the same ability to use a wildcard like exim then a client-info sendmail change might look like
    echo AuthInfo:*.google.com \"U:smmsp\" \"I:user_id\" \"P:password\" \"M:pLAIN\" > client-info

    Hope this helps other get the Gmail SMARTHOST working with TLS SMARTTLS in sendmail
     
  11. RSDunn

    RSDunn New Member

    Joined:
    Aug 4, 2013
    Messages:
    4
    Likes Received:
    1
    wardmundy likes this.
  12. jerrm

    jerrm Guru

    Joined:
    Sep 23, 2015
    Messages:
    321
    Likes Received:
    107
    I prefer fs2ram out of debian(raspbian) packages. Slightly different approach, but has been solid for us.
     
  13. RSDunn

    RSDunn New Member

    Joined:
    Aug 4, 2013
    Messages:
    4
    Likes Received:
    1
    fs2ram ... sounds good. I searched the forums before I posted anything... How come nobody has brought this or any other sdcard thrashing solution(s) to the table before my addition? IMHO seems to be the right place to offer up these helpful ideas for all ...
     
  14. jerrm

    jerrm Guru

    Joined:
    Sep 23, 2015
    Messages:
    321
    Likes Received:
    107
    It has been discussed several times.

    Forum conversations often are not search friendly.
     
    wardmundy likes this.
  15. rlust@mac.com

    rlust@mac.com Member

    Joined:
    Feb 17, 2009
    Messages:
    35
    Likes Received:
    0
    I have the latest Rasp pi release up and running, but some activity causes error
    I am getting the following error and it is stopping Asterisk

    *** Error in `/usr/sbin/asterisk': corrupted double-linked list: 0x019ac730 ***

    If I do a Amportal Restart it comes backup.
    Any ideas?
     
  16. TirsoJRP

    TirsoJRP Member

    Joined:
    Jan 8, 2015
    Messages:
    72
    Likes Received:
    25
    Same here, I thought it was because of all the playing I have been doing with mine.

    Does it happen when you apply settings in FreePBX? Is it asterisk_safe running after you execute amportal restart?
     
  17. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    13,819
    Likes Received:
    2,293
    What are you doing and what does the Asterisk CLI show when this occurs??
     
  18. dallas

    dallas Member

    Joined:
    Oct 21, 2007
    Messages:
    152
    Likes Received:
    12
    I have just installed the latest Incredible for Rasbian Jessie (15 Sept) and I have a question about disabling some components.
    1. I would like to disable Chan-SCCP as I don't have any Cisco phones.
    2. As I am outside the USA I would also like to disable GV OAUTH.

    Can they be turned off in the Incredible GUI?
     
  19. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    13,819
    Likes Received:
    2,293
    Not in the GUI, but you can disable them in /etc/asterisk/modules.conf.
     
  20. dallas

    dallas Member

    Joined:
    Oct 21, 2007
    Messages:
    152
    Likes Received:
    12
    I managed to disable chan_sccp yesterday and while testing I found that the pbxstatus still showed the module as UP.
    I have found an error in the pbxstatus script.
    The following code will always take the else path and show sccp as up because grep will return either 1 or 0. The -z $test will always fail.
    test=`asterisk -rx "module show like sccp" | grep -c Running`
    if [[ -z $test ]]; then
    sccp="$DN"
    else
    sccp="$UP"
    fi

    This code is also used for these services. apache2, webmin, ssh. Fortunately the fix is easy. just remove the -c argument passed to grep.

    I haven't yet figured out how to stop gvoauth and the test for it in pbxstatus just looks for the Incredible version.
    test=`cat /etc/pbx/.version`
    if [[ "$test" < "13-12.17" ]];
     

Share This Page