SOLVED Problem Sending Fax

kdthomas

Member
Joined
May 13, 2016
Messages
57
Reaction score
11
Latest build of Incredible 13-13 (Full) on CentoOS 7. I was able to get past the first error trying to send a fax from the AvantFax GUI. This involved modifying the host file for hylafax (localhost / 127.0.0.1 to the top). Now I'm getting this message when I attach a file (TXT) and try to use a cover page (Generic Letter). If I select no cover page, the fax goes out. It would be nice to have a cover page though

Problem sending the fax.
sendfax: Error creating cover sheet; command was "/var/www/html/avantfax/includes/faxcover.php -C '/var/www/html/avantfax/images/coverpage.html' -c 'Hello World' -f 'email' -n '5555551212' -s 'default' -t 'Ken Thomas' -x 'BUSINESS' -N '555-555-1213' -V '555-555-1214' -M '[email protected]' -p '1'"; exit status ff00


On another note, when the fax goes out the received fax has the header "IncredibleFax" up top. Any way to change this?

Update: Choosing either PDF/TXT as the attachment and using the HTML Cover Page seems to go out fine. I guess I can live with that.
 
Last edited:

dicko

Still learning but earning
Joined
Oct 30, 2015
Messages
667
Reaction score
248
You can fix the first problem by editing includes/config.php and adding -c to the arguments to faxadduser
 

dicko

Still learning but earning
Joined
Oct 30, 2015
Messages
667
Reaction score
248
full instructions :-

edit includes/config.php and add -c to the arguments to faxadduser
 

mainenotarynet

Not really a Guru - Just a long time user
Joined
May 29, 2010
Messages
608
Reaction score
78
Location
Bangor, ME USA
I think he means:

Open either SSH as root -- or -- winscp to your server (winSCP or similar program is easier for what you need to do here)
SSH method is harder but doable (you'll probably need the ssh after anyways)

cd /var/www/html/avantfax/includes/
nano config.php
go down to line 400 (on mine anyways) or find the line that reads:

$FAXADDUSER = $HYLAFAX_PREFIX.DIRECTORY_SEPARATOR.'sbin'.DIRECTORY_SEPARATOR.'faxadduser';

and make it look lie this:

$FAXADDUSER = $HYLAFAX_PREFIX.DIRECTORY_SEPARATOR.'sbin'.DIRECTORY_SEPARATOR.'faxadduser -c';
(according to Dicko, its the only line I found with faxadduser anywhere)

Save the file if in ssh and you used nano to do this -- [ctrl]+x Y [Enter] will put you back at command line

now do (depending on Incredible version:
amportal restart (newer ones use the next line but this will be redirected to it)

fwconsole restart

Not sure if it would matter but a

service httpd restart

wouldn't hurt either - the only reason I am not sure is how often is the config file read when using avantfax and it IS php which I believe needs the apache restarted to have changes to these take effect (again on this I am not sure but it can't hurt to do it)

WinSCP is a windows FTP/SCP client if you have Mac or other llinux , find a similat and use that - it makes navigation and editing easier and it can open ssh for you as well.

Hope this helps for what you needed.


 
  • Like
Reactions: dhoppy and ostridge

PatPend

New Member
Joined
Jan 15, 2016
Messages
25
Reaction score
3
full instructions :-

edit includes/config.php and add -c to the arguments to faxadduser
I'm finishing up an install from IncrediblePBX13-13.iso (see http://nerdvittles.com/?p=24444) which has this issue...

So I made the -c change to faxadduser line in config.php (also at line 400), but now nothing gets added to hosts.hfaxd (neither at the top or bottom) when you add a fax user. Remove the -c and the user gets added at the top again.

If I do a $ man faxadduser, it does show the -c option is available.

Possibly a bug in faxadduser in this version?
 

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
PatPend,

The fix is to swap a pair of lines in rc.local per this thread: https://pbxinaflash.com/community/threads/making-avantfax-cover-page.6997/page-2#post-137319

The directions read:
/etc/rc.d/rc.local

needs to have two lines of code changed because they happen out of order. Default is:

touch /var/lock/subsys/local
sleep 5
/root/sig-fix
sleep 5
/usr/local/sbin/iptables-restart
sleep 5
/usr/local/sbin/fwconsole start
sleep 10
$(which faxgetty) -D ttyIAX0
$(which faxgetty) -D ttyIAX1
$(which faxgetty) -D ttyIAX2
$(which faxgetty) -D ttyIAX3
exit 0
Should be changed to:

touch /var/lock/subsys/local
sleep 5
/root/sig-fix
sleep 5
/usr/local/sbin/fwconsole start
sleep 5
/usr/local/sbin/iptables-restart
sleep 10
$(which faxgetty) -D ttyIAX0
$(which faxgetty) -D ttyIAX1
$(which faxgetty) -D ttyIAX2
$(which faxgetty) -D ttyIAX3
exit 0
Then roboot!


It worked for me.


Andrew
 

PatPend

New Member
Joined
Jan 15, 2016
Messages
25
Reaction score
3
That fixed the issue where sent & received faxes weren't getting saved in archive/inbox, but not the issue with adding faxusers then having to manually edit hosts.hfaxd to move the new user from the top of the file to the bottom.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,450
Messages
138,039
Members
14,613
Latest member
roshan2019