SOLVED Phone Rings once every hour - no caller.

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
650
Reaction score
86
Each hour, my phone(s) rings once. I believe the phone is registering, but I could be wrong.
The phone is an analog phone attached to a Sipura ATA.

My Yealink also chirps, but it isn't a full on ring.

Is there a setting on the ATA or in PBX Green to stop this action?

Andrew
 

tbrummell

Guru
Joined
Jan 8, 2011
Messages
667
Reaction score
80
Location
Ottawa, Canada
Depends where it is coming from. Do you see a call in CDR from your provider, or IPBX, or both? Do you get CID with the call? Is it always the same? IPBX is hosted internally, cloud? NAT firewall in place, ports forwarded somewhere? Need a lot more information to triage this.
 
  • Like
Reactions: ostridge

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
650
Reaction score
86
I have my PIAF Green machine running locally.
The calls do not show up in the CDR nor in the cli
It's as if (I'm guessing) that the phone is re-registering or getting 'pinged' by the PBX and the ATA causes the phone to ring.

It's a completely internal event.

The ATA is a Sipura 2002 with two phones hanging off of it as extensions.

Both lines are fed into a Panasonic two line cordless phone. LIne 1 registers using port 5061 and Line 2 registers using port 5060. It appears that Line 1 is the one ringing (says so on the phone).

I've changed the device to use port 5060 for both. Others on the board have said that I need a different port for each, but it seems to work. I'll see if it changes the ringing.

I've thought about running debug on that extension (peer) and seeing if there is any traffic shown at the time when the phone rings. I guess that will be next.


Andrew
 

KNERD

Active Member
Joined
Mar 9, 2014
Messages
121
Reaction score
26
It's what as known as a "ghost call."

Many SIP devices will allow anonymous SIP calls to come in. I am not sure about that device, but there should be a setting for accepting calls only from authorized SIP server,
 

dicko

Still learning but earning
Joined
Oct 30, 2015
Messages
675
Reaction score
251
Simple solution, just don't use port 5060.
Better solution, only allow known hosts through your firewall.

The Sipura does need separate ports or the line that rings for an incoming call will be the one that last registered with your pbx.
 
  • Like
Reactions: tbrummell

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
650
Reaction score
86
dicko,

Oddly, 5060 for both works. If I call from another extension to either line, it rings/works. If I call to the other line on the Sipura, it works too.
This is no change from when I used 5060 for one and 5061 for the other. Both extensions show as registered

My firewall is set using TM3. These 'calls' don't originate from outside (or seemingly anywhere). There is no call/activity in the asterisk cli.

Weird. And, since it rings out in the middle of the night, really annoying.

Andrew
 

dicko

Still learning but earning
Joined
Oct 30, 2015
Messages
675
Reaction score
251
They ARE likely coming through your firewall from outside, and they ARE likely coming on UDP port 5060, just watch sngrep on a machine inside your LAN, you will see them arrive and where they are coming from, If you have extensions like 100 , 101 , 1000 etc they will often be "INVITES" which will be responded to depending on the phone and never go anywhere near your PBX, chirps, rings or nothing if ythe phone is clever enough.
 

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
650
Reaction score
86
So, it appears to be ringing via a REGISTER notification from the PBX per sngrep.

Any idea how to turn off this behavior in the SPA-2002? I have firmware 3.1.2(a) and no idea how to find anything (which does exist) newer.

Andrew
 
  • Like
Reactions: KNERD

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
650
Reaction score
86
Never figured out how to stop the ring.

I'm trying to get the 'new' 16-15 system working. Still a remote user issue, but at least the Sipura doesn't ring the phone every hour.
My friend can't talk or hear through his extension, but at least I can sleep.

Andrew
 

ostridge

Guru
Joined
Jan 22, 2015
Messages
396
Reaction score
71
Location
UK
I do not have a SPA2002 but use a PAP2T NA unlocked and on 192.168.1.100 Sip ports 49160, 49260
I understand the 2002 is similar.

I assume both pbx and sipura2002 are both on same private network like
192.168.1.xx and both at the 'friend' premises?

As the ATA will have one IP address for both lines the ports do need to differ if both lines are to be used.

On the ATA Line tab you have:
NAT Mapping set to No NAT keep alive set to No

Just try different 'sip ports' on the ATA say line1: sip port 5160 and line2: 5260, or a high port series say 49160 and 49260.

The following Admin guide if apropriate? 2102 should be similar but has onboard router.
SPA ATA Admin Guide
 
Last edited:

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
650
Reaction score
86
It's really two separate problems.

On my PBX Green (old), my friend's Yealink connects perfectly from across the country. The Sipura, using either different or the same ports for the two lines, rings one of the phones every hour.

On the 16-15 system (new), the Sipura behaves correctly. The Yealink has no audio in either directions - it registers and picks up, but no audio.

My router forwards ports to either the old system (with the new turned off) or to the new (with the old turned off). The port forwards read identically but for destination IP and only one set is active at a time.

It *seems* like it should be a firewall issue, but the commands read identically except for the final IP (192.168.40.29 (old) vs 192.168.40.60 (new)).

Weird.

Andrew
 

ostridge

Guru
Joined
Jan 22, 2015
Messages
396
Reaction score
71
Location
UK
If you turn off one line (at a time) on ATA then it maybe stops the ring or chirp?
 

dallas

Active Member
Joined
Oct 21, 2007
Messages
226
Reaction score
33
Location
Sydney, Australia
It's really two separate problems.

On my PBX Green (old), my friend's Yealink connects perfectly from across the country. The Sipura, using either different or the same ports for the two lines, rings one of the phones every hour.

On the 16-15 system (new), the Sipura behaves correctly. The Yealink has no audio in either directions - it registers and picks up, but no audio.

My router forwards ports to either the old system (with the new turned off) or to the new (with the old turned off). The port forwards read identically but for destination IP and only one set is active at a time.

It *seems* like it should be a firewall issue, but the commands read identically except for the final IP (192.168.40.29 (old) vs 192.168.40.60 (new)).

Weird.

Andrew
Andrew, did you see my reply to your other thread?
 

ostridge

Guru
Joined
Jan 22, 2015
Messages
396
Reaction score
71
Location
UK
The Sipura, using either different or the same ports for the two lines, rings one of the phones every hour.
The default star codes (on the 'REGIONAL' tab) to block anonymous calls on the SPA ATA may reduce the spurious calls, but also blocks legitimate withheld numbers from your doctor, the hospital, police etc.

*77
Block ANC Act CodeBlocks all anonymous calls.
*87
Block ANC Deact CodeRemoves blocking of all anonymous calls.

By anonimous it means witheld numbers via the privacy header.

The star codes must/should not conflict with those used on the PBX (see Admin/Feature Codes )

In my case I needed to delete the 'DND Act Code:' *78 Do not disturb and *79 to turn it off; so that that code could pass thro to the PBX then asterisk would know via the "sip show hints". However the pbx does have a star code 'DND Toggle' *76 which can be used instead.
 
Last edited:

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,520
Messages
138,557
Members
14,644
Latest member
goseph