1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TIPS Outgoing Callcentric call not working with Wazo

Discussion in 'Help' started by Jess Smith, Jan 11, 2017.

  1. Jess Smith

    Jess Smith
    Expand Collapse
    New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    0
    Hi, I've installed the Wazo version of Incrediblepbx twice now. While I can get two Google Voice numbers to work just fine, I can't get an outgoing call to work on my Callcentric trunk. Incoming calls are fine. I also installed the 3CX version and Callcentric in and out worked just fine there. It seems my authentication is failing but I've double checked the Callcentric trunk and outgoing calls set up and they match the set up guides perfectly as far as I can tell. Callcentric doesn't seem to know what's going on from the log files and screenshots I've sent them. I'm pretty much done all I can do. Here's a small snippet of a test call using Callcentric's test call number: Don't know how to attach a file here or I put the log in. Callcentric seemed to think the "realm" should be their IP address, not my private address.

    [Jan 11 11:22:43] CSeq: 103 INVITE
    [Jan 11 11:22:43] User-Agent: XiVO PBX
    [Jan 11 11:22:43] Proxy-Authorization: Digest username="1777MYCCID", realm="192.168.1.XXX", algorithm=MD5, uri="sip:sip:192.168.1.XXX", nonce="dcfd569bf6671caf5330b4d338f44801", response="c072dcb7d51c247257eadb19bf0d4146"
    [Jan 11 11:22:43] Date: Wed, 11 Jan 2017 17:22:43 GMT
    [Jan 11 11:22:43] Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
    [Jan 11 11:22:43] Supported: replaces, timer
    [Jan 11 11:22:43] Remote-Party-ID: "700 Jess" <sip:700@192.168.1.XXX>;party=calling;privacy=off;screen=no
    [Jan 11 11:22:43] Content-Type: application/sdp


    Could sure use some help/suggestions.

    Thanks
     
    #1 Jess Smith, Jan 11, 2017
    Last edited: Jan 11, 2017
  2. wardmundy

    wardmundy
    Expand Collapse
    Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    12,595
    Likes Received:
    1,870
    Here's the problem. See if you can't track down where it's set up like this:

    sip:sip:192.168.1.XXX
     
  3. Jess Smith

    Jess Smith
    Expand Collapse
    New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    0
    The XXX is just redacted. There's actually a number there. It's the server address.
     
  4. Sylvain Boily

    Sylvain Boily
    Expand Collapse
    Active Member

    Joined:
    Apr 30, 2016
    Messages:
    166
    Likes Received:
    87
    Why there is double sip:sip in your uri?
     
    wardmundy and briankelly63 like this.
  5. Jess Smith

    Jess Smith
    Expand Collapse
    New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    0
    Hello Sylvain, I wish I could tell you but I have no idea. I reinstalled everything tonight with the Phoenix version of Wazo. After setting everything up again (3rd time now), I get the exact same thing in the log. What could I possibly be adding to the set up that would cause that to happen. Seems like the system is sending that out from somewhere in the files. I'm stumped.
     
  6. Sylvain Boily

    Sylvain Boily
    Expand Collapse
    Active Member

    Joined:
    Apr 30, 2016
    Messages:
    166
    Likes Received:
    87
    Can you show us a result of :

    xivo-confgen asterisk/sip.conf

    Without the login/password. Maybe it can help to found the problem.
     
  7. Jess Smith

    Jess Smith
    Expand Collapse
    New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    0
    [1777MYCCID]
    disallow = all
    context = from-extern
    call-limit = 0
    amaflags = default
    port = 5060
    secret = password
    transport = udp
    nat = force_rport,comedia
    qualify = yes
    type = peer
    username = 1777MYCCID
    insecure = port,invite
    dtmfmode = rfc2833
    host = callcentric.com
    language = en_US
    allow = ulaw,alaw
    subscribemwi = no
     
  8. Jess Smith

    Jess Smith
    Expand Collapse
    New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    0
    Does anybody have a working Callcentric account that can make outbound calls? I set up a Voip.ms trunk and it worked right out of the box. The authorization for Voip.ms looks more like I would expect:

    Authorization: Digest username="XXXXXX_XXXX", realm="atlanta.voip.ms", algorithm=MD5, uri="sip:512789XXXX@atlanta.voip.ms:5060", nonce="69750011", response="cad881f51fd70c366a820dbf482535a5"

    Where Callcentrics is:

    Proxy-Authorization: Digest username="1777MYCCID", realm="192.168.1.XXX", algorithm=MD5, uri="sip:sip:192.168.1.XXX", nonce="29e26ef34148dad6af01c738714164b8", response="485402608c525ea1bfa5f68ccf8d23ea"

    Why the big differences in the realm and the uri? This is very frustrating. I'm not sure what user input I could change that would make a difference?
    Wazo - Version: 17.01 "Phoenix
     
  9. briankelly63

    briankelly63
    Expand Collapse
    Guru

    Joined:
    Nov 14, 2008
    Messages:
    1,284
    Likes Received:
    273
  10. Jess Smith

    Jess Smith
    Expand Collapse
    New Member

    Joined:
    Jan 2, 2017
    Messages:
    6
    Likes Received:
    0
    Well, I'm still racking my brain over this. When I first installed, and each time afterward, I did not add the external IP address or the local network. Two google voice numbers and voip.ms worked fine without it. I added them to see what effect it would have on the Callcentric outgoing. While it changes up the authorization sip message somewhat, it still makes no difference. So before adding the ext ip add and local network I got:

    [Jan 11 11:22:43] Proxy-Authorization: Digest username="1777MYCCID", realm="192.168.1.XXX", algorithm=MD5, uri="sip:sip:192.168.1.XXX", nonce="dcfd569bf6671caf5330b4d338f44801", response="c072dcb7d51c247257eadb19bf0d4146"


    Now I'm getting:
    [Jan 17 17:15:34] Proxy-Authorization: Digest username="1777MYCCID", realm="23.119.29.XXX", algorithm=MD5, uri="sip:sip:23.119.29.XXX", nonce="1dec67f764ab4f3436b8ab4769693c94", response="1ffdd348af49d06391e414a13c406916"

    I still have the danged "sip:sip" in the uri. Don't know where that's being generated from. I set the local network to 192.168.1.0/24. I tried 192.168.1.0/255.255.255.0 too, but no worky. Where's the sip:sip: coming from? Arrrggghhh.

    Edit: When I make a call using the voip.ms trunk, I get a nice clean authorization message. Of course, the only difference is that it's not a proxy authorization. It looks like:

    [Jan 17 17:28:16] Authorization: Digest username="210819_myid", realm="atlanta.voip.ms", algorithm=MD5, uri="sip:512789XXXX@atlanta.voip.ms:5060", nonce="384d6573", response="89805545793d8007f8e6bd5056a8f9d2"
     
    #10 Jess Smith, Jan 17, 2017 at 6:24 PM
    Last edited: Jan 17, 2017 at 6:30 PM

Share This Page