SOLVED No Outgoing calls

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
Hi All,
I have incredible pbx running on Ubuntu 18.04. I am using Linksys SPA-3102 as an FXO for my analog line. Calls coming in to analog line are routed properly. But I can not make any external calls using the Trunk I have made. I am getting "The number you have dialed is not in service...". My trunk configuration is as follows:

username=LINKSYS
secret=********
host=dynamic
nat=never
type=friend
context=from-trunk
qualify=yes
dtmfmode=rfc2833
canreinvite=no
disallow=all
allow=ulaw

I would appreciate it if someone can help me.
Thank you
 

mainenotarynet

Not really a Guru - Just a long time user
Joined
May 29, 2010
Messages
599
Reaction score
72
Location
Bangor, ME USA
One: No Provider -- each provider has a 'slightly' different config for trunks
Two: I know this because there is no hostname= in the config -- my voip.ms outgoing looks like:

Code:
username=myvoipmssubaccountname
type=peer
trustrpid=yes
sendrpid=yes
secret=mysubaccountpassword
qualify=yes
nat=yes
insecure=invite
host=montreal.voip.ms  <<-- This is what you are missing
fromuser=myvoipmssubaccountname
disallow=all
context=from-trunk
canreinvite=nonat
allow=ulaw;gsm
The incoming needs the registration string which looks like:

myvoipmssubaccountnae:[email protected]:5060

Also if the numbers needs a specific format you need to put that in (voip ms adds a 1 to NANPA numbers. You also need an outgoing ROUTE, without one no calls will go through. That is in another section (Connectivity->Outbound Routes), they look similar but you need the outbound rout and in there you tell it the trunks to use for the calls.
 

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
mainenotarynet thank you for your reply. I am using analog PSTN line for outgoing calls. I also I have an outbound route setup with dial patterns set.
 

MGD4me

Guru
Joined
Feb 3, 2009
Messages
429
Reaction score
56
Location
British Columbia
@technics...

My Trunk configuration looks like this:

disallow=all
allow=ulaw
canreinvite=no
context=from-trunk
dtmfmode=rfc2833
host=dynamic
incominglimit=1
nat=never
port=5061
sendrpid=yes
trustrpid=yes
qualify=yes
secret=whatever-you-set-up
type=friend
username=I-have-my-10-digit-PSTN-number-here
 
  • Like
Reactions: wardmundy

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
MGD4me I tried that and still no outgoing calls are routed to the trunk. My dial pattern in the outbound route is: XXXXXXX so any 7-digits number is routed to the trunk, but it is not. I see this warning message in Cli when calling an external number:
WARNING[7054][C-00000009]: Ext. s:6 @ from-sip-external: "Rejecting unknown SIP connection from 192.168.168.168"
 

MGD4me

Guru
Joined
Feb 3, 2009
Messages
429
Reaction score
56
Location
British Columbia
@technics

Check the PSTN Line tab on your 3102, and see if it looks similar to mine. The proxy IP address points to the PBX, yours will be different.

Note that the FXS uses port 5060, and FXO uses 5061.
 

Attachments

Eliad

Member
Joined
Aug 13, 2017
Messages
148
Reaction score
22
I have a similar problem on a new install on Centos 6.10. I think is something going on with this new IncrediblePBX script version. If you use the Yate soft phone client you do not get this error. When you use an actual IP Phone you get this error. This is true for Skyetel and for VOIP.MS. The trunk is connected, I even used an working VIOP.MS trunk which I have on another older install IncrediblePBX and still have the same error. I checked numerous time the dial plan and it is correct. Did anybody tried to use an actual Voip phone to dial out after using the latest IncrediblePBX install script?
I am now doing a test install using an older IncrediblePBX install script(early 2018) from Sourceforge, I will report how it goes
 

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
Eliad please keep me updated as I am suspecting the same problem. I installed earlier versions of Incredible Pbx with the same FXO and they work fine.
 

Eliad

Member
Joined
Aug 13, 2017
Messages
148
Reaction score
22
Eliad please keep me updated as I am suspecting the same problem. I installed earlier versions of Incredible Pbx with the same FXO and they work fine.
hI used an older IncrediblePBX script (early 2018) then installed Skyetel trunks. With this install the incoming and outgoing calls using a physical voip phone works well, both Skyetel and VOIP.MS. link for the script I used.
wget https://sourceforge.net/projects/pbxinaflash/files/IncrediblePBX13-13 with GVSIP for CentOS 6.10/incrediblepbx-13-13-LEAN.tar.gz.

I think the latest script has an error somehow and was not noted because everybody who tested it used Yate softphone and not an actual voip phone. This latest script I tested it with Yate and works but I had no luck when using an actual voip phone. this was true for Skyetel trunks and for the voip.ms. I one point I kept switching the outgoing between the Skyetel and Voip.ms and then i got the outgoing to ring to my cell phone but there was no connection made and my cell never actually rang.

I am not expert at all, I do not know how to fix this problem except by using the older install script
 

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
Thank you for the update. I am using Ubuntu 18.04 and it seems I can not run older versions of Incredible Pbx on Ubuntu 18.04.
 

Eliad

Member
Joined
Aug 13, 2017
Messages
148
Reaction score
22
Thank you for the update. I am using Ubuntu 18.04 and it seems I can not run older versions of Incredible Pbx on Ubuntu 18.04.
I recommend to use Centos 6.10. it is the best supported and updated on this forum than any other versions.
 

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
Before I used Centos. But now I need to use Ubuntu 18.04 for other work.
 

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
Eliad you are 100% correct. I installed a softphpne and it dials out with no problem. It is as you said when using a physical Voip phone it says "The number you have dialed is not in service...."
 

tbrummell

Guru
Joined
Jan 8, 2011
Messages
593
Reaction score
56
Because of this post I decided to fire up yet another instance, on Vultr 1 Gig ram, CentOS 6.10 instance. Results:
Groundwire softphone dialing: success
Snom 370 wired: success
Aastra 6757: success
Using ChanSIP only. I always disable PJSip as I've never had good luck with it.
Voip.ms is my trunking provider of choice.

Post some more details of your configuration if you need help.
 

Eliad

Member
Joined
Aug 13, 2017
Messages
148
Reaction score
22
Because of this post I decided to fire up yet another instance, on Vultr 1 Gig ram, CentOS 6.10 instance. Results:
Groundwire softphone dialing: success
Snom 370 wired: success
Aastra 6757: success
Using ChanSIP only. I always disable PJSip as I've never had good luck with it.
Voip.ms is my trunking provider of choice.

Post some more details of your configuration if you need help.
I fixed my problem by using the older IncrediblePBX script for Centos 6.10. Then I added manually the Skyetel trunks. Right now my system works, my install was a local install in a Proxmox VM. I wonder if this makes a difference. It is very strange. I am no expert by any means. This is a hobby, tinkering with Linux.
 

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
I found some information on installing FreePbx on Ubuntu 18.04. Would I lose much if I installed FreePbx instead of Incredible Pbx?
 

Eliad

Member
Joined
Aug 13, 2017
Messages
148
Reaction score
22
IncrediblePBX is a FreePBX with more bells and whistles, from what I gather IncrediblePBX has a better firewall implementation than FreePB and many add ons which i don't use.
Also, is my understanding FreePBX has a firewall too, not sure how good it is.
One of the experts on this forum might want to correct my statements since I am no expert.
This being said, I just wonder if the firewall implementation for last IncrediblePBX for the cloud has a different firewall setup and this is the reason of the odd behavior of this install on a local server.

It looks is another user having similar problem. Softphone works, hardphones dont. He also provides the log output. The thread is called Asterisk mistakes call from extension as anonymous.
 
Last edited:

Eliad

Member
Joined
Aug 13, 2017
Messages
148
Reaction score
22
I found some information on installing FreePbx on Ubuntu 18.04. Would I lose much if I installed FreePbx instead of Incredible Pbx?
Ward listed a possible fix for this on the other thread. I copied his fix, I hope he does not mind.
Code:
sed -i '\:// BEGIN SIP URI Mod1:,\:// END SIP URI Mod1:d' /etc/asterisk/extensions_custom.conf
asterisk -rx "dialplan reload"
 
Last edited by a moderator:
  • Like
Reactions: wardmundy

technics

New Member
Joined
Dec 9, 2016
Messages
14
Reaction score
1
Looking at the logs, is not telling much. At least that I can understand. I am speculating that it has to do with the context that the call is initiated from. Though it looks - at least to me - that softphone and normal phones are not different as they are just extensions. Does anyone know how to remove Incredible Pbx safely?
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,262
Messages
136,420
Members
14,501
Latest member
yeoldroundabout