SOLVED No calls working

l4cky

Member
Joined
Jan 27, 2015
Messages
70
Reaction score
0
So I had an old version of incredible pbx back in 2016 and i just installed the newest version 13.13.10

I try to use the same info as before, but the PJSIP extension that I created can't be registrered for a reason I do not know. So I changed all the PJSIP to CHANSIP.

My setup is behind a router and I open DMZ for the ip address of the pbx.

Trunk says it is registered.

But when I make incoming, NO ivr works, nothing works. When I choose extension, the extension rings and when i pick up the extension, no sound comes from either way, and then suddenly there comes the automatic message from the SIP server (timeout). It looks like incrediblepbx can pick up an empty call, but the caller's call isn't connected to the extension and keeps ringing without even going through the pbx system.When the caller's call is terminated by hangup, the extension who picked up the calls doesn't terminate the call. So I believe the problem is not in the IVR, but the incoming call which can not be sent to any destination as when I try to call, no sound can be heard no matter what destination I choose at the inbound options.

As for outgoing, it just doesn't work and won't even ring the phone.

I am not sure if it is a nat problem as chansip offered a nat = yes or no, while pjsip doesn't.

I google a lot, people ask to post some sip debug, I don't even know how to sip debug, I can only see the default asterisk logfiles>full

-----------------------------------------------------

Here is a video on youtube showing the problem.
 
Last edited:

Eliad

Member
Joined
Aug 13, 2017
Messages
165
Reaction score
23
I think what are referring is to run in the terminal asterisk -rvvv. This will give you debug info. You can put even more v if you want more verbose output. Besides this I can not help, I am not an expert.
 

l4cky

Member
Joined
Jan 27, 2015
Messages
70
Reaction score
0
Code:
  == Using SIP RTP TOS bits 184
  == Using SIP RTP CoS mark 5
    -- Called SIP/fpl/15148888888
[2019-06-19 21:20:39] WARNING[2138]: chan_sip.c:4069 retrans_pkt: Retransmission timeout reached on transmission [email protected] for seqno 103 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 32000ms with no response
[2019-06-19 21:20:39] WARNING[2138]: chan_sip.c:4093 retrans_pkt: Hanging up call [email protected] - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
  == Everyone is busy/congested at this time (1:0/0/1)
    -- Executing [[email protected]:25] NoOp("PJSIP/444-00000004", "Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 18") in new stack
    -- Executing [[email protected]:26] GotoIf("PJSIP/444-00000004", "0?continue,1:s-CHANUNAVAIL,1") in new stack
    -- Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
    -- Executing [[email protected]:1] Set("PJSIP/444-00000004", "RC=18") in new stack
    -- Executing [[email protected]:2] Goto("PJSIP/444-00000004", "18,1") in new stack
    -- Goto (macro-dialout-trunk,18,1)
    -- Executing [[email protected]:1] Goto("PJSIP/444-00000004", "s-NOANSWER,1") in new stack
    -- Goto (macro-dialout-trunk,s-NOANSWER,1)
    -- Executing [[email protected]:1] NoOp("PJSIP/444-00000004", "Dial failed due to trunk reporting NOANSWER - giving up") in new stack
    -- Executing [[email protected]:2] Progress("PJSIP/444-00000004", "") in new stack
    -- Executing [[email protected]:3] Playback("PJSIP/444-00000004", "number-not-answering,noanswer") in new stack
[2019-06-19 21:20:39] NOTICE[2099]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request 'REGISTER' from '<sip:[email protected]>' failed for '192.168.1.147:46556' (callid: sEqYWJL1jY7APw7Uje90YA..) - No matching endpoint found
    -- <PJSIP/444-00000004> Playing 'number-not-answering.ulaw' (language 'en')
[2019-06-19 21:20:39] NOTICE[2099]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request 'REGISTER' from '<sip:[email protected]>' failed for '192.168.1.147:46556' (callid: sEqYWJL1jY7APw7Uje90YA..) - No matching endpoint found
[2019-06-19 21:20:39] NOTICE[2099]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request 'REGISTER' from '<sip:[email protected]>' failed for '192.168.1.147:46556' (callid: sEqYWJL1jY7APw7Uje90YA..) - Failed to authenticate
    -- Executing [[email protected]:4] Congestion("PJSIP/444-00000004", "20") in new stack
  == Spawn extension (macro-dialout-trunk, s-NOANSWER, 4) exited non-zero on 'PJSIP/444-00000004' in macro 'dialout-trunk'
  == Spawn extension (from-internal, 5148888888, 6) exited non-zero on 'PJSIP/444-00000004'
    -- Executing [[email protected]:1] Macro("PJSIP/444-00000004", "hangupcall") in new stack
    -- Executing [[email protected]:1] GotoIf("PJSIP/444-00000004", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,3)
    -- Executing [[email protected]:3] ExecIf("PJSIP/444-00000004", "0?Set(CDR(recordingfile)=)") in new stack
    -- Executing [[email protected]:4] Hangup("PJSIP/444-00000004", "") in new stack
  == Spawn extension (macro-hangupcall, s, 4) exited non-zero on 'PJSIP/444-00000004' in macro 'hangupcall'
  == Spawn extension (from-internal, h, 1) exited non-zero on 'PJSIP/444-00000004'
 

l4cky

Member
Joined
Jan 27, 2015
Messages
70
Reaction score
0
manage to get pjsip to work partially after sending chansip settings to port 5070 and pjsip to 5060, but that doesn't help much
 

l4cky

Member
Joined
Jan 27, 2015
Messages
70
Reaction score
0
I am not sure what is wrong with the incrediblepbx 13.13.10 raspberrypie

I did a whole new install , and only edited 2 things right after the fresh install:

Add a PHSIP ext --> which also failed right away (to registret)

So I did again a chan_sip ext --> registration works.

Add a trunk, inbound and outbound --> same problem, no connection nothing for outbound except after timeout said number can't be reached, and inbound, same problem as the video i post on youtube on first post.

------------------
 

Eliad

Member
Joined
Aug 13, 2017
Messages
165
Reaction score
23
Is there a necessity to use pjsip? Apparently pjsip is generally not as mature as chan-sip. I myself tried pjsip and I gave up.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,071
Reaction score
2,597
Have you whitelisted the IP address of your provider using /root/add-ip? Perhaps the calls are being blocked by the firewall.
 

l4cky

Member
Joined
Jan 27, 2015
Messages
70
Reaction score
0
Is there a necessity to use pjsip? Apparently pjsip is generally not as mature as chan-sip. I myself tried pjsip and I gave up.
I initially went with chan_sip after I was unable to get pjsip to work. But I figure out, the same problems happened.

Have you whitelisted the IP address of your provider using /root/add-ip? Perhaps the calls are being blocked by the firewall.
It is a good idea.

I manage to get it work temporary by combining:

1- IP addresss of PBX to put in DMZ in router
2- Port forward 5060 in router to the IP of PBX (I find out it only 1 port per line for Asus router as UTP 5060,5061,10000:20000 (RTP) doesn't work..
3- Need to reboot router by unplugging the power cord, the interface reboot doesn't help
4- Removing all the red warning on the dashboard

The problem is I plan to use this configuration to another place with another router and another external IP, and change the IP address of the PBX.

My guess is I only need to go to asterisk sip settings and detect network, and addip for safelist of the computer i wanna login in the interface.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,317
Messages
136,958
Members
14,541
Latest member
matpots64