Resource icon

TUTORIAL Monitor your PBX using Zabbix 2.0

No permission to download

chewie

Member
Joined
Sep 17, 2013
Messages
33
Reaction score
1
2.11 and some change (latest updates).

I *think* I may have figured it out...waiting for the next poll before I can verify.

I saw there was a mass of userparams from the userparameter_asterisk.conf file and I modified them to use the root login I use (stupid yes, but whatever) vs the specified zabbix user.
--

Update: Nope, for some reason it's not updating anything asterisk related.

I will note I have Zabbix installed on a seperate VM.
Imported the xml template file and assigned it to the PBX server.
Installed the agent on the PBX server, and then configured the agent settings (both zabbix_agent.conf and agentd.conf have the user parameters, using -u root instead of -u zabbix). Did a restart of the services, waited a while and no dice still.
 

Hyksos

Guru
Joined
May 28, 2011
Messages
474
Reaction score
69
exactly which version of asterisk are you running?
 

chewie

Member
Joined
Sep 17, 2013
Messages
33
Reaction score
1
Sorry:

PIAF installed version = 2.0.6.2 (under vmware)
FreePBX version = 2.11.0.32
Running Asterisk version = 1.8.8.0 (same for asterisk source version).

If it helps, I see that in the Queues that 22 items are waiting to be updated and go from 1 minute up to waiting for 10 minutes... exactly the number of items the Asterisk template looks for!

So I'm trying to comb the zabbix logs and not finding anything useful on the server end nor the client end.
---

Another update. So I'm still plugging away and decided to revisit the user parameters. Realized that the zabbix user was created and added to the PBX per the install script. Ran the commands for creating zabbix and such and now I'm actually able to manually get info from the PBX from the zabbix cli (e.g. zabbix_get -s pbxserver -k ast.pid) but the queue is still registering that the 22 items are 'stuck'...

Last update:
Got it running on the PBX itself so....good enough for now!
I have a ESXI host (where this all lives) two windows VM's and another linux VM I'll monitor as well. Will just have to beef up the 1gb ram on the PBX up to 2 and it should be happy.
 

Hyksos

Guru
Joined
May 28, 2011
Messages
474
Reaction score
69
Based on what you said I cant help to figure out what was wrong when the server was on another machine. There is no reason for it not to work as this is not special the situation here... Zabbix is always used on another server usually.

I though you could be running into this:
https://issues.asterisk.org/jira/browse/ASTERISK-23084
Which messes the output of all asterisk -rx stuff.
But it seem your version is older so it's not spitting this warning, also the fact that it works from the PBX itself... means the userparams are good as this doesn't change at all when moving from on the PBX itself to a standalone Zabbix.
 

Hyksos

Guru
Joined
May 28, 2011
Messages
474
Reaction score
69
my thinking is you should keep trying to make it work standalone... moreso if your monitoring other servers.
Doesn't make sense to host Zabbix on the PBX as anyway it will not be on the other servers... So you still have to make Zabbix work when it's not on the same server it's monitoring. You've put on the PBX... but now it's remote from the other servers... If you can make the others work... why would the PBX not work with a remote Zabbix too?
 

jrosetto

New Member
Joined
Feb 13, 2012
Messages
4
Reaction score
0
Is it possible to get this script to pull from a remote PIAF server with the Zabbix agent installed? I have a Zabbix server currently monitoring tons of other clients and would like to find a way to incorperate this. I tried added the userparameter_asterisk.conf file to the Zabbix server and configured the Zabbix agent on the PBX but it never seems to get any data. If I run zabbix-get from the CLI I get data back. Stumped just like the person above...
 

jrosetto

New Member
Joined
Feb 13, 2012
Messages
4
Reaction score
0
For me it ended up being the firewall on the Zabbix Server that was blocking the active check port 10051. After disabling the firewall stats began to flow.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,581
Messages
138,982
Members
14,676
Latest member
BluePeter