QUESTION IVR not playing announcement

rchalk

Member
Joined
Feb 19, 2010
Messages
287
Reaction score
22
Location
N.E. GA, USA
I have an operating system, and am trying to set up a new IVR. I have made a new recording using the system recording function, and the file plays fine using VLC media player. However, when I select this file as the announcement for the IVR, it does not play. Using an earlier recording (for a different IVR) plays fine. I checked the file permissions, and they were different (0640) than all the other system recordings (which were 0775) so I changed them to match. File ownership is the same as all the other files on the system.

Anyone have any ideas how to get the file to play? Thanks.
 

atsak

Guru
Joined
Sep 7, 2009
Messages
1,849
Reaction score
196
What's the log say about why it wont' play? Usually that tells you if it's a permission or encoding issue.
 

ostridge

Guru
Joined
Jan 22, 2015
Messages
404
Reaction score
72
Location
UK
I just made a /var/lib/asterisk/sounds/custom/myfilename.wav with 775 permissions.
I dropped an extra line into my lenny dialplan in /etc/asterisk/extensions_custom.conf to include
Code:
exten => 53669,n,Playback(custom/myfilename)
CLI trace
Code:
Connected to Asterisk 13.12.2 currently running on raspberrypi (pid = 1677)
  == Using SIP VIDEO TOS bits 136
  == Using SIP VIDEO CoS mark 6
  == Using SIP RTP TOS bits 184
  == Using SIP RTP CoS mark 5
    -- Executing [[email protected]:1] Answer("SIP/701-0000000a", "") in new stack
       > 0x7651ab40 -- Probation passed - setting RTP source address to 192.168.1.100:49128
    -- Executing [[email protected]:2] Set("SIP/701-0000000a", "TIMEOUT(absolute)=600") in new stack
    -- Channel will hangup at 2019-11-26 01:29:11.405 GMT.
    -- Executing [[email protected]:3] Set("SIP/701-0000000a", "MACHINE=0") in new stack
    -- Executing [[email protected]:4] Set("SIP/701-0000000a", "OPTION=5") in new stack
    -- Executing [[email protected]:5] Set("SIP/701-0000000a", "TALK_DETECTED=0") in new stack
    -- Executing [[email protected]:6] Set("SIP/701-0000000a", "RECORDING=1574731151.60") in new stack
    -- Executing [[email protected]:7] MixMonitor("SIP/701-0000000a", "/tmp/Lenny/1574731151.60.wav") in new stack
  == Begin MixMonitor Recording SIP/701-0000000a
    -- Executing [[email protected]:8] NoOp("SIP/701-0000000a", "Recording will be available: /tmp/Lenny/1574731151.60.wav") in new stack
    -- Executing [[email protected]:9] Playback("SIP/701-0000000a", "custom/myfilename") in new stack
    -- <SIP/701-0000000a> Playing 'custom/myfilename.slin' (language 'en_GB')
    -- Executing [[email protected]:1] Hangup("SIP/701-0000000a", "") in new stack
noted it plays ok when 53369 is dialed from exten 701
 

geopeterwc

Guru
Joined
Aug 17, 2010
Messages
265
Reaction score
60
Location
SF Bay Area - Go Giants!
@rchalk - The most useful format to use for Asterisk recordings is WAV. Files saved in this format can be of many different kinds, but only one type of WAV file will work with Asterisk: files must be encoded in 16-bit, 8000 Hz, mono format. If your recording does not meet this criteria, Asterisk will simply NOT play it. I have been tripped up when using Audacity when making recordings - the program defaults to recording in 'stereo'. Audacity has an option under "tracks" to ensure that the recording is saved as 'mono.'
/Pete./
 

dallas

Active Member
Joined
Oct 21, 2007
Messages
234
Reaction score
36
Location
Sydney, Australia
@rchalk - The most useful format to use for Asterisk recordings is WAV. Files saved in this format can be of many different kinds, but only one type of WAV file will work with Asterisk: files must be encoded in 16-bit, 8000 Hz, mono format. If your recording does not meet this criteria, Asterisk will simply NOT play it. I have been tripped up when using Audacity when making recordings - the program defaults to recording in 'stereo'. Audacity has an option under "tracks" to ensure that the recording is saved as 'mono.'
/Pete./
Personally I would create multiple sets of prompts and announcement, one for each of the active codecs you have configure. That way there is no transcoding required.
 
  • Like
Reactions: ostridge

ostridge

Guru
Joined
Jan 22, 2015
Messages
404
Reaction score
72
Location
UK
The most useful format to use for Asterisk recoon mrdings is WAV. Files
I think @rchalk is using incrediblePBX from the UI in admin/System Recording so I assume from an extension phone. The default is .WAV as in Settings/Advanced Settings. So it should already be in that format.

A better way would be as @geopeterwc recommends and using a decent mic.

On testing I noticed file played as a .slin filetype so it must be converted from .WAV on the fly.
 

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,560
Messages
138,866
Members
14,669
Latest member
cleron