NO JOY IPBX 13-13 Time wrong

Discussion in 'PBX in a Flash 3' started by Scott Reeves, Mar 13, 2018.

Tags:
  1. Scott Reeves

    Scott Reeves New Member

    Joined:
    May 4, 2017
    Messages:
    4
    Likes Received:
    1
    In spite of endless searching, I can't solve a timezone problem. In the TimeGroups dialog the time is two hours off and has the wrong time zone listed. It's causing the CDR reports to be wrong as well as the timestamp for voicemails/call recordings.

    I've tried to use the timezone-setup script a couple of times in /root but to no avail. Rebooting the server doesn't fix it either. My correct TZ is America/Phoenix and is reflected in php.ini as such. However, the dialog shows EST but I can't seem to figure out why. Executing 'date' at the terminal returns the correct time. Hardware and system time are the same.

    Any takers?
     
  2. phonebuff

    phonebuff Guru

    Joined:
    Feb 7, 2008
    Messages:
    850
    Likes Received:
    48
  3. Scott Reeves

    Scott Reeves New Member

    Joined:
    May 4, 2017
    Messages:
    4
    Likes Received:
    1
    Great article but carefully reading through it, I tried every trick in there - no joy...
     
  4. Scott Reeves

    Scott Reeves New Member

    Joined:
    May 4, 2017
    Messages:
    4
    Likes Received:
    1
    There has to be a place where this bit of code picks up the wrong time. The hardware clock is right, php.ini is right, the date command at the terminal shows the correct time... Where could this be getting the wrong time from? What am I missing?
     
  5. billsimon

    billsimon Experienced in Asterisk, FreePBX, and SIP

    Joined:
    Jan 2, 2011
    Messages:
    861
    Likes Received:
    261
    Settings -> Advanced Settings -> PHP Timezone - may be overriding what you have set in php.ini
     
    Scott Reeves likes this.
  6. Scott Reeves

    Scott Reeves New Member

    Joined:
    May 4, 2017
    Messages:
    4
    Likes Received:
    1
    DUDE! That was it! Gosh, what a relief. Thank you so very much!
     
    billsimon likes this.

Share This Page