QUESTION IncrediblePBX on Pi3 & NAT

BeeryGaz

New Member
Joined
Jul 7, 2018
Messages
4
Reaction score
0
Incredible PBX 13.0.192.19
Rasberry PI 3
Installed form image incrediblepbx13.13-raspbian8.zip

I appear to be having a NAT-related issue.

I have two internal extensions configured, and they work fine.
I have a SIP trunk provider and have configured the trunk with my credentials

Inbound calls ring the extension according to the inbound rule, but the call terminates as soon as the call is answered.

According to my SIP provider, outbound calls present the internal IP of my IPBX in the SIP headers rather than the external IP, despite
Settings/Asterisk SIP Settings/Chan SIP Settings/NAT = Yes
Settings/Asterisk SIP Settings/Chan SIP Settings/IP Configuration=Static IP

My Incredible PBX has a private IP, behind a Unifi USG router with a static public IP
SIP ALG (COnTrack in Unifi parlance) = Disabled
UDP Ports 5060/5061 & 10000-50000 forwarded to the PBX private IP

I thought it might be the firewall. There seems to be no Travellin Man 3 'secure-iptables' on my image, so I installed per the tutorial, but the scripts seem to be designed for Centos not Rasbian (referencing /etc/sysconfig). I also disabled iptables and that still didn't help.

I also don't see any entries regarding NAT in the /etc/asterisk/sip_general_custom.conf file - shouldn't they be in there?


 

BeeryGaz

New Member
Joined
Jul 7, 2018
Messages
4
Reaction score
0
To possibly answer my own question:

I found the following three lines in my sip_general_custom.conf file
icesupport=yes
stunaddr=stun.counterpath.net
srvlookup=yes

No idea why they were there. I removed them and everything seems to be working.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,317
Messages
136,958
Members
14,542
Latest member
k0dean