SOLVED IncrediblePBX 13 ISO - problems with Avantfax, RSS feed

DoctorJ

Member
Joined
Jul 14, 2015
Messages
41
Reaction score
13
Sigh.

Not sure if someone on the forum can help me. I'm quite a newbie, but I have tried everything that I can imagine. I'm setting up a PBX for my small office (probably about 10 extensions with only about 3 in use at any single time). I was hoping that this project would be fairly "turnkey," but it has been quite frustrating. I have setup a Raspberry Pi2 with IncrediblePBX without issue.

My current setup:
I bought the Intel NUC, Kingston SSD, and Crucial RAM (I have 8GB), as recommended by Ward: http://nerdvittles.com/?p=15048

I followed the tutorial precisely for the turnkey ISO: http://nerdvittles.com/?p=14942

My current problems:
  1. After initial boot, the RSS feed on the left side of the Kennonsoft GUI disappears. After running /root/timezone-setup it reappears. Not a big deal, but with each reboot, this happens again, only to be resolved after re-running timezone-setup. Quirks like that worry me that I am missing some bigger issue, and I would like to use this as a production system.
  2. IncredibleFax install just doesn't work correctly
    • The password set by /root/avantfax-pw-change never sticks. I can log in using the "admin:password" -- then I can never logout again. There are forum threads on this issue already, but no apparent resolution.
    • At some point, I fixed the issue by completing deleting the contents of /etc/pbx/httpdconf/avantfax.conf -- this apparently handed password access back to avantfax from apache (I think).
    • Faxing with a cover sheet does not include the attachment. There are forum and other blog posts about this issue, also without resolution as far as I can tell.
Some things I have done.
  1. I've installed using the incrediblepbx iso. Both DVD (even bought the LG DVD writer from Ward's post to be completely consistent).
  2. I've installed using the incrediblepbx USB method. Again, same problems.
  3. I've installed CentOS (not SL) 64-bit using the minimal.iso, while following this post: http://nerdvittles.com/?p=14208 -- this essentially solved the RSS GUI issue after installing Incredible PBX. Also, this was the only install that allowed the Avantfax password issues to be solved as noted above. Using the iso, I could never get Avantfax credentialing to work properly. The only remaining issue on this install was the cover page issues in Avantfax
  4. I thought that perhaps my problem was my hardware. So I created an account at rentpbx.com. I installed the CentOS 6.7/Incredible GUI 13 image. No Kennonsoft GUI issue, but same exact problems in Avantfax.

Not sure where to go from here. I've exhausted my ideas. If it's a known bug in the incrediblefax install script or with the iso, please let me know. Anyone having similar issues? I'd be disappointed, but I realize that Ward and all work very hard. I'd stop banging my head against the wall and wait for an update.

Thanks,

Joe
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,234
Reaction score
2,666
The fax setup is normal behavior. No need to worry about not logging out. The firewall has you covered. Your browser is caching your credentials.

The Kennonsoft GUI issue is a new one. I'm curious how often you are having to reboot your server. Once configured, most run unattended for months and years. So... I wouldn't worry too much about a quirk that doesn't affect the actual operation of your PBX.
 

DoctorJ

Member
Joined
Jul 14, 2015
Messages
41
Reaction score
13
Thanks for the reply, Ward! If not symptomatic of a deeper problem, I'm not too concerned with the GUI issue. The AvantFax issue is a little more of a problem. Because I cannot log out, I cannot set up multiple users for the fax. Ultimately, I was hoping to arrange DID routing for fax to email.

How about the cover page bug? Any way to resolve it?

Also, the authentication issue causes problems with other apps. For example, machylafax cannot send a coverpage. I also use Hylafax Lite on my iPhone. I cannot view faxes using the app with this build. All of these features seem to work seemlessly on my home RPi2 PBX. I just want something a bit more "robust" for work.

Many of the issues are more eloquently explained here: http://pbxinaflash.com/community/threads/install-avantfax-on-piaf-green-no-incrediblepbx.18205/

Any thoughts / help appreciated.

Thanks!
 
Last edited:

DoctorJ

Member
Joined
Jul 14, 2015
Messages
41
Reaction score
13
Created a Digital Ocean droplet. Same Avantfax issue.
 

simplydrew

Member
Joined
Feb 19, 2012
Messages
92
Reaction score
4
Created a Digital Ocean droplet. Same Avantfax issue.
Hi @DoctorJ - just noticed that the referenced post was mine, for this particular issue. Every single install of Avantfax I've had this problem with, and it has taken a lot of wrestling with to resolve both problems - the "unable to log out" issue, as well as the password issue.

For me, the "change Avantfax password" script has never worked. It may work for some, but has never worked for me. Maybe @wardmundy can tackle fixing that up one day. He's been extremely helpful in trying to help me through the Avantfax issues I've had in the past (as you can see in that thread), but it seems like there's still issues with it.

I resorted to changing the password within the MySQL database itself. That was the only definitive way to resolve it. I'll have to deploy a test VM this weekend and see if I can perform step by step instructions. I neglected to when I did this last.

For your log out issue, I think commenting out everything in /etc/pbx/httpdconf/avantfax.conf worked for me. Just be sure you have iptables up and running, allowing only the IPs you trust to hit your PBX and Avantfax. htaccess auth is a flimsy at best, and inadvisable level of security if exposed to the open Internet.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,234
Reaction score
2,666
Another thought on this is to try changing the admin acct name and password in the AvantFax config option. Just be sure you have a backup somewhere as this may permanently break something although I wouldn't think so.
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,579
Reaction score
427
Location
South Florida
Created a Digital Ocean droplet. Same Avantfax issue.
Is there a resolution for this? I've tried both DO and Wable, and I have the same issues. Won't Logout, and trying to use other login accounts (different browser) won't login. This essentially locks you down to giving everyone the admin credentials - which really limits any flexibility of multiple users.
 

kmcdaniel

Guru
Joined
Jan 23, 2008
Messages
327
Reaction score
11
Is there a resolution for this? I've tried both DO and Wable, and I have the same issues. Won't Logout, and trying to use other login accounts (different browser) won't login. This essentially locks you down to giving everyone the admin credentials - which really limits any flexibility of multiple users.
What browser's have you tried? Firefox and Chrome? I had same issues and accessed my fax from IE and it worked.
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,579
Reaction score
427
Location
South Florida
Doctor J had the answer: Found the answer - protected folder - remove /etc/pbx/httpdconf/avantfax.conf

Don't rename it like I did thinking it wouldn't be read - it still is. Remove it - and then you get the Avantfax login page and logout works and so does using different user names.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,448
Messages
138,013
Members
14,613
Latest member
roshan2019