GOOD NEWS Incredible Ubuntu 18.04

rygel_fievel

New Member
Joined
Aug 4, 2018
Messages
9
Reaction score
0
What are the steps in getting Let's Encrypt to work with this distro? I followed the directions from Let's Encrypt for Ubuntu 17.xx on their website. It fails during the http-01 challenge. I take it is because of iptables and/or fail2ban?
 
Last edited:

kyle95wm

Phone Genius Owner
Joined
Apr 16, 2016
Messages
521
Reaction score
89
Location
Midhurst, ON, Canada
What are the steps in getting Let's Encrypt to work with this distro? I followed the directions from Let's Encrypt for Ubuntu 17.xx on their website. It fails during the http-01 challenge. It take it is because of iptables and/or fail2ban?
I think @wardmundy has an article on it but Im not sure if he has steps for Ubuntu.
 

rygel_fievel

New Member
Joined
Aug 4, 2018
Messages
9
Reaction score
0
Haven't tackled 18.04 yet. Sorry.
This is what I'm getting if it helps.

http-01 challenge for fakedomain.com
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. fakedomain.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://fakedomain.com/.well-known/acme-challenge/XxX1234ABCdefg: Timeout during connect (likely firewall problem)
 

chris_c_

Active Member
Joined
Aug 19, 2010
Messages
509
Reaction score
67
This is what I'm getting if it helps.

http-01 challenge for fakedomain.com
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. fakedomain.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://fakedomain.com/.well-known/acme-challenge/XxX1234ABCdefg: Timeout during connect (likely firewall problem)
That means the letsencrypt server failed to connect to your server. HTTP means port 80. So you need to allow incoming connection to your server on port 80 from whatever hostname or IP the letsencrypt server is.
You can disable your iptables firewall, run the script, and enable iptables again after the script's successfully gotten your letsencrypt TLS cert.

Alternately, just have webmin get the letsencrypt TLS certs for you, webmin has the ability.
 

rygel_fievel

New Member
Joined
Aug 4, 2018
Messages
9
Reaction score
0
That means the letsencrypt server failed to connect to your server. HTTP means port 80. So you need to allow incoming connection to your server on port 80 from whatever hostname or IP the letsencrypt server is.
You can disable your iptables firewall, run the script, and enable iptables again after the script's successfully gotten your letsencrypt TLS cert.

Alternately, just have webmin get the letsencrypt TLS certs for you, webmin has the ability.
That's what I thought too. I tried service iptables stop then running it again without success. I don't think Let's Encrypt gives out the IP addresses as they can change and I don't know the name of the host to give exception.
 

silimms

New Member
Joined
Feb 18, 2016
Messages
21
Reaction score
1
I have tried to install incrediblePBX on ubuntu 18.04 64bit.

but it seems not installed.

Is it cannot install on 64bit? only 32bit?
 

tycho

Guru (not...)
Joined
Aug 9, 2011
Messages
592
Reaction score
229
I have tried to install incrediblePBX on ubuntu 18.04 64bit.

but it seems not installed.

Is it cannot install on 64bit? only 32bit?
Sure it does. I installed IncrediblePBX on Ubuntu 18.04 64 bit just this past week.
 

silimms

New Member
Joined
Feb 18, 2016
Messages
21
Reaction score
1
Sure it does. I installed IncrediblePBX on Ubuntu 18.04 64 bit just this past week.
Does it have something need notice?
I have do step by step
But it seems something cannot install.
 

tycho

Guru (not...)
Joined
Aug 9, 2011
Messages
592
Reaction score
229
In my case I installed IncrediblePBX using the instructions found at this link:

http://nerdvittles.com/?p=25930

... on a VPS instance of an Ubuntu 18.04 64 bit server hosted at Cloud at Cost (not recommended as a provider, but it is what I have). I did this within the past 7 days. It installed fine and works fine.

So, without specific details as to how it is failing at your end I don't know why it is not working for you.
 

rygel_fievel

New Member
Joined
Aug 4, 2018
Messages
9
Reaction score
0
I was able to install an SSL certificate after manually applying these iptable rules:

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -F

This actually disables the firewall and can be confirmed by pbxstatus. If you do service iptables stop, pbxstatus still shows the firewall being up. Once I was able to get my certificate, I just used iptables-restart. You may need to also stop Apache prior to certificate request.
 

MUTLU BATTAL

New Member
Joined
Jun 14, 2018
Messages
2
Reaction score
0
hello everyone,
i have installed asterisk on ubuntu server 32 bit.
when i try to get into CLI by typing asterisk -r, asterisk stopped and I get an error as
"Unable to connect to remote asterisk (does /var/run/asterisk/asterisk/ctl exist?)"
when i tried amportal restart, i got

[email protected]:/var/log/asterisk# amportal restart

Please wait...

!!!!amportal is depreciated. Please use fwconsole!!!!
forwarding all commands to 'fwconsole'
Running Incredible PBX shutdown...
[Whoops\Exception\ErrorException]
fclose() expects parameter 1 to be resource, boolean given
restart [-i|--immediate] [args1] ... [argsN]

any help would be highly appreciated.
thanks in advance...
 

Eliad

Member
Joined
Aug 13, 2017
Messages
165
Reaction score
23
as far as i know and also as you can see in previous comments, you will have to use 64 bit version of Ubuntu
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,317
Messages
136,960
Members
14,542
Latest member
k0dean