SOLVED Incredible PBX with Google Voice on Raspberry Pi

ericgiler

New Member
Joined
Oct 30, 2017
Messages
5
Reaction score
1
The instructions and software are awesome!! I am trying to use a Incredible PBX/Raspberry Pi/Google Voice together without using an external server like Simonics or Obihai. (Those work quite well and are easy to install). I have been able to set up your Incredible PBX on the Pi without difficulty, both Pi2 and the PiZeroW. The Google Auth instructions also appear to work fine. I just don't seem to be able to get the GV motif trunk to connect. It says under trunk status as "disconnected" On the other side, I've tried both a Cisco ATA and the Yate Client. When I try an outside call, I do get a dial-tone on the Cisco and the Yate Client shows as connected. When I place a call, I get the voice saying "call cannot be completed....." on both. When I place I call to the GV number(s) it rings until I get the "Google Voice subscriber is not available..... " Think I am following the directions. Any thoughts?
 

Twilight Sparkle

♕ Princess
Joined
Jul 21, 2013
Messages
316
Reaction score
26
Location
Ponyville
Try
Some apps and devices use less secure sign-in technology, which makes your account more vulnerable. You can turn off access for these apps, which we recommend, or turn on access if you want to use them despite the risks. Learn more


Allow less secure apps: ON
then try
Link: this https://accounts.google.com/b/1/DisplayUnlockCaptcha
also SSH or COMMAND TERMINAL enter: amportal restart

then reboot and try the https://accounts.google.com/b/1/DisplayUnlockCaptcha again
good luck ps: not sure what i am talking about half the time lol

also note to set the outbound trunk to your google voice account should already be listed make sure to move it to the 1st slot and make sure to set inbount routes and remove the DEFAULT listed on or just use that

go to your google voice and click on Gogle Chat if its listed if its not there is a bad chance the account wont work as you where not grand father into the old network and now only have hangouts most google voice accounts dont have google chat listed any more since its been removed UNTILL you revert back which is gone and im not sure maybe someone else knows?
 
Last edited:

ericgiler

New Member
Joined
Oct 30, 2017
Messages
5
Reaction score
1
Thanks! Got it working. It turns out I had two problems. One was the Inbound trunk setting and the second was the ATA I'm using has two ports, 5060 and 5061. Had it it set to 5060 and it was on 5061.

EG
 
  • Like
Reactions: Twilight Sparkle

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,319
Messages
137,021
Members
14,550
Latest member
treimers