GOOD NEWS Incredible PBX for RasPi3

Discussion in 'Open Discussion' started by wardmundy, Sep 14, 2017.

  1. mrfeh

    mrfeh New Member

    Joined:
    Jun 24, 2016
    Messages:
    17
    Likes Received:
    0
    Roger that. Thanks.
     
  2. Waffull

    Waffull New Member

    Joined:
    Jul 2, 2018
    Messages:
    27
    Likes Received:
    1
    I just removed the r and everything worked
    Code:
    exten => _1NXXNXXXXXX,n,Dial(PJSIP/1${EXTEN:1}@gvsip,,)
    
    I don't remember all the technical reasons, but basically on some calls you'll get the ring back and on others you won't. But I think that's better than having the called dropped after 20 seconds. And the added benefit, at least to me, is that when dialing a number that's busy, the phone won't ring once first which completely kills a number of functions including auto-busy-redial.


     
  3. Laurence

    Laurence New Member

    Joined:
    Jul 6, 2018
    Messages:
    15
    Likes Received:
    0
    I am new to all of this but after some time I managed to install Incredible PBX on a Raspberry PI I had lying around and also the GVSIP integration. I felt pretty stoked by that. I even managed to get the Yate client installed and working to make calls any location from the GUI.

    I would like to now work how to get my Linksys SPA2102 working so I can use analogue phones but I can't find a guide anywhere. Can anybody point me to some information on how to do that? Thanks

    Just a partial updated. Guessing some parameters I have got the 2102 sort of working in that calls to the test numbers work okay DEMO - Apps Demo
    123 - Reminders
    947 - Weather by ZIP Code
    951 - Yahoo News
    *61 - Time of Day
    TODAY - Today in History

    But that could be just the PBX handling the call. As soon as I dial *48 I get fast busy
     
    #83 Laurence, Jul 6, 2018
    Last edited: Jul 6, 2018
  4. MGD4me

    MGD4me Guru

    Joined:
    Feb 3, 2009
    Messages:
    423
    Likes Received:
    54
    On the Regional tab, check the section "Vertical Service Activation Codes" to see if *48 is a reserved code for use by the 2012, Actually, you can probably just delete ALL Vertical Service Activation Codes, since the PBX will be handling everything for you.

    Second, be sure your 2012 Dial Plan(s) have a match for handling *xx numbers.
     
  5. Laurence

    Laurence New Member

    Joined:
    Jul 6, 2018
    Messages:
    15
    Likes Received:
    0
    Thanks. Partial progress. I edited extensions_custom.conf to remove the *48 prefix

    ; To use no *48 dial prefix, comment out lines above and uncomment lines below
    exten => _NXXNXXXXXX,1,Set(CALLERID(dnid)=${CALLERID(dnid)})
    exten => _NXXNXXXXXX,n,Set(CALLERID(dnid)=1${CALLERID(dnid)})
    exten => _NXXNXXXXXX,n,Goto(1${EXTEN},1)
    exten => _1NXXNXXXXXX,1,Set(CHANNEL(accountcode)=Google Voice)
    exten => _1NXXNXXXXXX,n,Dial(PJSIP/1${EXTEN:1}@gvsip,,r)

    and now outbound calls appear to work. But I can't receive inbound calls and I wonder if it's either

    1. I don't have the routing to my 701 extension but the extensions_custom.conf file has these entries

    ; uncomment next line to call ext. 701
    same => n,Dial(SIP/701,20,D:)1))

    so it looks like they are getting forwarded to the 701 extension which is the default I used OR

    I have Google Voice setup on my Android (and other Android devices). Would that cause some confusion?

    I have done all this

    . When your DID has been assigned, click the More icon at the bottom of the left column of the Google Voice desktop. Click Legacy Google Voice. Now click the Settings icon on your legacy Google Voice desktop. Make certain that Forward Calls to Google chat is checked and disable calls to your forwarding number. Click on the Calls tab and select Call Screening:OFF, CallerID (Incoming):Display Caller’s Number, and Global Spam Filtering:checked. The remaining entries should be blank.

    I do receive calls to Hangouts which is attached to my GV account
     
  6. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    14,310
    Likes Received:
    2,437
    You forgot the warning about not registering your Google Voice DID in more than one place.
     
  7. Laurence

    Laurence New Member

    Joined:
    Jul 6, 2018
    Messages:
    15
    Likes Received:
    0
    No I didn't but wasn't sure how it applied. I have the GV app installed on my phone but that's only active when I send a text or make calls over WiFi.

    Anyway for some strange reason it's now all working. Maybe I needed to restart PBX after making the last of my config changes but I did note for inbound 701 was already set as the extension destination. I can make and receive call using my GV number so all is good at the moment. Just got off a 30 min call with a friend and he didn't complain about call quality at all.

    Thanks
     
  8. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    14,310
    Likes Received:
    2,437
    GVSIP is not designed for use with the same Google Voice account connected to your smartphone. Whether you're currently making a call or sending a text message, the GV account is still registered with Google.
     
  9. rogerjbos

    rogerjbos Member

    Joined:
    Mar 27, 2015
    Messages:
    46
    Likes Received:
    5
    I followed the tutorial diligently, but I am still not able to make or receive calls. Here is the error I am seeing in the log file:

    [2018-07-08 09:45:05] ERROR[4458] chan_pjsip.c: Unable to create PJSIP channel - endpoint 'gvsip' was not found
    [2018-07-08 09:45:05] WARNING[4457][C-00000004] app_dial.c: Unable to create channel of type 'PJSIP' (cause 3 - No route to destination)

    The "Asterisk Info" report also shows no PJSip Endpoints:

    Asterisk System uptime: 28 minutes, 40 seconds
    Last reload: 28 minutes, 40 seconds
    Active SIP Channel(s): 2 Active PJSIP Channel(s): 0 Active IAX2 Channel(s): 0
    Sip Registry: 1 PJSip Registrations: 0 IAX2 Registry: 1
    Sip Peers:
    Online: 1
    Online-Unmonitored: 0
    Offline: 0
    Offline-Unmonitored: 0
    PJSip Endpoints:
    Available: 0
    Unavailable: 0
    Unknown: 0
    IAX2 Peers:
    Online: 0
    Offline: 0
    Unmonitored: 0

    I did a fresh IncrediblePBX13 install and then did the GVSIP install as follows:

    cd /root
    wget http://incrediblepbx.com/gvsip-naf.tar.gz
    tar zxvf gvsip-naf.tar.gz
    rm -f gvsip-naf.tar.gz
    cd gvsip-naf
    ./install-gvsip.sh

    I input my refresh token, username, and phone number when requested. And I have made sure I am logged out of the GV account being used. What else can I try to get this working? Thanks in advance for any suggestions.
     
  10. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    14,310
    Likes Received:
    2,437
    You're using the WRONG INSTALLER for the RasPi platform. Go here.
     
  11. mrfeh

    mrfeh New Member

    Joined:
    Jun 24, 2016
    Messages:
    17
    Likes Received:
    0
    And, start with a fresh install of IncrediblePBX. I learned the hard way that once you install the CentOS GVSIP package, you cannot install the Raspbian GVSIP package on top of it.
     
  12. Laurence

    Laurence New Member

    Joined:
    Jul 6, 2018
    Messages:
    15
    Likes Received:
    0
    This is whole platform is a black box to me and I surprised myself that I was actually able to get it to work at all. It is satisfying not having to go buy a Obihai 200 or 202 (I have two GV lines). So even with the GV account logged onto my phone it still works okay. I guess I won't argue with success. Thanks
     
  13. rogerjbos

    rogerjbos Member

    Joined:
    Mar 27, 2015
    Messages:
    46
    Likes Received:
    5
    Ok. Now I am not feeling very diligent anymore. I will start with a fresh image and the correct installer. Thanks so much!
     
  14. rogerjbos

    rogerjbos Member

    Joined:
    Mar 27, 2015
    Messages:
    46
    Likes Received:
    5
    Thanks for that advice. It worked perfectly with a fresh install and the correct script for the raspi. Big thanks to Ward and NAF. This is really great.
     
  15. rogerjbos

    rogerjbos Member

    Joined:
    Mar 27, 2015
    Messages:
    46
    Likes Received:
    5
    My raspi pbx is working well with outgoing calls from a softphone, but calls from the Obi have no audio and hang up after 9 seconds due to SIP retransmission problems (please see below). Has anyone else seen this?

    [2018-07-08 21:17:43] VERBOSE[4781][C-00000008] app_dial.c: PJSIP/gvsip-00000004 answered SIP/701-00000008
    [2018-07-08 21:17:43] VERBOSE[4788][C-00000008] bridge_channel.c: Channel PJSIP/gvsip-00000004 joined 'simple_bridge' basic-bridge <45b8c61d-34a5-4ded-b8cc-4d309ab9fe62>
    [2018-07-08 21:17:43] VERBOSE[4781][C-00000008] bridge_channel.c: Channel SIP/701-00000008 joined 'simple_bridge' basic-bridge <45b8c61d-34a5-4ded-b8cc-4d309ab9fe62>
    [2018-07-08 21:17:52] WARNING[1793] chan_sip.c: Retransmission timeout reached on transmission 65ef7691@192.168.0.4 for seqno 8002 (Critical Response) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
    Packet timed out after 8448ms with no response
    [2018-07-08 21:17:52] WARNING[1793] chan_sip.c: Hanging up call 65ef7691@192.168.0.4 - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
     
  16. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    14,310
    Likes Received:
    2,437
    If it's an OBi100 series device, it's no longer supported by Obihai.
     
  17. rogerjbos

    rogerjbos Member

    Joined:
    Mar 27, 2015
    Messages:
    46
    Likes Received:
    5
    That is the whole purpose of using a PBX (or GVGW) because the Obi100 series still connects to standard SIP servers. I don't know what that problem was, but I switched to a HiFormance server and everything is working fine now (knock on wood). In other words, whatever my problem was, it was not related to me using an Obi100 (or Obi110 in my case).

    While it is not suppored by Obihai, they do still allow it to be configured on Obitalk (though I shouldn't give them any ideas).
     
  18. ostridge

    ostridge Guru

    Joined:
    Jan 22, 2015
    Messages:
    338
    Likes Received:
    56
    Apology for the belated reply - been away in wilderness away from inet for a week.

    For info I got it from:-
    Incredible PBX 06-02-2018 for Raspberry Pi and Asterisk 13.21.0 + GUI ver. 13.0.120.10
    from the nv Gold Standard (soup) page link to

    https://sourceforge.net/projects/pb...ian/incrediblepbx13.13-raspbian8.zip/download

    Code:
    ls-al incrediblepbx13.13-raspbian8.zip
    -rw-r--r-- 1 root root 1384643640 Jun  2 21:13 incrediblepbx13.13-raspbian8.zip
    md5sum  ./incrediblepbx13.13-raspbian8.zip
    d57e6c7a4a73214cf0982f7a306456ac  ./incrediblepbx13.13-raspbian8.zip
    That is same as currently on sourceforge.
     
    #98 ostridge, Jul 12, 2018
    Last edited: Jul 12, 2018
  19. rogerjbos

    rogerjbos Member

    Joined:
    Mar 27, 2015
    Messages:
    46
    Likes Received:
    5
    Ward, I used the GUI to define Inbound Routes under Connectivity, and the PBX is working perfectly, but I noticed that it does not use the config in [from-external-custom]. I wonder if you could tell me where the config is saved that is generated by the GUI for Outbound Routes so I could look at it? The PBX works great, but I would still like to learn more about how it works so when something happens down the road I will have an idea what to do.

    BTW, I know it is not using the [from-external-custom] because I commented out the whole sections and reloaded the dialplan and everything still works. My suspicion was aroused when I put a bunch of Verbose command in there to see what was happening and didn't see anything in the Asterisk CLI output.
     
  20. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    14,310
    Likes Received:
    2,437
    Incoming calls now are handled in the FreePBX GUI using your GVSIP custom trunk. See the new build under this thread for the latest implementation which relies entirely on FreePBX.
     

Share This Page