QUESTION Incredible PBX 13-13: need help integrating sip extension from cellphone

skyeman

New Member
Joined
Jul 9, 2018
Messages
3
Reaction score
1
I'm exploring migrating my once trusty FreePBX 13 home pbx server over to Incredible13-13, because my only trunk needs have ever been provided by the googlevoice-motif module in the past. It broke a few weeks ago as xmpp was finally deprecated by google. (It could receive calls with working audio both ways (at least at times), but couldn't originate calls with incoming audio at all.) The prospect of fixing this with the new googlevoice sip add-on using IncrediblePBX is what brought me here.

So, I'm enjoying learning this fork of asterisk. My IPBX-13-13 was built using the CentOS-SL6.9 _x64 installer on a Pentium T4500 platform with 3 gig RAM. All went smoothly. I've built a working softphone extension on a LAN desktop, and installed a csipsimple extension to my cellphone which works well when the phone's wifi is linked to the same network as the server. Normal audio both on ulaw and g722.

So, as you might expect, my issues are no-audio both ways when csipsimple tries to place or receive a call across the WAN. I can get the cell sip phone to register after running DroidKnocker (the cellphone's wan ip gets added to iptables). I can INVITE calls to the cell sip client from my LAN softphone, and they ring through normally. But no audio either way. I can INVITE calls from the cellphone to both my server and the softphone, and same story: ring-thru works, but no audio at all. With the cellphone sip client, I cannot terminate the call normally (it will eventually time out).

I've tried all this using a csipsimple configuration which did work across the WAN for my FreePBX server. So, I'm thinking, maybe it's my NAT settings either in IncrediblePBX or on the phone. Or, something to do with iptables.

For me, iptables are unfamiliar territory, as was port knocker. Indeed, compared to FreePBX13 (employing the Sangoma firewall module), the correct configuration for IPBX13-13 is somewhat mysterious to me. The Sangoma firewall requires the server be placed in the router's DMZ. This seems unwise for IPBX13-13 ??? There's one of my questions.

Anyway, I've struggled with this csipsimple extension problem for three full days, and I'm ready for some help. If I can make it work, I promise I'll pay it forward by writing up a how-to, and posting it to the forum.

Thanks,
skye
 
Last edited:

skyeman

New Member
Joined
Jul 9, 2018
Messages
3
Reaction score
1
Ahh, humble pie time! I found my error in the Asterisk SIP settings; an utterly trivial error in the server IP settings. Should have eithere entered the numeric IP address using the Static IP choice, and not the FQDN. With that change it's now fixed. Well, that's a relief...
 
  • Like
Reactions: xekon

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,377
Messages
137,433
Members
14,578
Latest member
BoRoDKuH