GO HERE Incredible PBX 12.0.70 'Incredible PBX GUI' Sip Phones/ATAs won't receive incoming calls

RalphF

New Member
Joined
Jul 7, 2016
Messages
5
Reaction score
1
I'm a long time Asterisk user with multiple PBXs. All of them have been in my data center on individual servers and have worked great for many years.

I recently deployed a droplet on Digital Ocean using Incredible PBX 12.0.70 'Incredible PBX GUI' on the recommended version of Ubuntu and had really no problem migrating phones, IVRs, etc over (had to recreate the IVRs but at least had the audio files).

Everything seems to work: inbound and outbound calls, follow me, EXCEPT on incoming calls none of the ATAs or SIP phones (Linksys SPA942s) respond when they are called. Caller hears ringback but no indication on phone. All phones work fine for outbound and I know the inbound DIDs are bringing calls in.

It has been a long time since I deployed my other boxes and if I had a workaround for this, I sure don't remember it.

Can anyone steer me to what I need to look at? I'm not an expert at decoding SIP log files but if someone needs them I will be glad to add them.

Thank you!
 

RalphF

New Member
Joined
Jul 7, 2016
Messages
5
Reaction score
1
@wardmundy, thanks for the reply. I see the tutorial. My pbx is on a static address in the Digital Ocean data center. My devices are all NATted through a single static IP at a remote location. They all work on the old FreePBX 2.9.0.15 system (which I let g
t by RalphF

et too old and couldn't update).


I don't understand why the need to whitelist the IPs of the phones (the static public I guess) just to get them to ring. Or have I missed something along the way in development?

And also- the address where the phones are is the same one where the PBX was initially set up from, so that IP is already allowed.

Please set me straight about this.

Thanks
 
Last edited:

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,562
Messages
138,877
Members
14,669
Latest member
cleron