TIPS If your GVSIP Google Voice trunk starts reporting congestion

ABSGINC

You can call me Scott.
Joined
Oct 1, 2014
Messages
59
Reaction score
31
Location
Flint, MI
...try a "fwconsole restart" before you take a sledgehammer to your box or bother tweaking your settings.

On a mildly fresh install of the incredible pbx 13 and the GVSIP / NAF fork running asterisk 13.22, everything was rolling smoothly, until suddenly the GVSIP1 trunk was reporting congestion.



The logs were looking something like this... I troubleshooted a little to find that dialing my google # resulted in no activity on the CLI, and attempting to dialout resulted in a congestion error like so..

Code:
Executing [[email protected]:32] Dial("PJSIP/Inbound-HIFI-Chicago-000000e8", "PJSIP/[email protected],300,T") in new stack
[2018-09-26 11:21:12] DEBUG[11151]: res_pjsip_outbound_registration.c:2541 transport_from_endpoint_override: Setting transport to 0x7fd0743fc368
[2018-09-26 11:21:12] DEBUG[11151]: res_pjsip.c:3072 ast_sip_dlg_set_transport: Overriding endpoint transport to use 0x7fd0743fc368
    -- Called PJSIP/[email protected]
[2018-09-26 11:21:12] DEBUG[31520]: res_pjsip_outbound_registration.c:2577 handle_outgoing_request: Found matching outbound registration state
[2018-09-26 11:21:12] DEBUG[31520]: res_pjsip_outbound_registration.c:2590 handle_outgoing_request: Found service-route. Adding route header for <sip:ACAH**********************TOT4LW3UV6I:5060;uri-econt=UIOPHG7D6W2I**********************RSCXI4USOZRCJPYCYZK2GTPEY2LE5UVFDEGXX32EFEUKJIRWT3E**********************GESO;lr>
[2018-09-26 11:21:12] DEBUG[31520]: res_pjsip_outbound_registration.c:2590 handle_outgoing_request: Found service-route. Adding route header for <sip:ABZSS4********************************************H2:5060;transport=udp;lr;uri-econt=26***********KHI>
  == Everyone is busy/congested at this time (1:0/1/0)
    -- Executing [[email protected]:33] NoOp("PJSIP/Inbound-HIFI-Chicago-000000e8", "Dial failed for some reason with DIALSTATUS = CONGESTION and HANGUPCAUSE = 34") in new stack
I will mention that logging into the box as root and executing "fwconsole restart" solved the issue entirely and instantly as when asterisk returned incoming calls were hitting the box again and outbound calls no longer resulted in the congestion error. I am unsure as to how it lost registration / was unable to update and register again without the restart. Before I began to troubleshoot this issue the problem remained for around 14 hours or more without resolving itself.

I just wanted to share my experience.
 

John123

New Member
Joined
May 15, 2015
Messages
7
Reaction score
0
I have the same problem. fwconsole restart will fix the problem but only temporarily. After a few minutes outbound GV calls report busy/congested. The log shows the same message as above. Interestingly, if I hang up and the place the outbound call right away, it completes successfully. I too am running the IncrediblePBX image Aug 25, 2018 from Guthub, installed unmodified except for my Callcentric trunk. The definitions in the image did not work. I followed the directions on the callcentric site and I can receive calls from there without problem. I only have one outgoing route and that uses only the GV trunk. I also have an trunk to voip.ms. It is used for inbound calls and it works well too.

Inbound calls from GV show the same pattern. If an outbound call has been placed, or attempted, in the last few minutes, then an inbound call is successful. If no outbound call has occurred for a while, then the inbounc GV call is answered by Google's voice mail saying the subscriber is not available.

This sure sounds like a registration issue to me, but "pjsip show registrations" says "registered" both before an unsuccessful call and a successful one.

Any ideas please?
 

ABSGINC

You can call me Scott.
Joined
Oct 1, 2014
Messages
59
Reaction score
31
Location
Flint, MI
@John123 -- I noticed I had to perform another fwconsole restart this morning as I was getting this happening again. -- I've only had this happen twice --- during this time of failure my PBX is not alerted to inbound calls, . If I have Google Hangouts activated on a device I can see the call coming in there, but the PBX sees nothing. and it cannot successfully send outbound through the channel after I notice it is not receiving inbound even though the PBX says that it is still registered. -- Did you also notice less frequent or halted pjsip registrations that come through the Full Log? I feel as though that stops, and I am unsure why.. Maybe it is a qualify ptime issue for the trunk registration. Anyone else have any thoughts here?
 

John123

New Member
Joined
May 15, 2015
Messages
7
Reaction score
0
I turned pjsip logging on as well as debug and verbose. When I place an outbound call I see the "congestion" message, and the call fails. Then asterisk immediately registers with GV. The registration is successful, which explains why, if I immediately retry the call it goes through, and incoming calls then work. pjsip show registrations indicated "registered" before placing the first call though, but obviously the trunk wasn't registered. Inbound calls don't work even though the GV trunk shows as registered, until I place a call and it re-registers. After several minutes, the whole scenario can be repeated. It seems to be more than a minute or two, but not much longer.

I've tried a bunch of googling around and suggested changes, but backed them all out because none have worked so far.
 

John123

New Member
Joined
May 15, 2015
Messages
7
Reaction score
0
Success, I think! Long story short, I set the TCP timeout on the router to 3600, which is the GV registration expiry time and all is well, so far. But this does indicate that keep-alive packets are not being sent, or at least not handled properly otherwise the timeout would have been detected. @ABSGINC, with the missing keep-alive, if the connection drops, it would be reestablished until a bit before the registration timeout, which is an hour.
 

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,314
Messages
136,938
Members
14,539
Latest member
andrewbyrd70