SOLVED Help with Twilio SIP setup

Kalash

New Member
Joined
Apr 20, 2017
Messages
9
Reaction score
3
Hi everyone,
Does anyone have experience or currently runs Twilio SIP trunk on Wazo/Xivo and could help me with setting?

I've been trying to setup Twilio on Wazo 17.05.

So far I've been able to setup few Gvoice trunks successfully, so I know that PBX itself works fine.

Now as for Twilio, I've followed various instructions on their website, as well as looked at some online tutorials, but I just can't seem to get it to work.

On the out_call I get "the caller is not accepting calls, on the In_call it just goes to "this call can not be completed at this time.

I've white-listed twilio's IPs as well as my FQDN {example}.pstn.twilio.com on Wazo

I've been beating my head against it for like 6 hours trying different setting, but I just can't get it to work. I've checked over and over the credentials and IP's so I don't understand why it's not communicating.
 

Kalash

New Member
Joined
Apr 20, 2017
Messages
9
Reaction score
3
Hello Sylvain,

Could you please be a little more specific.

Is it in my PBX? Under SIP Trunk is it in General,Register,Signaling or Advanced? and what specific checkbox?
 

Kalash

New Member
Joined
Apr 20, 2017
Messages
9
Reaction score
3
Marking this a Solved, big thanks to Sylvain Boily

for people that might need the answer to this.

to be able to make outbound calls I had to add +1 to extern prefix

to be able to receive inbound calls I had to go to IPBX configuration>contexts and list the number there, and DO NOT forget the 1 in your Calls Management>incoming calls!
 
  • Like
Reactions: Sylvain Boily

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,317
Messages
136,983
Members
14,545
Latest member
aigyu