TIPS Gotcha-Free PBX: Fax Sending Problems

Joined
Nov 19, 2007
Messages
170
Reaction score
7
Location
Georgia
Just finished installing incrediblefax11 on my RPi, and am not getting the faxes to send out. Here's my log:

-- Accepting AUTHENTICATED call from 127.0.0.1:
-- > requested format = ulaw,
-- > requested prefs = (),
-- > actual format = ulaw,
-- > host prefs = (ulaw),
-- > priority = mine
-- Executing [[email protected]:1] Dial("IAX2/iax-fax3-1353", "local/[email protected]") in new stack
[Feb 19 11:19:21] NOTICE[31004][C-00000002]: chan_local.c:971 local_call: No such extension/context [email protected] while calling Local channel
-- Couldn't call local/[email protected]
== Everyone is busy/congested at this time (0:0/0/0)
-- Executing [[email protected]:2] Goto("IAX2/iax-fax3-1353", "outbound-allroutes,18553301239,1") in new stack
-- Goto (outbound-allroutes,18553301239,1)
-- Executing [[email protected]:1] NoOp("IAX2/iax-fax3-1353", "SIPDOMAIN=") in new stack
[Feb 19 11:19:21] WARNING[31004][C-00000002]: chan_sip.c:22073 func_header_read: This function can only be used on SIP channels.
-- Executing [[email protected]:2] Set("IAX2/iax-fax3-1353", "FROM_IP=") in new stack
-- Executing [[email protected]:3] GotoIf("IAX2/iax-fax3-1353", "0?hangup,1") in new stack
-- Auto fallthrough, channel 'IAX2/iax-fax3-1353' status is 'CHANUNAVAIL'
-- Executing [[email protected]:1] NoOp("IAX2/iax-fax3-1353", "SIPDOMAIN=") in new stack
[Feb 19 11:19:21] WARNING[31004][C-00000002]: chan_sip.c:22073 func_header_read: This function can only be used on SIP channels.
-- Executing [[email protected]:2] Set("IAX2/iax-fax3-1353", "FROM_IP=") in new stack
-- Executing [[email protected]:3] GotoIf("IAX2/iax-fax3-1353", "0?hangup,1") in new stack
I have looked at extensions-custom.conf, and my from-fax context looked like this:
Code:
[from-fax]
exten => _x.,1,Dial(local/${EXTEN}@from-internal)
exten => _x.,n,Goto(outbound-allroutes,,1)
exten => _x.,n,Hangup
so I changed the second line to this per the instructions in another thread:
Code:
[from-fax]
exten => _x.,1,Dial(local/${EXTEN}@from-internal)
exten => _x.,n,Goto(outbound-allroutes,${EXTEN},1)
exten => _x.,n,Hangup
but the problem still exists.

I would not put it past me that I configured something wrong. I'm trying to use GV for the outgoing (hence the "1" prefix). If I dial that fax number directly with phone, I hear the receiving fax machine answer, so I know it's there.
 
Joined
Nov 19, 2007
Messages
170
Reaction score
7
Location
Georgia
Wow. That did it. It went right out GV when removing the prefix (1 or 9 when trying other providers). Confirmed the fax shows up on Fax Toy.
 

Mark-G

New Member
Joined
May 21, 2015
Messages
1
Reaction score
0
My google-fu is failing me to get the fax working. AvantFax page reports no dial tone when attempting to fax out. Inbound faxes are not working either. This is on a Pi2 and using GVoice. After initial GV setup the voice line worked.. I changed the config file as mentioned in your blog post to activate the fax, rebooted, restarted etc to no effect. One post found mentioned changing the dialout string for the modems (see http://blog.agate.io/post/25504962228/hylafax-no-local-dialtone-solved) but scowering the configs I couldn't find the location of the string to test. Any ideas?
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,367
Messages
137,356
Members
14,575
Latest member
Issue