SUGGESTIONS Google Voice OAUTH Custom Domain

classicalmusic

New Member
Joined
Apr 21, 2015
Messages
29
Reaction score
13
Location
Salt Lake City, UT
I have a Google Voice number associated with a Custom Domain. Let's say my email is [email protected]. How do I enter this into the ./add-gvtrunk and in the WAZO web interface. I remember FreePBX version of IncrediblePBX allowed me to use custom domain.

I put in [email protected] however in the website the name field doesn't allow @ symbol.

Customized Trunk Settings:
Name: [email protected]
Interface: Motif/[email protected]
Suffix: @voice.google.com
Context: Outcalls (to-extern)

Incoming Calls Settings:
DID: 8015551212
Context: Incalls (from-extern)
Destination: Your Choice
Redirect to: Your Choice
Ring time: 30

Outgoing Calls Settings:
Name: [email protected]
Context: Outcalls (to-extern)
Preprocess subroutine: subr-gv-outcall
Selected trunk: [email protected]
Exten + Stripnum: Must Be Unique

I'll continue to play around with this. Any help would be appreciated!

Thanks!
 

sipbit

New Member
Joined
Mar 4, 2016
Messages
5
Reaction score
1
This affects me as well. My Google Voice number is set up on a Google Apps account with a custom domain.

For what it's worth, my main personal Google account, while not part of a Google Apps account on a custom domain, also uses a non-Gmail e-mail address as the login username.

I realize this isn't how the majority of Google accounts are set up. But these types of accounts do exist, and it would be nice to see them supported again.
 

billsimon

Experienced in Asterisk, FreePBX, and SIP
Joined
Jan 2, 2011
Messages
946
Reaction score
294
For what it's worth, my main personal Google account, while not part of a Google Apps account on a custom domain, also uses a non-Gmail e-mail address as the login username.

I realize this isn't how the majority of Google accounts are set up. But these types of accounts do exist, and it would be nice to see them supported again.
Google accounts that are neither GMail nor Google Apps won't work. If you have, for example, [email protected] that is the login for your Google Voice account, you will have to transfer that number to GMail or a GApps account (with GMail) for it to work.

The reason is that only GMail and GApps accounts can log in to the Google Chat (XMPP) service, which is what is being used here to connect the PBX to Google Voice.
 

sipbit

New Member
Joined
Mar 4, 2016
Messages
5
Reaction score
1
Google accounts that are neither GMail nor Google Apps won't work. If you have, for example, [email protected] that is the login for your Google Voice account, you will have to transfer that number to GMail or a GApps account (with GMail) for it to work.

The reason is that only GMail and GApps accounts can log in to the Google Chat (XMPP) service, which is what is being used here to connect the PBX to Google Voice.
Thanks for sharing that. I guess Google is tying Google Chat to having Gmail on an account.
 

classicalmusic

New Member
Joined
Apr 21, 2015
Messages
29
Reaction score
13
Location
Salt Lake City, UT
Google accounts that are neither GMail nor Google Apps won't work. If you have, for example, [email protected] that is the login for your Google Voice account, you will have to transfer that number to GMail or a GApps account (with GMail) for it to work.

The reason is that only GMail and GApps accounts can log in to the Google Chat (XMPP) service, which is what is being used here to connect the PBX to Google Voice.
Hi Bill,

It works on the incrediblePBX 13_12.2 running Ubuntu and the CentOS version I have played with, too. Both running with OAUTH. Are the these versions connecting to Google differently than WAZO? I think it is as @wardmundy said...the scripts need to be modified for Google Apps (custom domain [email protected]).

For now the Ubuntu or Centos version works for my needs. Maybe one of these days I'll take a peek at the scripts in WAZO but unfortunately my work and family time prevents much play now days. :)
 

billsimon

Experienced in Asterisk, FreePBX, and SIP
Joined
Jan 2, 2011
Messages
946
Reaction score
294
Hi Bill,

It works on the incrediblePBX 13_12.2 running Ubuntu and the CentOS version I have played with, too. Both running with OAUTH. Are the these versions connecting to Google differently than WAZO? I think it is as @wardmundy said...the scripts need to be modified for Google Apps (custom domain [email protected]).

For now the Ubuntu or Centos version works for my needs. Maybe one of these days I'll take a peek at the scripts in WAZO but unfortunately my work and family time prevents much play now days. :)
Please check back at what I wrote. Google Apps and GMail are fine. It's the other kinds of accounts that are neither GApps nor GMail that will not work.
 

classicalmusic

New Member
Joined
Apr 21, 2015
Messages
29
Reaction score
13
Location
Salt Lake City, UT
Update:

I used this info to modify the motif.conf and xmpp_oauth.conf to somewhat work:

XIVO Google Voice setup for Google Apps Account

I can make outbound calls, however incoming calls not working. It's like the trunk isn't registered because it goes to GV voice mail. The logs don't show any type of incoming activity... only the outbound activity.

Here is what I have. Keep in mind Google voice email has been changed for privacy to [email protected] and tele 555-555-5555


xmpp_oauth.conf

Code:
[general]

;# // BEGIN abc_xyz_com
[abc_xyv_com]
type=client
serverhost=talk.google.com
[email protected]
secret={oauth refresh_token}
port=5222
usetls=yes
usesasl=yes
status=available
statusmessage="I am Available"
timeout=5
priority=127
;# // END abc_xyz_com
motif.conf

Code:
;# // BEGIN abc_xyz_com
[abc_xyz_com]
context=from_abc_xyz_com
disallow=all
allow=ulaw
connection=abc_xyz_com
;# // END abc_xyz_com

In WAZO, my custom trunk:
Name: abc_xyz_com
Interface: Motif/abc_xyz_com
Interface Suffix: @voice.google.com
Context: Outcalls (to-extern)

Incoming Calls (I used one of your lines and modified it... also tried creating a new one):
DID: 8015555555
Context: Incalls (from-extern)
Destination: User
Redirect to: Incredible PBX
Ring Time: 30

I also tried redirecting it to one of the custom users already set up to the IVR demo. No go.

Any troubleshooting items anyone can think of? Thanks in advance!
 

Merlin

Member
Joined
Mar 10, 2017
Messages
37
Reaction score
1
You are a life saver. I've been pulling out my hair trying to figure why I cannot get incoming calls. Setting forwarding number to google chat fixed it.
 

gabrielsallum

New Member
Joined
Jun 14, 2018
Messages
1
Reaction score
0
hello all, kinda late here but didn't see some simple solution to this for the home gamer like myself so:


reading this I've editied the file :
/var/www/html/admin/modules/motif/page.motif.php

around line 43 , you can see the line :
$un = preg_match('/@/i',$un) ? $un : $un . '@gmail.com';

change that @gmail.com with your @<domain.tldn> there, save the file
than, in the UI, add the trunk as per instructions, then just change it back, if you want.
in my case that's the only trunk I've really needed so....
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,317
Messages
136,958
Members
14,541
Latest member
matpots64