FOOD FOR THOUGHT Fresh Ubuntu 18.04.1 Install + PIAF = Broken

Discussion in 'PBX in a Flash 5' started by ASItechsupport, Aug 6, 2018.

  1. ASItechsupport

    ASItechsupport New Member

    Joined:
    Oct 30, 2008
    Messages:
    26
    Likes Received:
    5
    Hello all!

    Finally I'm getting time to update my very old PIAF, and decided to start fresh in a virtualized environment. So I started down the path of following the article Summer Surprise: It’s Incredible PBX 13-13 for Ubuntu 18.04, but the initial result was that amportal was not found and so everything was broken. I've now tried this 3 times and end up with the same result each time. However, if I instead use a 18.04 lxc template, then everything comes up fine after the script finishes. So I'm wondering if there's a wrinkle introduced with Ubuntu 18.04.1 ISO installation that is causing the PBIAF script to error out...??

    Here's the exact steps I'm following:
    1. Proxmox VE 5.2 is my VM platform
    2. Download Ubuntu 18.04.1 Server from here: https://www.ubuntu.com/download/server
    3. Install Ubuntu into the VM with the downloaded ISO
    4. Setup the root user password
    5. "su root" into the root user and change directory to /root
    6. download the PIAF script from: http://incrediblepbx.com/incrediblepbx-13-13U-LEAN.tar.gz
    7. untar and run the two commands in the article
    8. End result = no amportal... and webmin isn't installed either.
    I have the latest failure log file available if you can point me in the direction of what I might want to look for and post here...

    But am I missing something obvious?

    Here's a screenshot of the resulting web page error when I go to the IP address: PIAF_Fail.png
     
    #1 ASItechsupport, Aug 6, 2018
    Last edited: Aug 6, 2018
  2. ASItechsupport

    ASItechsupport New Member

    Joined:
    Oct 30, 2008
    Messages:
    26
    Likes Received:
    5
    Figured this out... So the first run of the IncrediblePBX script was showing an error, and I wasn't catching it.

    I'll detail my findings here so it might help someone else... and maybe Ward can adjust the script to account for this situation...?

    So the message I was seeing was:
    Unable to locate package selinux-utils​

    Looking at Ward's script I see that on the first run he's attempting to install that package. So I attempted to manually install selinux-utils, and found it wasn't getting installed. But it worked on a Ubuntu 18.04 LXC container, so lets check what the sources.list looks like... bingo

    So the sources.list of Ubuntu Server 18.04.1 is:
    deb http://archive.ubuntu.com/ubuntu bionic main
    deb http://archive.ubuntu.com/ubuntu bionic-security main
    deb http://archive.ubuntu.com/ubuntu bionic-updates main​

    But on the working LXC container, the sources.list is:
    deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse​

    Well there is the problem, not all the repos are enabled when installing from iso! There are no options during the install to enable additional repos, so there's no way to direct a user to enable these. So I'd suggest that we put a check into the script to check for the vanilla lines and add the additional "universe multiverse" so that everything works as expected.



     
    chris_c_ likes this.
  3. wardmundy

    wardmundy Nerd Uno

    Joined:
    Oct 12, 2007
    Messages:
    14,172
    Likes Received:
    2,391
    Hi John,

    Thanks for the update. 18.04.1 was supposed to be an LTS bugfix. But they changed the sources.list which was correct in 18.04. Anyway, we've added it back into the installer so it won't be a problem... at least until 18.04.2. Thanks again.
     
  4. ASItechsupport

    ASItechsupport New Member

    Joined:
    Oct 30, 2008
    Messages:
    26
    Likes Received:
    5
    Huzzah, glad I could help! :clap:
     
    wardmundy likes this.

Share This Page