TIPS Failure to boot incredible pbx after moving VM to new vlan

ilovepancakes95

New Member
Joined
Aug 14, 2018
Messages
26
Reaction score
1
Moved the VM (CentOS) running Incredible PBX to a new port group on a different vlan. Need to change the IP settings for the "ethernet" interface but after booting up the VM after making the network port change, I get the following. Once it gets to the starting sendmail part it goes really really slow from there and eventually comes up with these errors and then tries to shutdown asterisk and then it hangs on stopping fail2ban and does nothing anymore. It appears the errors and fail to boot have to do with it not getting a network connection I think but if I can't even boot up how do I change the IP so it can work?

2408
 

dallas

Active Member
Joined
Oct 21, 2007
Messages
226
Reaction score
33
Location
Sydney, Australia
There is more to changing the IP address of the VM than just changing the ethernet interface.
httpd will still be trying to bind to the old address and the same applies to Asterisk. There may be more changes need too.
 

ilovepancakes95

New Member
Joined
Aug 14, 2018
Messages
26
Reaction score
1
There is more to changing the IP address of the VM than just changing the ethernet interface.
httpd will still be trying to bind to the old address and the same applies to Asterisk. There may be more changes need too.
Great, I'd love to know how to do that then. There are some other VMs I had running Nginx, Apache, etc... other services and changing the IP of the OS worked fine as I assume the web servers and stuff look at the IP of the OS in the end. Not saying this is definitely the case with Incredible PBX but figuring there must be a way to do it... But it won't even boot which I don't get at all.
 

atsak

Guru
Joined
Sep 7, 2009
Messages
1,834
Reaction score
193
fail2ban hangs when there is no internet connection. If you wait about 10 minutes it usually times out, but sometimes not. Before you move it, delete the /etc/udev/rules.d/70-persistent-net.rules and you should find everything works, or even disable fail2ban for the first boot.
 
  • Like
Reactions: ilovepancakes95

ilovepancakes95

New Member
Joined
Aug 14, 2018
Messages
26
Reaction score
1
fail2ban hangs when there is no internet connection. If you wait about 10 minutes it usually times out, but sometimes not. Before you move it, delete the /etc/udev/rules.d/70-persistent-net.rules and you should find everything works, or even disable fail2ban for the first boot.
OK, getting closer.... it did actually boot up like you said after waiting about 15 minutes once it appears to hang. So now I can get in to CentOS, I changed the IP and gateway by modifying the appropriate ifcfg-eth0 file in /etc/sysconfig/network-scripts, and I also updated /etc/sysconfig/network. In both those areas I put the new DNS server address but after rebooting /etc/resolv.conf still shows my old DNS server address which can't be used anymore.

How do I get the system to update the DNS address in resolv.conf with the value I entered in the other two files? It did accept the new IP and GUI seems to work on that IP. I can ping WAN IPs but not DNS names because I guess the system still wants to use old DNS server.

Also, should I still delete the file you mentioned or not necessary because it did boot?
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,608
Reaction score
438
Location
South Florida
How do I get the system to update the DNS address in resolv.conf with the value I entered in the other two files? It did accept the new IP and GUI seems to work on that IP. I can ping WAN IPs but not DNS names because I guess the system still wants to use old DNS server.
I like to use to webmin ... I think it's https://ip_address:9001 or :10001 depending on how its set up and which version you've got.
 

atsak

Guru
Joined
Sep 7, 2009
Messages
1,834
Reaction score
193
PS no need to delete the file whatever Hypervisor you're using is moving the MAC address so should be fine.
 

ilovepancakes95

New Member
Joined
Aug 14, 2018
Messages
26
Reaction score
1
Is system-config-network installed? Use that.
Ahh okay, I thought the command was nmtui for some reason and that wasn't working. So your command opens up and lets me change the settings but I get this upon saving and exiting. I did try the command as "sudo system-config-network" as well.
2411
 

ilovepancakes95

New Member
Joined
Aug 14, 2018
Messages
26
Reaction score
1
I like to use to webmin ... I think it's https://ip_address:9001 or :10001 depending on how its set up and which version you've got.
Also, turns out I do have webmin installed, thought I didn't. So I went there, login as root, and changed the DNS address which is still set to the old and I get this when I try to save the config in webmin:

Failed to save DNS configuration : Failed to replace /etc/resolv.conf with /etc/resolv.conf.webmintmp.29043 : Operation not permitted
 

krzykat

Guru
Joined
Aug 2, 2008
Messages
1,608
Reaction score
438
Location
South Florida
Also, turns out I do have webmin installed, thought I didn't. So I went there, login as root, and changed the DNS address which is still set to the old and I get this when I try to save the config in webmin:

Failed to save DNS configuration : Failed to replace /etc/resolv.conf with /etc/resolv.conf.webmintmp.29043 : Operation not permitted
lsattr /etc/resolv.conf
lsattr /etc/resolv.conf ----i-------- /etc/resolv.conf


The "i" means it's a file that's been given the immutable attribute, meaning no one, not even root, can edit that file.

That's not something that occurs by default, so something, or someone, had set that after the server was setup :)

You can unset that by running this command:

chattr -i /path/to/file

Once you do that, you should be able to edit those files.
 

ilovepancakes95

New Member
Joined
Aug 14, 2018
Messages
26
Reaction score
1
lsattr /etc/resolv.conf
lsattr /etc/resolv.conf ----i-------- /etc/resolv.conf


The "i" means it's a file that's been given the immutable attribute, meaning no one, not even root, can edit that file.

That's not something that occurs by default, so something, or someone, had set that after the server was setup :)

You can unset that by running this command:

chattr -i /path/to/file

Once you do that, you should be able to edit those files.
That worked! File edited with system-config-network and DNS working again. behavior of OS and Incredible PBX seems to have gone back to normal (booting faster, etc..).

Thank you! (and now I know about immutable attributes) ;)

Take a look at raspi-config -> network
On CentOS 6.
 
  • Like
Reactions: krzykat

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,514
Messages
138,539
Members
14,644
Latest member
goseph