SOLVED Changing the default interface

kcallis

Member
Joined
Oct 23, 2007
Messages
137
Reaction score
3
Location
Little Rock, AR
I am running Incredible PBX CentOS 6.9 on a Open VZ host on HIFormance or at least I am trying to run Incredible PBX. I have been trying to get knockd working, but every time I try to active knockd, it fails because it can't access the interface (eth0). My virtual interface is venet0:0 and although IncredPBX seems to find the interface, CentOS defaults to eth0.

Is there some way to get systemd-networkd to default to the venet0.0 interface as opposed to the eth0 interface?
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,411
Reaction score
2,736
@kcallis: The config file to modify is /etc/sysconfig/knockd and the syntax: OPTIONS="-i venet0:0". Then restart: service knockd restart.
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,571
Messages
138,917
Members
14,674
Latest member
gnordli