FYI Can't login ssh after new install, all ports blocked

hostile

New Member
Joined
Nov 20, 2015
Messages
6
Reaction score
0
Hi, I am new to Incredible pbx. Not new to linux tho.

My prob is, I installed it both on Ubuntu 14 and Centos

I went okay, at the end server rebooted and I logged in, it check for updates, I hit enter a,d after that Unable to login anymore, had to delee server from panel, Happened twice already.

Whats im missing?

I got to the point when I got that gui that shows time and all services are up, the n it restart, I login to root and got choice update hit enter or ctrl + c for cancel

Update makes all ports blocked.

Should I cancel it and run scripts for firewall? iptables?

I dont want it block at all, how to switch it or allow all connections from any IP, for testing.

And if use firewall how to do it for dynamic IP, My IP is dynamic...

I install it on cloud at cost remotelly.

Thanks for help
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,320
Reaction score
2,700
If your local IP changes regularly, then use PortKnocker to get back in and add the IP address. We'd recommend you set up your local machine with a dynamic DNS updater and then add that FQDN to your server with /root/add-fqdn. Then you won't get locked out.
 

hostile

New Member
Joined
Nov 20, 2015
Messages
6
Reaction score
0
Is it way to switch it off?

Or whitelist any ip

And it was blocking port 80 too cuz gui didnt worked

is it port knocker already preinstalled with this? http://nerdvittles.com/?p=14183

Thx
 
Last edited:

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,320
Reaction score
2,700
You don't want to turn off the firewall on a Cloud-based platform with no hardware-based firewall to protect you.

PortKnocker should be there. Look in the /root folder for your credentials... knock.something
 

hostile

New Member
Joined
Nov 20, 2015
Messages
6
Reaction score
0
I temporary allowed all traffic on any open porst for testing / learning.

I got new issue

I can call demo 3366 but only when im on WIFI

When I use mobile phone data 3G/4G there is no response from pbx

Any idea

thank you
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,320
Reaction score
2,700
Don't run a PBX on the public Internet without a firewall unless you have a big wallet to pay your phone bills!!! That's a lesson you don't want to learn. :batman:

If you're just getting started, you are much safer installing Incredible PBX on an old PC that's lying around and experiment BEHIND a hardware-based firewall where it's safer to turn off the included firewall. A new tutorial is now available on Nerd Vittles tomorrow.
 
Last edited:

rchalk

Member
Joined
Feb 19, 2010
Messages
285
Reaction score
21
Location
N.E. GA, USA
If using a cloud server such as RentPBX, make sure the port number for SSH is included in the add-fqdn script. In Travelin Man 3, the SSH ports are 22, and 9022, but the rentPBX port is 20022.

Edit the script to add a comma, and 20022 right after the 9022, so the line looks like this:
entry[8]="-A INPUT -p tcp -m multiport -s $iptest --dports 22,9022,20022 -j ACCEPT"
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,510
Messages
138,507
Members
14,637
Latest member
gatoambroggio