SOLVED AnveoDirect on Xivo - Incoming calls busy

SilentJ

New Member
Joined
Oct 6, 2016
Messages
2
Reaction score
0
I have a recent install of Xivo that I setup with Google Voice (via Simonics) and AnveoDirect. GV works flawlessly as does outbound calling on Anveo. However, when I dial into the Anveo number I get a busy signal and this line in the logfile:

NOTICE[1750][C-00000010] chan_sip.c: Call from 'AnveoDirect' (50.22.101.14:5060) to extension '1xxxxxxxxxx' rejected because extension not found in context 'to-extern'.​

My first thought is that this is caused because I did something wrong with the code that Ward instructed to be placed in extensions_custom.conf (see http://nerdvittles.com/?p=5680). This file did not exist on my machine, so I placed it in extensions.conf.

I also have a question as to why the error message references an incoming call to an outgoing context (all my incoming trunks use the 'from-extern' context).

I have easily spent over 40 hours troubleshooting this to no avail. Any help would be greatly appreciated.


P.S. A quick shout out... Ward, thanks for helping to make PBXs an accessible tool for the rest of us.

UPDATE: The logfile provided the needed clue. I had a trunk for sbc.anveo.com for outgoing calls and another for 50.22.101.14 for incoming calls. It turns out, sbc.anveo.com resolves to 50.22.101.14; thus, the incoming call was being picked up on the trunk set up for outgoing calls (with the context 'to-extern'). I simply disabled the outgoing trunk and I can now receive calls.
 
Last edited:

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,319
Messages
137,021
Members
14,550
Latest member
treimers