TIPS Anveo Direct with Incredible PBX 13-13

desmondfuller

New Member
Joined
Mar 20, 2009
Messages
22
Reaction score
1
I decided I've had enough of Woot and have setup shop on Vultr. I ran thru the latest "Summer Surprise" article and have gotten stumped why I can't get Anveo working.

I have enable the Anveo-1 thru 5 trunks. I have change the SIP trunk with the new IP ([sip] $[E164][email protected]) on Anveo.

When I call my DID, it immediately goes to the PSTN failover number I've setup so I'm guessing it isn't even getting thru to the PBX.

Any trouble shooting tips?
 

batchris

New Member
Joined
Nov 15, 2015
Messages
4
Reaction score
0
I use an Anveo Direct DID for a conference line. I have the per minute/10 channel service. I only have experience with that setup, which may be totally different from yours, so forgive me if this suggestion is way off base.

Are you able to directly call a SIP URI for one of your inbound trunks?

In my experience, Anveo Direct's DIDs have to be pointed to something else, like a URI or a PSTN number. If it cannot access your trunk, that may be why it's failing over to your PSTN. In my case, I have two VOIP.ms URI's set up as the primary and failover for my Anveo DID.

Anveo also offers channel services, but I haven't used them, so I can only assume that you get a SIP URI for each channel and use the Forward on Busy function to ring each channel.

Try setting up one of your trunks to deliver to something that auto answers, like an IVR or a conference extension, and place a few test calls to the URI for that trunk. Once your PBX is picking up when you call the URI, then try forwarding your Anveo DID to that same URI and see what happens. That's what I did when I was figuring my conference setup.

Hope this is helpful.

~chris
 

jreming

Member
Joined
Mar 27, 2019
Messages
30
Reaction score
6
You can dump all those sip trunks and replace it with a single much more reliable pjsip trunk

----------------------------------------------------------

Add SIP (chan_pjsip) Trunk
[General]
Trunk Name - Anveo ... or whatever

[Dialed Number Manipulation Rules]
Outbound Dial Prefix - set if you use prefix for anveo, otherwise ignore

[pjsip Settings]
[General]
Authentication - None
Registration - None
SIP Server - sbc.anveo.com
SIP Server Port - 5060
Context - from-pstn-e164-us

[Advanced]
Qualify Frequency - 0 (not sure it matters)
Match (Permit) - 50.22.101.14/32, 67.212.84.21/32, 176.9.39.206/32, 50.22.102.242/32, 72.9.149.25/32
Support Path - Yes

pretty sure the other stuff is fine default, but I enabled Direct Media

[Codecs]
Pretty much enable all you want in the order you want, never know if a server will support it, ulaw is going to be accepted everywhere as well but if you want a wideband or something with better quality move it to the top and hope for the best

----------------------------------------------------------

On Anveo, add server to Authorized IP list (optional, and my preference vs prefix)
[Destination SIP Trunks]
$[E164][email protected]:5061
 
  • Like
Reactions: wardmundy

Hometech

Member
Joined
Mar 9, 2008
Messages
161
Reaction score
16
Location
Leo, IN
Hey is this Anveo Trunk setup for inbound and outbound calls? so use this for both? Also no user or password is needed?
 

jreming

Member
Joined
Mar 27, 2019
Messages
30
Reaction score
6
@Hometech Yes, its 1 trunk that covers both inbound/outbound calls. Also since its pjsip you do not have to worry about not having any of the connection or audio issues associated with the normal sip trunks caused by not having the ip address of the actual sip server.
 

Hometech

Member
Joined
Mar 9, 2008
Messages
161
Reaction score
16
Location
Leo, IN
OK Great! I set it up but in my log I see this message:

ERROR[1649] res_pjsip.c: Unable to retrieve PJSIP transport 'udp'

Do I need to set something else up?

Thanks
 

jreming

Member
Joined
Mar 27, 2019
Messages
30
Reaction score
6
did you change the endpoint on anveo to the correct port 5061 instead of 5060?
 

Hometech

Member
Joined
Mar 9, 2008
Messages
161
Reaction score
16
Location
Leo, IN
I did do this at Anveo's site $[E164][email protected]:5061

at the PBX I have this:

[pjsip Settings]
[General]
Authentication - None
Registration - None
SIP Server - sbc.anveo.com
SIP Server Port - 5060
Context - from-pstn-e164-us

does the 5060 need to change here?
 

Hometech

Member
Joined
Mar 9, 2008
Messages
161
Reaction score
16
Location
Leo, IN
I missed one setting Qualify Frequency - 0
The error messages stopped.

thanks
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,450
Messages
138,038
Members
14,613
Latest member
roshan2019