401 unauthorized number on toll-free inbound

rn2018

New Member
Joined
Jul 2, 2018
Messages
7
Reaction score
1
Hello everyone,
I have an Incredible PBX system up and running with inbound toll-free and landline numbers.
I'm using Twilio as my PSTN provider.
When a call comes in on landline number there's no problem - the call is being answered like configured.

When someone calls my toll-free number an error busy tone is being played on the line. When checked the PCAP file it seems the PBX returns a 401 error msg.
Status-Line: SIP/2.0 401 Unauthorized
Status-Code: 401
[Resent Packet: False]
[Request Frame: 1]
[Response Time (ms): 77]

Here's the request info:
Request-Line: INVITE sip:[email protected]***.***.***.*** SIP/2.0
Method: INVITE
Request-URI: sip:[email protected]***.***.***.***
Request-URI User Part: +18338204971
E.164 number (MSISDN): 18338204971
Country Code: Americas (1)


Both being handled by the same incoming trunk. Tried even configure another trunk (makes no sense but tried anyway) - didn't work.

I verified the DID pattern on inbound route is correct, and even remove it to "ANY" - didn't fix it.

I have a reason to believe the call is being rejected to even before the inbound route as when I change the landline DID it gives a recording saying number is not recognize.

Only thing I was able to do to bypass was to set "Allow Guest" on SIP settings - then the toll free number is being answered but now i'm getting 500 error responses on my logs on Twilio.

Any ideas on how to fix this will be greatly appreciated!

Thanks,
Rn2018
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,456
Messages
138,073
Members
14,620
Latest member
Brads#Bell