TIPS 16-15 Inbound Route - where is Fax Recipient Destination?

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
I'm setting up a new machine to replace my PIAF Green PBX.

I have Centos 7 and 16-15 set up on a local machine.

I'm trying to set my first inbound route, and 'Fax Recipient' is no longer a a valid destination.

I have my own incoming fax line directed to Hylafax on my current machine - and I get the emails. I have a friend's business fax line going to 'Fax Destination' and he gets his incoming faxes.
I'm trying to replicate this setup, but I'm now lost by a seemingly missing feature.

Andrew
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,011
Reaction score
207
@AndyInNYC By default the fax module is disabled in IncrediblePBX 16-15. You need to go to the module admin page and enable it. Then it will be marked back out of service requiring you to upgrade it. Try this from the Linux command line: fwconsole ma --edge upgrade fax and then fwconsole reload. If you cannot access the edge repository from FreePBX, you'll have to ask @wardmundy to add the latest version of the module (fax v15.0.18) to the IncrediblePBX repository.

If you are able to successfully upgrade the module and enable it, you will have a FAX tab on the inbound route.
 

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
Thanks, Kenn10. I'll try this.

Edit:
Code:
No repos specified, using: [standard,extended,unsupported] from last GUI settings

fax is not a locally installed module, unable to upgrade
Updating Hooks...Done
Chowning directories...Done
Resetting temporarily repository state
WARNING: Always run Incredible PBX behind a secure firewall.
So, no joy. Ward, any help?



Andrew
 
Last edited:

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,011
Reaction score
207
@AndyInNYC look in your /root directory at the script called resetting-module-repository. Use the line of code to find out what your current repository is and write it down. Then use the commands listed to reset the repository to https://mirror.freepbx.org.

In the GUI for IncrediblePBX, go to Settings >> Advanced Settings and scroll down to GUI Behavior. Look for "Set module admin to Edge mode" and set it to yes. Submit and apply changes.

Then the commands I listed in Post #2 above will work. After you grab the fax module, set your repository back to the original to avoid messing other things up with modules that aren't ready for prime-time. In the IncrediblePBX GUI, go back and turn edge mode off in the Advanced settings.

Do any of this at your own peri; especially if you grad other modules.. IncrediblePBX is entirely open source and the FreePBX repo can introduce non-open source modules or modules not ready for general release. That is why Ward has a separate IncrediblePBX repository for the modules. Many of the upgraded modules from FreePBX will complain about invalid signatures. If you encounter this, use the script "sig-fix" in the /root directory to shut off that complaint.

Good luck.
 
  • Like
Reactions: wardmundy

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
I can't figure out what to do/change/fix from the script.

Would you be so kind as to elaborate on what I need to change or adjust?

Thanks

Andrew
 

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
If I run the script,

It returns:

Code:
+-------------+-------------------------------------------------------+-------------+
| keyword     | value                                                 | name        |
+-------------+-------------------------------------------------------+-------------+
| MODULE_REPO | http://mirror1.freepbx.org,http://mirror2.freepbx.org | Repo Server |
+-------------+-------------------------------------------------------+-------------+
What am I missing? Isn't this the repo I want?

I need help, because faxing is important, and I'm not sure I can get DID based routing to work in Avantfax.


Andrew
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,011
Reaction score
207
This is what mine is set too. Notice that it is https:// and not http:// The forum does not let me post the actual command to set it but use the one that says SET and use https://mirror.freepbx.org.

Code:
 mysql -u root -ppassw0rd asterisk -e "select keyword,value,name from freepbx_settings where keyword='MODULE_REPO';"
+-------------+----------------------------+-------------+
| keyword     | value                      | name        |
+-------------+----------------------------+-------------+
| MODULE_REPO | https://mirror.freepbx.org | Repo Server |
+-------------+----------------------------+-------------+
WARNING: Always run Incredible PBX behind a secure firewall.
I
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,011
Reaction score
207
@AndyInNYC I just installed an IncrediblePBX 16-15.2 version and could not get this to work from the command line. I finally removed the module and reinstalled it: You still need to set your module repo as shown above. Once done, use the commands below.

1) fwconsole ma delete fax or if that does not work, try fwconsole ma uninstall fax
2) fwconsole ma install fax

You may have to go back to the gui under Admin > Module Admin and enable the fax module once it is installed.
 

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
I was able to google a little differently and got some results.
After install, the fax config module IS installed (I thought I would need a fax module, not a config module).
The problem is that you need to go into User Management (under Applications) and 'enable' at least one user. This sends a email/whatever.

Fax Destination then shows up in Trunks.

Thanks for your help. I haven't put this into service yet (still lots to set up in my spare time), but at least the destination is set correctly.

Now I'm wondering if AvantFax 3.3.5 has fixed routing issues.

Andrew
 
  • Like
Reactions: kenn10

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
So, I'm still having a problem.

I have fax destination in my Inbound Route.
I have created a virtual extension which is targeted by the Route.

when I go into the virtual extension, however, there are NO fax options available. I have to tell the fax where to email itself, so there has to be something.

Again this is 16-15.2

I'm missing something obvious, but I can't yet figure it out.

Help?

Andrew
 

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,011
Reaction score
207
You're right. i don't see anything you can use except to intercept the fax and send it to another extension. The old FreePBX 13 allowed you to route to an extension's destination. Look at Admin > User Management. There is a FAX tab there that may give you some insight and ideas.

I don 't use fax but I think whatever the user's email address is will get the fax if you set up fax on the user admin page. Then route the incoming route to the extension of the user. Hopefully, it is smart enough to know that is a fax and then email it to the user.
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,239
Reaction score
2,667
I think we all need to consider removing faxing from the PBX equation. Almost all VoIP providers now provide fax DIDs for about $1/month plus pay-as-you-go pricing on calls. It's reliable. It's secure. And it's cheap. We spend and have spent an inordinate amount of time and technical talent wrestling with this for very little ROI. Just my $.02.
 
  • Like
Reactions: billsimon

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
I can't say I agree with you on this one, Ward. It's supposed to be 'built in' to freepbx and asterisk - I just can't tell what I'm doing wrong coming from an earlier version.

It's worked well for me for years (on Green); I can't see any reason to not include it since it should be a stable module.

Of course, you're doing the integration and development. I'm just a user.


Andrew
 

dicko

Still learning but earning
Joined
Oct 30, 2015
Messages
667
Reaction score
248
I personally have taken faxes outside Asterisk, it just doesn't have a solid fax solution IMHO

Hylafax however does, I would suggest using t38modem direct to your vsp that supports t38

Add email2fax and fax2email over postfix, (plenty of recipes around ;-) )

If you really want to have asterisk in the middle T38 pass-through generally works, just send them to hylafax.
 

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
Dicko,

I'm using hylafax/avantfax for 'my' faxes. Unfortunately, I have never been able to get Avantfax's DID based routing to work - now that I'm on 3.3.5 without an upgrade, maybe that will change.

Since my friend who uses my PBX for his business has a fax line, I have been sending his faxes to 'Fax Recipient' in the inbound route and all has been well (my PBX is still running Green). Now that I'm upgrading to 16.15.2 on Centos7, gui options have changed (like where's the email address the fax should be sent!).

Andrew
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,239
Reaction score
2,667
Settings -> Fax Configuration

NOTE: Reread the 16-15 documentation please. The last time I checked incoming faxes were broken in FreePBX 15. Stick with Incredible PBX 13-13 if you need reliable faxing.
 
Last edited:

AndyInNYC

Active Member
Joined
May 23, 2013
Messages
622
Reaction score
83
I've installed 13-13. Fax Configuration is a 'global' config of sorts. It's not a per user/extension system.

I'll set the email in the User Management for the extension and hope that works when I start sending faxes and testing; this assumes I get my SIP trunk with flowroute working (see my 16-15 issues, if you will).

Andrew
 

Members online

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,450
Messages
138,038
Members
14,613
Latest member
roshan2019