TIPS 13-13 to 16-15 upgrade issues

Keith Clendaniel

New Member
Joined
Oct 6, 2016
Messages
6
Reaction score
0
I am running through the posted instructions regarding upgrading 13-13 to 16-15 found here (http://nerdvittles.com/?p=30365) and it states "When the whirring stops, there will be an error message. Ignore it. Don’t click anything just yet." I am curious what that error message is. All i get is a SQL syntax error below but I think that is an issue with the admin user account that is for some reason getting hung up on the roles. I have tried changing the administrator account by add/delete and removing roles but the error remains. This appears to be blocking my import into the 16-15 instance.

SQL:
INSERT INTO `ampusers` VALUES ('admin','883178c2a67c73a47491672ab293691d4778f693','','','',_binary 'manager;backup_servers;backup_templates;ampusers;userman;users');SQLSTATE[HY000]: General error: 1 near "'manager;backup_servers;backup_templates;ampusers;userman;users'": syntax error
 

wardmundy

Nerd Uno
Joined
Oct 12, 2007
Messages
15,401
Reaction score
2,731
This is a new one. Undoubtedly, the (new) FreePBX Team has "improved" something.
 

Keith Clendaniel

New Member
Joined
Oct 6, 2016
Messages
6
Reaction score
0

kenn10

A lesser geek
Joined
Dec 16, 2007
Messages
1,036
Reaction score
220
There have been many module updates to FreePBX 15 since the initial IncrediblePBX 16-15 came out. You need to update a multitude of modules for the conversion to work correctly. This includes backup, core, framework, voicemail, userman...just to name a few.

I was surprised to see the continual module changes to a bunch of modules to fix backup issues. I believe that FreePBX 15 is still Beta so this is to be expected.
 
  • Like
Reactions: dhoppy

Keith Clendaniel

New Member
Joined
Oct 6, 2016
Messages
6
Reaction score
0
Unfortunately on this fresh install of IPBX 16-15 from yesterday it is not connecting to the freepbx servers for updates on the module admin screen, another thing I have to troubleshoot with the default firewall, so I have not pulled any module updates from them.
 

Keith Clendaniel

New Member
Joined
Oct 6, 2016
Messages
6
Reaction score
0
Post upgrade of all available module upgrades the error is the same. It is possible it is due to an update since this process was developed but subsequent updates have not resolved the issue. I do find it curious that this error was noted in an attempt to restore 14 to 15 during the development.
 

Keith Clendaniel

New Member
Joined
Oct 6, 2016
Messages
6
Reaction score
0
I ran the new backup installer Ward released. I was to understand mongo and sql was incorporated later in that thread?
 

Keith Clendaniel

New Member
Joined
Oct 6, 2016
Messages
6
Reaction score
0
David, I ran mongo and sqlite installs on both 13 and 15 systems. Both have all modules up to date. No change on the import attempt in regards to the SQL error. My guess is from the point that you came up with that solution and now they have changed the baseline code for the backup & restore module.
 

Members online

No members online now.

PIAF 5 - Powered by 3CX

Forum statistics

Threads
22,560
Messages
138,866
Members
14,669
Latest member
cleron