1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TRY THIS Strange IAX problem.

Discussion in 'Trunks' started by Cynjut, Oct 21, 2009.

  1. Cynjut

    Cynjut
    Expand Collapse
    Member

    Joined:
    Jul 15, 2009
    Messages:
    68
    Likes Received:
    8
    I started experimenting with some inbound IAX phone connections. They worked fine - but now the inbound trunk (also IAX2) with my main office number rings busy. Here are some of the log entries that I believe are pertinent:

    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: == Binding IAX2 to default address 0.0.0.0:4569
    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: -- Seeding '534' at 192.168.3.231:4569 for 60
    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: == Registered channel type 'IAX2' (Inter Asterisk eXchange Driver (Ver 2))
    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: == 10 helper threaads started
    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: == IAX Ready and Listening
    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: == Loaded firmware 'iaxy.bin'
    [2009-10-21 15:42:24] NOTICE[3344] iax2-provision.c: No IAX provisioning configuration found, IAX provisioning disabled.
    [2009-10-21 15:42:24] VERBOSE[3344] logger.c: chan_iax2.so => (Inter Asterisk eXchange (Ver 2))
    ...skipping
    [2009-10-21 15:43:11] VERBOSE[3373] logger.c: -- Format for call is ulaw
    [2009-10-21 15:43:11] VERBOSE[3565] logger.c: -- IAX2/VoipStreet-13260 is ringing
    [2009-10-21 15:43:11] NOTICE[3366] chan_iax2.c: Host 64.136.174.24 failed to authenticate as 534
    [2009-10-21 15:43:12] VERBOSE[3565] logger.c: -- IAX2/VoipStreet-13260 stopped sounds
    [2009-10-21 15:43:12] VERBOSE[3565] logger.c: -- IAX2/VoipStreet-13260 is busy
    [2009-10-21 15:43:12] VERBOSE[3565] logger.c: -- Hungup 'IAX2/VoipStreet-13260'
    [2009-10-21 15:43:12] VERBOSE[3565] logger.c: == Everyone is busy/congested at this time (1:1/0/0)

    Why on earth would my inbound IAX trunk be expected to try to authenticate as extension 534?

    As soon as I removed the IAX2 extensions, the inbound trunk worked just fine. This performs completely outside of my expectations. Any suggestions?

    I'm running PIAF with the most up-to-date software.
     
  2. jmullinix

    jmullinix
    Expand Collapse
    Guru

    Joined:
    Oct 21, 2007
    Messages:
    1,264
    Likes Received:
    6
    What phone are you using as an IAX client. I have seen this behavior with older versions of Zoiper.
     
  3. blanchae

    blanchae
    Expand Collapse
    Guru

    Joined:
    Mar 12, 2008
    Messages:
    1,922
    Likes Received:
    4
    Could be that you used the same name for the trunk as an extension or a restricted name like IAX2 (too general). The lines:

    [2009-10-21 15:43:11] VERBOSE[3565] logger.c: -- IAX2/VoipStreet-13260 is ringing
    [2009-10-21 15:43:11] NOTICE[3366] chan_iax2.c: Host 64.136.174.24 failed to authenticate as 534

    Indicate that there is a username/password issue. Have you checked that the IAX extensions or trunk require password authentication?
     
  4. jroper

    jroper
    Expand Collapse
    Guru

    Joined:
    Oct 20, 2007
    Messages:
    3,814
    Likes Received:
    53
    Hi

    What version of Asterisk are you using? If it is a later version then add something like


    calltokenoptional = 0.0.0.0/0.0.0.0
    maxcallnumbers = 16382

    to iax-general-custom.conf - check the filename!

    Adjust for your own requirements.

    Joe
     
  5. cvschleich

    cvschleich
    Expand Collapse
    Member

    Joined:
    Dec 17, 2007
    Messages:
    55
    Likes Received:
    0
    Old thread, but I ran into the same problem. Multiple PiaF servers on the campus all connected via IAX trunks and dundi. Then I tried adding a VoIPStreet IAX trunk for incoming calls, but it kept trying to authenticate against the dundi trunk between the servers and failing. Working it out with tech support at VoIPStreet we found adding:

    permit=<IP address of the other end of your trunk>

    to the "Incoming Settings" - "User Details" section in the trunk definition in FreePBX solved it for me.
     

Share This Page