TUTORIAL SIP Phones on VOICE Vlan via LLDP

AntonVP

New Member
Joined
Jan 28, 2016
Messages
16
Reaction score
2
Hi All,

Just wanted to share something that made my voice network setup a bit more elegant.
You know how Cisco phones are put on a voice vlan automatically via SWITCHPORT VOICE VLAN #?
We can achieve the same behavior with non-Cisco phones that support LLDP on the phone and switch sides. That way you can have a PC on a data vlan and all phone traffic (voice, dhcp and SIP control traffic) binded to a voice vlan on a single switch port. So when you plug in your SIP phone you don’t have to setup a voice vlan on it and if you connect your PC to a LAN port of the phone it will be on a data untagged vlan while voice vlan will be tagged automatically by the phone.
Here is my setup:

1.
Setup DHCP on the router or a switch for both vlans:
!
ip dhcp pool DATA
network 10.0.10.0 255.255.255.0
default-router 10.0.10.1
dns-server 8.8.8.8 4.2.2.2
domain-name Yourdomain.com
lease 0 3
!
ip dhcp pool VOICE
network 10.0.5.0 255.255.255.0
default-router 10.0.5.1
dns-server 8.8.8.8 4.2.2.2
domain-name Yourdomain.com
lease 0 3
!

2.
Setup both Vlans on your switch:
!
vlan 5
name VOICE
!
vlan 10
name DATA
!

3.
Enable globally LLDP:
!
lldp run
!

4.
Create LLDP Policy:
!
network-policy profile 1
voice vlan 5
voice-signaling vlan 5
!

5.
Configure switch ports (must be in access mode)
!
interface range GigabitEthernet 0/1-20
description DATA & VOICE
switchport access vlan 10
switchport mode access
network-policy 1
no logging event link-status
no shutdown
spanning-tree portfast
!

6. Write Memory and enjoy your network even more ;)

Above has been derived from:
http://www.cisco.com/c/en/us/td/doc...53_se/configuration/guide/2960scg/swlldp.html

Above setup will also come handy when setting up QoS later on, plus you separate voice traffic to a separate broadcast domain as well as it can be secured easier for access from other networks.

Enjoy,

-A
 

Members online

Forum statistics

Threads
25,812
Messages
167,767
Members
19,241
Latest member
bellabos
Get 3CX - Absolutely Free!

Link up your team and customers Phone System Live Chat Video Conferencing

Hosted or Self-managed. Up to 10 users free forever. No credit card. Try risk free.

3CX
A 3CX Account with that email already exists. You will be redirected to the Customer Portal to sign in or reset your password if you've forgotten it.
Top