1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED rentpbx.com - inbound route going straight to voicemail

Discussion in 'Help' started by scurry7, Jul 15, 2013.

  1. scurry7

    scurry7
    Expand Collapse
    Member

    Joined:
    Jun 29, 2010
    Messages:
    49
    Likes Received:
    0
    I have rentpbx.com piaf install connected to vitelity sip trunk.

    I can call out just fine, but when I call in it goes straight to vmail. What do I need to do to get the extension (Grandstream DP715) to receive calls?

    sip show peers:
    Code:
     asterisk -rx "sip show peers"
    Name/username              Host                                    Dyn Forcerport ACL Port    Status
    101/3411xxx              75.109.xx.xx                          D  N          A  21814    UNREACHABLE
    vitality-inbound/scu_xx  66.241.xx.xx                                N            5060    Unmonitored
    vitality-outbound/sc_xx  64.2.1xx.xx                                  N            5060    Unmonitored
    3 sip peers [Monitored: 0 online, 1 offline Unmonitored: 2 online, 0 offline]
    
     
  2. scurry7

    scurry7
    Expand Collapse
    Member

    Joined:
    Jun 29, 2010
    Messages:
    49
    Likes Received:
    0
    my sip_additional.conf
    Code:
    [101]
    deny=0.0.0.0/0.0.0.0
    secret=!***********a
    dtmfmode=rfc2833
    canreinvite=no
    context=from-internal
    host=dynamic
    trustrpid=yes
    sendrpid=no
    type=friend
    nat=yes
    port=5060
    qualify=yes
    qualifyfreq=60
    transport=udp
    encryption=no
    callgroup=
    pickupgroup=
    dial=SIP/101
    mailbox=101@default
    permit=0.0.0.0/0.0.0.0
    callerid=101 <101>
    callcounter=yes
    faxdetect=no
    cc_monitor_policy=generic
    
     
  3. scurry7

    scurry7
    Expand Collapse
    Member

    Joined:
    Jun 29, 2010
    Messages:
    49
    Likes Received:
    0
    Not sure if I fixed it or it just stared working. I went to (freepbx) settings > general sip settings > then set NAT to yes and IP CONFIGURATION to Public. now I can call into it. woohoo!

    maybe this will help someone else (I couldn't find much, eventhough i'm sure there was a ton out there).
     
  4. lgaetz

    lgaetz
    Expand Collapse
    Pundit

    Joined:
    Sep 15, 2009
    Messages:
    2,793
    Likes Received:
    524
    If your inbound route directs calls to a single extension, is it possible that the extension is set to dnd (do not disturb)? Note that DND can be set on the server and many times can also be set on the phone. If that is not it, give us the log entries from an inbound call enclosed between code tags. Asterisk log is located in /var/log/asterisk/full

    edit
    I see it is working, I will leave the above in case it it useful.
     

Share This Page