1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Grandstream GXP2020 Intercom and Paging

Discussion in 'Endpoints' started by witdirect, Jun 1, 2009.

  1. witdirect

    witdirect
    Expand Collapse
    Member

    Joined:
    Oct 1, 2008
    Messages:
    48
    Likes Received:
    0
    I have 5 Grandstream GXP2020 phones and I need to get paging and intercom working. I created a group for them but they don't work.
    Can someone give me the break down of steps to get it working?
     
  2. tshif

    tshif
    Expand Collapse
    Guru

    Joined:
    Jan 3, 2008
    Messages:
    1,240
    Likes Received:
    1
    In the configuration screen for the individual line that you want to enable intercom use for, locate and enable these two settings:
    Allow Auto Answer by Call-Info

    Turn off speaker on remote disconnect
     
  3. Boolah

    Boolah
    Expand Collapse
    Guru

    Joined:
    Nov 16, 2007
    Messages:
    335
    Likes Received:
    22
    Did you install the Paging & Intercom module?
     
  4. witdirect

    witdirect
    Expand Collapse
    Member

    Joined:
    Oct 1, 2008
    Messages:
    48
    Likes Received:
    0
    Yes I installed the module and which lines on the phones or in freepbx?
     
  5. tshif

    tshif
    Expand Collapse
    Guru

    Joined:
    Jan 3, 2008
    Messages:
    1,240
    Likes Received:
    1
    Sorry - The lines on the phone
     
  6. Boolah

    Boolah
    Expand Collapse
    Guru

    Joined:
    Nov 16, 2007
    Messages:
    335
    Likes Received:
    22
    Once the module is installed, it should be pretty straight forward.
    1. In FreePBX, create a new Paging Group and assign the extensions who should be members of this group.
    2. On your 2020's enable both of these settings for each account on the phone where paging will be used (as mentioned by tshif): Allow Auto Answer by Call-Info and Turn off speaker on remote disconnect
    That should be it. Just dial the paging group you created in step #1 and things should work.
     
  7. witdirect

    witdirect
    Expand Collapse
    Member

    Joined:
    Oct 1, 2008
    Messages:
    48
    Likes Received:
    0
    Ok I followed these steps and everything works. Well there is one hitch now the phones auto answer incoming calls automatically instead of allowing users to answer incoming calls.
     
  8. tshif

    tshif
    Expand Collapse
    Guru

    Joined:
    Jan 3, 2008
    Messages:
    1,240
    Likes Received:
    1
    There are two entries worded in a similar fashion -

    Make sure you have enabled "Auto Answer by Call-Info", and that "Auto Answer" is disabled.
     
  9. krzykat

    krzykat
    Expand Collapse
    Guru

    Joined:
    Aug 2, 2008
    Messages:
    841
    Likes Received:
    148
    So to recap, the two settings as listed in the auto-provisioning (for line1) are:

    P298 = 1 (allow auto answer by call-info)
    P299 = 1 (turn off speaker on remote disconnect)

    Now - how will this function with the "Intercom" button on the 2020? I'd assume you could press "intercom" + multi-purpose key of another extension? or the paging ring group?

    Thanks in advance for any clarification.
     
  10. Boolah

    Boolah
    Expand Collapse
    Guru

    Joined:
    Nov 16, 2007
    Messages:
    335
    Likes Received:
    22
    You would think this is the way the Intercom button on the phone would work, but it doesn't. It works just like a speed dial button. So you could program it to call a paging group (just enter the extension number assigned to the paging group), but cannot use the button for multi-step dialing.
     

Share This Page