1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

TUTORIAL Vitelity setup

Discussion in 'Trunks' started by Soulpole, Feb 10, 2012.

  1. Soulpole New Member

    I sorry for posting this question again, but I think some of the setup has changed since the last post.

    I have been using google voice for my home phone and now I have signed up for Vitelity. However, I my Vitelity inbound trunk is not working.

    A little background:
    I used the Trixbox setup wizard to try to configure my inbound and outbound trunks. This instructed me to create one inbound and one outbound sip trunks.

    The inbound trunk:

    Trunk name: inbound

    Peer details:
    type=friend
    username=uname
    secret=passwd
    insecure=very
    context=from-trunk
    canreinvite=no
    host=inbound16.vitelity.net
    disallow=all
    allow=ulaw


    The registation string works:
    Code:
    uname:passwd@inbound16.vitelity.net:5060



    The outbound trunk:

    Trunk name: outbound

    Peer details:
    type=friend
    username=uname
    secret=passwd
    fromuser=ntll_home
    trustrpid=yes
    sendrpid=yes
    context=from-trunk
    canreinvite=no
    host=outbound.vitelity.net
    disallow=all
    allow=ulaw


    Outbound does not have a registration string.

    Extra information:
    Networking and TCP/IP is my speciality, with that said all my ports are properly forwarded, and my firewall is passing traffic. Also ping test from my PBX goes to inbound16.vitelity.net and outbound.vitelity.net. Port scans show all positive information. My open ports are 5060 - 5061 and 10000 - 20000.


    Thanks a million!
  2. jackstay New Member

    Have you tried the Vitality recommended settings? Log into the Vitality portal and click the Support menu. I'm using the recommended settings with a nat router and no ports forwarded and it works fine. Also, be sure to check to see that your routing method in the Vitality web site is set correctly.

    Trunk name
    vitel-inbound

    Peer Details on my inbound route are:
    username=xxx
    type=friend
    t38pt_udptl=no
    t38pt_tcp=no
    t38pt_rtp=no
    secret=xxx
    insecure=port,invite
    host=inbound18.vitelity.net
    disallow=all
    context=from-trunk
    canreinvite=no
    allow=ulaw

    Good Luck!
  3. myitguy Guru

    I just compared your settings to the ones I have, and everything is the same except that I do not have
    disallow=all
    allow=ulaw

    Can you clarify what you mean by the Inbound doesn't work? This can mean a bunch of various things IMO.

    Also, can you share some log file entries (Tools --> Asterisk Logfiles) and what you have under Tools --> Asterisk SIP Settings

    For what it's worth, I haven't had to open any ports on my firewall to place/receive calls...

    [edit]Also you might want to remove the from_user value from the post above in your outbound trunk sample as this is the same as your Vitelity username (At least in my case)[/edit]
  4. Mike_S New Member

    My inbound trunk settings are the same as yours.

    Did you set the ip address in the externip= which gets written into sip.conf? You need to do this if you are behind a router and using NAT. I always put a second NIC on my machines to avoid the NAT issues. This is especially handy if you intend to have remote phones behind firewalls connecting to your asterisk box. I also firewall the crap out of the public interface.

    You may also try "nat=yes", although I believe it's Vitelity that needs to know that you are behind NAT, not the other way around.

    Is your DNS resolving. Can you ping yahoo.com?
  5. Soulpole New Member

    Thanks Guys!

    I removed the forwarded ports and reconfigured the settings on my vitelity sub account. I also removed the allow and disallow as recommended.

    It Works!!
  6. ChicoCanada Member

    hi all, I am stumped on this...

    Just installed PIAF v2 (1.8 and 2.9) w/ IncrediblePBX 3. In the pre-made inbound trunk I put this in my peer details:

    username=XXXXXXXXX
    type=friend
    t38pt_udptl=no
    t38pt_tcp=no
    t38pt_rtp=no
    secret=XXXXXXXXXXXX
    insecure=port,invite
    host=inbound16.vitelity.net
    context=from-trunk
    canreinvite=no
    allow=all
    nat=yes

    In my account in Vitelity, my sub account is set to NAT and shows as Online. In PIAF the trunk show as online and registered. My user context and user details on the trunk page are blank. I opened all the UDP ports on my firewall for 140.239.143.5 (inbound16.vitelity.net) pointed to my PIAF.

    In the Asterisk SIP settings, I set NAT to yes, set IP to Dynamic and entered the host name, and put in my local network: 192.168.10.1/255.255.255.0

    I am still running my old Trixbox server with the same hostname (dyndns) which is entered into the client on my firewall/router. I also have the same ports forwarded to my Trixbox. Could this be causing a problem? My guess is no, as I only have the ports open for 140.239.143.5 (inbound16.vitelity.net). I did the same with Trixbox, ports are open for specific IPs and IP ranges and none of them overlap. I have DNS resolution on my PIAF, 38ms ping to Vitelity :)

    I want this Vitelity trunk for inbound only.

    Any ideas?


    ********** UPDATE

    My Peer details now are this:

    type=friend
    dtmfmode=auto
    username=xxxxxxxx
    secret=xxxxxxxxxxx
    context=from-trunk
    insecure=very
    canreinvite=no
    nat=yes
    host=inbound16.vitelity.net

    same problem.... :-(
  7. ChicoCanada Member

    Resolved!!!!!

    I resolved the issue. Since I could not find anything wrong on my end (I always point the finger at myself by default), I turned my attention to Vitelity. I logged into my account on Vitelity's website and poked around in every section I could find. One detail caught my eye: click on the DID tab at the top, this takes you to the "main" sub-tab, I noticed that the "route to account" said "main", which seemed normal, but something told me that I might be able to select the "sub account" I had to create, even though I only had one. So I made the change and BAM! For once it wasn't me, well, kind of... ;-)

    Cheers and I hope this helps anyone stuck like me

Share This Page