1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

Postfix Setup Instructions

Discussion in 'Add-On Install Instructions' started by RizSher, Nov 21, 2007.

  1. RizSher Guru

    Postfix Setup Instructions to allow Email Notification of Voicemail etc

    Followed the instructions in the nerdvittles guide to setup email, however, always get the following message when I try to send a mail thru the * box:

    "The original message was received at Wed, 21 Nov 2007 23:08:51 GMT
    from rizsher.home.net [127.0.0.1]

    ----- The following addresses had permanent fatal errors -----
    <Trial@hotmail.com>
    (reason: 550 DY-001 Mail rejected by Windows Live Hotmail for policy reasons. We generally do not acc
    ept emai...l/network admins, please visit http://postmaster.live.com for email delivery information and s
    upport)

    ----- Transcript of session follows -----
    ... while talking to mx3.hotmail.com.:
    >>> MAIL From:<root@rizsher.home.net> SIZE=553
    <<< 550 DY-001 Mail rejected by Windows Live Hotmail for policy reasons. We generally do not accept email
    from dynamic IP's as they are not typically used to deliver unauthenticated SMTP e-mail to an Internet m
    ail server. http://www.spamhaus.org maintains lists of dynamic and residential IP addresses. If you are n
    ot an email/network admin please contact your E-mail/Internet Service Provider for help. Email/network ad
    mins, please visit http://postmaster.live.com for email delivery information and support
    554 5.0.0 Service unavailable
    "

    Any ideas?
  2. jroper Guru

    Hi

    The clue is in the message: -

    "We generally do not accept email from dynamic IP's as they are not typically used to deliver unauthenticated SMTP e-mail to an Internet mail server"

    Maybe set your system to deliver your mail via another SMTP server.

    see this post on how you may do this:-
    http://nerdvittles.com/forum/showthread.php?t=143

    Joe
  3. RizSher Guru

    I ended up installing PostFix, then got into trouble as my ISP requires SMTP Authentication for outgoing mails. Here is what I did:

    Replaced SendMail with Postfix by:

    Code:
    # rpm -e --nodeps sendmail
    # yum -y install postfix
    
    Then modified /etc/postfix/main.cf to add the following:

    relayhost = my.outgoing.smtp.server

    and, right at the bottom of the file,

    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =
    broken_sasl_auth_clients = yes
    myorigin = Put.Domain.YouWant

    Then, create sasl_passwd by

    Code:
    # nano /etc/postfix/sasl_passwd
    and add an entry like so:

    Code:
    my.outgoing.smtp.server   username:password 
    [my.outgoing.smtp.server is the same entry as the one added to relayhost in main.cf]

    make sasl_passwd root only:

    Code:
    # chown root:root /etc/postfix/sasl_passwd && chmod 600 /etc/postfix/sasl_passwd
    
    Create the hash file:
    Code:
    # postmap /etc/postfix/sasl_passwd
    Make the hash file world readable:
    Code:
    # chmod 644 /etc/postfix/sasl_passwd
    Reload the Postfix config:
    Code:
    # /etc/init.d/postfix reload
    At this point, I was able to send email from the command prompt, and also voicemail to email, and subsequently, FreePBX notification of updates all started working.
  4. cramerjd New Member

    my.outgoing.smtp.server usernameassword

    What is the username password setting, it got messed up with a smiley

    is it username:password, username@password, just usernamepassword, ??????
  5. cramerjd New Member

    Figured it out by posting it

    it is username : password but with no spaces :) and p make smiley)
  6. phinphan Member

    Thanks for these instructions. I was able to get my voicemails using my exchange server and that saved me the trouble of routing them out of the office. Followed your instructions to the T and the only problem I had was that when I went to restart Postfix it hadn't started. I went to Webmin and started it and made sure it will autostart with the system. Thanks again. The whole thing soups to nuts was about 5 minutes.
  7. jroper Guru

    Hi

    A tip for getting stuff to autostart on boot is to type setup at the command line.

    Follow your nose to the services, and select the ones you want to start on boot.

    Joe

Share This Page