1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

FYI PIAF Endpoint Manager

Discussion in 'Add-On Install Instructions' started by tm1000, Apr 9, 2010.

  1. tm1000 Schmoozecom INC/FreePBX

    Why can't you just connect this machine to the internet and give it proper DNS.

    Also where are you getting the files to upload manually from?

    also 'tail -f /var/log/httpd/error_log' then making the blank page happen would be helpful to me.
  2. gregpadgett New Member

    My machine is connected to the internet and DNS seems to be working as I can ping any domain I try. I can get updates from FreePBX with no problem as well as wget files.

    I found the link to the files in one of these forums, I honestly don't remember now I have worked on this so much the last couple of days.

    I uninstalled and reinstalled just to try one more time so I do not have the files I uploaded here at home. I will re-upload the files and do the tail..... at work tomorrow.

    Thanks for your quick responses.
  3. gregpadgett New Member

    I found the files I was using. I downloaded them from http://www.provisioner.net/release/v3/yealink/
  4. gregpadgett New Member

    I uninstalled, reinstalled, and uploaded the files. Now instead of a blank page I am getting....

    Error Returned From Provisioner Library: Could not load: /var/www/html/admin/modules/_ep_phone_modules/endpoint//global_template_data.json

    I also still cannot update automatically.
  5. gregpadgett New Member

    Fixed

    Ok - after hours of trying to figure out my problem I finally have it fixed.

    I decided to take a couple of hours and read each post in this thread. I have already skimmed most of it, but decided to read in detail.

    My problem the entire time was my Sonic Wall content filter.

    Was there must have been a change in the way the module works? I never had this problem in previous versions and have had Sonic Wall content filtering for a couple of years.
  6. tm1000 Schmoozecom INC/FreePBX

    Only change was stop using php cURL and start using system native wget. If wget didnt work then it wouldn't have worked for you I suppose.

    However even php was not returning a response code from the server.

    Most people would agree that sonicwall is not a good router choice and since I don't have it here in my lab there's nothing much I can do unfortunately.

    I could switch between curl and wget, maybe that would help.
  7. gregpadgett New Member


    Once I figured out the problem, all I have to do is disable when I want to update. Everything is working fine now.
  8. gregpadgett New Member

    Yealink T38

    In previous versions I used the Enable FreePBX ARI Module in EPM. I have Yealink T38 phones.

    It seems to work fine on provisioning phones, but when I attempt to change one of the 6 line keys it actually changes one of the side keys. When I attempt to change one of the side keys, the change goes to never never land.

    Something does not seem to be right about the mapping of the keys. Anything I can do to help since I have 60 of these phones?
  9. MiB New Member

    Hi Andy,

    I noticed your latest EPM 2.10.3.x versions all download Polycom firmware UC4.0.x, but I'm not sure this is intentional because the autoprovisioning config files EPM creates stil look like their for for 3.2.x

    sip.cfg is deprecated and no longer used in UC3.3x & UC4.0.x

    A lot of the syntax and variables are incompatible and considerably different between UC3.2.x, UC3.3x and UC4.0.x

    What Polycom firmware should we be using to be completely compatible with the configs EPM creates?

    On another note, no matter what UC firmware version I've tried I cannot get EPM to reboot the Polycoms.

    Thanks for working so hard on building a great EPM for us!:smile5:
  10. tm1000 Schmoozecom INC/FreePBX

    Sorry for your troubles. It is indeed the right configuration files. I've worked directly with several polycom vendors on this and it does work. When the files load they generate no errors as can be seen in the boot and app logs. Sip is only partially depreciated. You are still suppose to put extra variables in there and you'll notice my sip file is significantly less than i was in previous releases.

    I seriously doubt your polycom is running anything higher than 3.3 which the system is designed for. Actually it's designed for 4.0. And its been tested on on about 500 ish polycoms. Please look at my files more closely and you will see this for yourself

    Send me your app and boot logs to my email and I can help you figure out why your phones won't work
  11. MiB New Member

    No. not at all. It's me who's sorry to bother you.

    Ok no worries. It surprising because all the Polycom documentation for UCS 3.3.x and 4.0.x says:

    It is no longer necessary to load the default sip.cfg and phone1.cfg files to ensure proper operation. This saves approximately 200 KB from being downloaded from the provisioning server for every phone, and will result in
    improved boot speed, particularly in ‘power failure recovery’ scenarios. Now,you only have to manage non-default parameters.
    Implication: To take advantage of this change, you need to remove the sip.cfg and phone1.cfg templates from the 000000000000.cfg or <MAC Address>.cfg
    files. For administrators that have created their own custom configuration files (for example, by combining sip.cfg and phone1.cfg), all parameters that are set to default values need to be removed.
    Change is mandatory: Since the sip.cfg and phone1.cfg files are no longer distributed with the release, this change will need to be made.



    I don't know why you seriously doubt me. In EPM configuration MGR, if I click Install Firmware, it downloads 4.0.1 and when I provision the phone, that's what get's loaded. I know because I had to use a special downgrade boot loader to get it back to 3.3.3.

    Ok good to know. I couldn't find any documentation about this anywhere.

    Like I mentioned, the phone (IP670) does work when provisioned thru EPM on 4.0.1. On the phone's diags it logs about 22 errors on a stock config with just a single line registration provisioned. Nothing fancy. I always do a 'format file system' before provisioning to make sure nothing carries over.

    In any case, now that I know that you've optimized the configs for 4.0.1 I have something to work towards.

    Because Polycom's documentation is based on the premise that sip.cfg & phone-1.cfg are deprecated, it makes customizing configs via EPM non standard. Which file should I be adding and fine tuning features?

    Thanks man, you're always great about offering to help. I just need some guidance on which files I modify to fine tune features and if you have any idea why I cannot reboot the phone after a change from EPM using any firmware. I've tried 3.3.2, 3.3.3 & 4.0.1 all with clean formats in between. If you can help with those 2 things, that should keep me busy for a while!
  12. gregpadgett New Member

    Yealink T38

    I am using Yealink T38 and Endpoint Manager 2.10.3.2.

    Provisioning works wonderful until you want to change settings on lines and DSS keys.

    When I try to change one of the 6 line buttons it instead changes one of the top 6 DSS keys. When I change DSS keys it goes to oblivion. I have logged in to the individual phones and verified that it indeed is mapping the keys incorrectly.

    Not only does this make it difficult to set up the phones - I have 60 Yealink phones - but the end users cannot change their DSS keys.

    HELP!
  13. alauppe Member

    Is this endpoint manager still being maintained? I suspect it is, because I see an update was offered to support the Polycom VVX 500, but http://wiki.provisioner.net/ has had the same database error screen for a while now.

    Any ideas? Great software - there is clearly someone (or a team of someone's) taking fantastic care of it.
  14. jborchart New Member

  15. wardmundy Nerd Uno

    Last edited by wardmundy, Mar 25, 2014
  16. Damian Stalls New Member

    I am using EPM v 2.11.5.3 which has worked fine for my GrandStream and SPA2102. I have gotten a few SPA8000 units which seemed to provision ok, except for the following:

    1. Unable to dial extensions configure on the SPA8000 or anywhere else on the PIAF
    2. Unable to access "Admin" section of the SPA8000 to see if the dial plan is different than my SPA2012 units
    Any suggestions?
  17. Damian Stalls New Member

    Please disregard my previous posts as i figured out that the OSS EPM dial plan for the SPA8000 was no good. Also, the default config from OSS EPM also disabled web management directly on the SPA.

    HOWEVER.... I have found a HUGE issue....

    It seems that randomly after adding some lines to a device in EMP all of the graphic icons disappear. These are the graphics that allow you to see if the device is online/offline and the pencil that let you edit the config files for each device. They just disappear for no reason. I have rebooted everything and they never come back. Even if I delete the module and reinstall or delete all devices and readd. I was able to get the graphics to re show up after uninstalling the module, installing an older version of the module, then upgrading again. However after I added the SPA8000 back and added a few lines (POOF) all graphics in EPM are gone and so are my editing ability.
  18. james Guru

  19. Damian Stalls New Member

    Is Provisioner the same as OSS EPM???
  20. Robert-BCC Guru

    The EPM linked at the bottom of this github page refers to http://www.the159.com/endpointman/ (an old / broken link) and then refers to a download location for the EPM intended for FreePBX 2.10. If I am running 2.11, is it OK to use the 2.10 package? I don't see a way to get the files shown at the top of the page.

Share This Page