1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

BUG Missing Kennonsoft Menu after Upgrade

Discussion in 'Bug Reporting and Fixes' started by miguel, Apr 3, 2014.

  1. miguel Member

    Can anyone please tell me how to get back the kennosoft menu because I just can get to the freepbx menu and no fax or open fire menu no nothing just directly to the freepbx web gui this happened after the framework upgrade via module admin, here is my config please help me!

    Attached Files:

  2. lgaetz Pundit

    Confirmed.

    My test PBX is PIAF 3.6.5 running FreePBX 2.11.0.31 and Asterisk 11.7. I just now did a Module Admin upgrade of all modules (probably about 20) and after the upgrade the Kennonsoft menu is gone. Navigating to the PBX ip, automatically redirects to /admin and prompts for credentials. If credentials are cached, it automatically loads FreePBX.
  3. lgaetz Pundit

    FIXED.

    One of the updates (dunno which) overwrites the file /var/www/html/index.php without backing up the old version (SHAME!). This new version of index.php checks for the existence of the file index.custom.php first before redirecting to /admin. The following will fix:

    Code:
    cd /var/www/html/
    wget https://gist.githubusercontent.com/lgaetz/9954119/raw/index_custom.php
    chown asterisk:asterisk index_custom.php
    Takeaway:
    If you want a custom /var/www/html/index.php it MUST be named index_custom.php to prevent FreePBX updates from overwriting.
  4. miguel Member

    you are the best I can't thank you enough!
    lgaetz likes this.
  5. lgaetz Pundit

    @wardmundy two systems affected and a confirmed fix, I shan't be surprised to see a flood of theses reports. The easiest solution is to have two copies of the Kennonsoft index.php, the other named index_custom.php. It will be there if needed and won't hurt anything if it is not needed.
  6. tm1000 Schmoozecom INC/FreePBX

    You say "shame" but I disagree. We had this conversation in a thread over a year ago with all the important people involved in PBX in a flash and it was stated that the index.php flag fix would be temporary and that PIAF should use index_custom.php. Are we suppose to backup every file that we over write? It's been over a year now since we made the custom_index.php changes which work fine and furthermore the index_custom.php fix was written specifically for PIAF and it's surprising that it is still not used in PIAF.

    lgaetz likes this.
  7. lgaetz Pundit

    Mea culpa. Since this only hit me today, I assumed the issue was new. The 'proper' fix really is simple, using update-fixes, test for the non-existence of the file /var/www/html/index_custom.php then upload the Kennonsoft index.php file as index_custom.php.
  8. tm1000 Schmoozecom INC/FreePBX

    The thing that was removed was the piaf.flag reference code that told FreePBX to leave the index.php file alone, that was a temporary fix (as was stated in the comment) and was removed as specific distro changes cause messy code (imagine if we had fixes for AsteriskNow, Elastix, PIAF, FreePBX distro). At the time it was agreed that PIAF would start to write to both index.php and index_custom.php at the same time so as when the time came to remove the aversion code there would be seamless changes. I am sorry that it didn't work out this way and unfortunately the thread that had all of this discussion was lost in the data crash of last year so I have no proof as to the conversation. We really try to have a system that works the same for everyone but that can be customized at the same time.

    We did think about looking at the index.php file and if it's there then move it to index_custom.php, but what happens if index.php is our file? Now we have just moved index.php to index_custom.php and any changes to index.php would be ignored in favor of index_custom.php

  9. wardmundy Nerd Uno

    Thanks for the heads up. I remember the PIAF flag agreement, @tm1000. The rest is new news at least to me. Doesn't mean someone else didn't know about it.

    Simple solution for current PIAF users is to protect index.php and index.html from being overwritten:

    Code:
    chattr +i /var/www/html/index.*
    Latest Incredible PBX 11 already has the fix built in.

    Here is a fix for anyone who already has lost the files:
    Code:
    cd /var/www/html
    rm index*
    wget http://pbxinaflash.com/piaf-index.tar.gz
    # alternate site
    # wget http://nerdvittles.dreamhosters.com/pbxinaflash/source/kennonsoft/piaf-index.tar.gz
    tar zxvf piaf-index.tar.gz
    # for absolute protection, uncomment the next line
    # chattr +i index*
    
    Keep the tarball to avoid any future issues.

    We will push this out in update-fixes ASAP.
    Last edited by wardmundy, Apr 12, 2014
  10. lgaetz Pundit

    While it may be simple, that solution is a hack. There is an error message thrown at boot and at amportal restart, and if attributes subsequently get changed, it will break at the next FreePBX update. The proper solution is no more difficult.
    rjaiswal likes this.
  11. wardmundy Nerd Uno

    Like I said, I thought we had an understanding, but I appreciate @tm1000's point as well. For the time being (until Asterisk 12), index.html and index.php are crucial PIAF files because they include our security alert RSS Feed which FreePBX does not (yet) support.

    We originally pushed this out last year but changed it back once we had an understanding on protecting those files for PIAF users. Something changed somewhere. And it's no big deal. We'll put the fix back for current users.
  12. lgaetz Pundit

    If you are going to push a fix, please take note of my post above to make this issue go away forever.
  13. wardmundy Nerd Uno

    Duly noted. Patch has been pushed out to all Incredible PBX systems running on CentOS/Scientific Linux/PIAF OS platforms. Raspberry Pi and BeagleBone Black versions were not affected since they use the traditional FreePBX menu system.
    miguel and lgaetz like this.
  14. jvangent100 Member

    Thanks people, I had the same problem, was thrown into admin straight away, instead of having the kennosoft menu.

    Just out of interest, why are the FreePBX modules updated so often ? I mean, the system I have running now (2 weeks or so) at least had two or three updates to the core engine.

    A bit much if you ask me.
  15. Hyksos Guru

    You either need a priest to chase ghosts that are applying updates in your back or you need to look in the mirror and ask the guy in there why he's applying all those updates while finding it a bit much at the same time.
    You could always use your left hand to slap your right hand?
    :leaving:
  16. james Guru

    FreePBX started out as a garage project of one guy and took off like a rocket. For years there was a couple of guys that without much praise or backing managed to keep it alive while working their day jobs and families. These guys were given the opportunity to make this their day job and were surrounded by a strong team over the last year or so. FreePBX went from a back burner passion that took time away from these guys families to a project that now helps them feed their family. The result of this partnership can be seen. I have been married over 10 years and can tell you when something goes from a hobby to paying your bills you get fired up. The leap from 2.09 to 2.10 and 2.11 have been incredible and with FreePBX 12 on the horizon it just gets better.

    We are working on taking FreePBX to the next level while still taking care of other things. We are actively clearing out back logs of bugs and feature requests from before Schmooze stepped up. We are constantly and actively improving things. It may seem like a bit much but there is a lot of money being dropped in to FreePBX and these updates are the result of that investment. I am happy to see this direction as apposed to the alternative of a stagnant project that simply dies.
    Trimline2, randy7376, rossiv and 3 others like this.
  17. jvangent100 Member

    No need for any priests, nor is there a need to slap any hands. Obviously I merely asked the question, which at least has been answered by James.
    Last edited by wardmundy, Apr 5, 2014
  18. lgaetz Pundit

    @Hyksos was merely pointing out that you are in control. FreePBX 2.11 has a different style of notice for critical security updates, the others you can choose to ignore for as long as it suits you. Generally, I only apply non-critical updates a few times a year, and will take the opportunity to image the drive before applying them.
    Hyksos likes this.
  19. gordon Member

    I got bit by this testing out the ec2 piaf image. I am trying to get the menu back. I've tried using both update-my-pbx and update-programs/update-fixes.

    Here is what happens with the manual fix posted above:
    Code:
    [root@*** html]# wget http://pbxinaflash.com/piaf-index.tar.gz
    --2014-04-12 02:42:10--  http://pbxinaflash.com/piaf-index.tar.gz
    Resolving pbxinaflash.com... 74.86.213.25
    Connecting to pbxinaflash.com|74.86.213.25|:80... connected.
    HTTP request sent, awaiting response... 403 Forbidden
    2014-04-12 02:42:10 ERROR 403: Forbidden.
    
  20. wardmundy Nerd Uno

    Sorry you're having trouble, @gordon. We can't reproduce the problem. Works fine for us.
    Code:
    wget http://pbxinaflash.com/piaf-index.tar.gz
    --2014-04-12 05:47:13--  http://pbxinaflash.com/piaf-index.tar.gz
    Resolving pbxinaflash.com... 74.86.213.25
    Connecting to pbxinaflash.com|74.86.213.25|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5551 (5.4K) [application/x-gzip]
    Saving to: “piaf-index.tar.gz”
     
    100%[===================================================================>] 5,551      --.-K/s  in 0s     
     
    2014-04-12 05:47:13 (27.7 MB/s) - “piaf-index.tar.gz” saved [5551/5551]
    
    Try from here:
    Code:
    wget http://nerdvittles.dreamhosters.com/pbxinaflash/source/kennonsoft/piaf-index.tar.gz

Share This Page