1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Installing apt-swift

Discussion in 'Help' started by wvroger, Jan 28, 2008.

  1. wvroger New Member

    i have followed the directions on the nerdvittles website without success. the app_swift.so is not loading.

    I am running asterisk 1.4.13 do I need to upgrade?

    Thanks
    Roger
  2. tfunk New Member

    I'm running into a similar problem.

    Code:
    root@pbx:/usr/src/app_swift-0.9.1 $ asterisk -rx "core show application swift"
    Your application(s) is (are) not registered
    root@pbx:/usr/src/app_swift-0.9.1 $
  3. merlyn New Member

    same problem....
    Your application(s) is (are) not registered.

    order i did it in.
    update-scripts
    update-fixes
    update-source

    then did nerdvittle install as instructed.
    I could hear the message "hello world" across usb headset but same error message came up about not being being registered when i continued down instructions.

    Do we need to be actually registed to not get this message?

    To test the install process i reverted to a old snapshot (in vmware ) and redid the entire process. During this snapshot reversion i appeared to have hosed my host OS windows vista 64 ultimate as i cannot use the keyboard or mouse now at all. will work on my probably unrelated host os problem and see if i can get pbxinaflash up and working again. I believe my usb has caused some random error and i will take me a bit to sort it out.

    unplugging and replugging in ps2 and usb devices as we speak ...

    merlyn
  4. merlyn New Member

    ok host computer is up and working again.

    pbxinaflash is up and working again. Appears plugging in a usb headset that was working in pbxinaflash before caused all kinds of errors.

    to fix it i had to shut down the host machine unplug all ps2 and usb devices. boot KVM (as in kick it across room). didnt help had to continue ...
    shutdown 2nd computer on kvm and reboot KVM (as in pick up the kvm and kicked it again across room) and voila everything is happy again.

    Now where was I ... oh yeah ..... swift install .... i was just installing a few applications in 1.4 before i tried doing a 1.6 asterisk install .... hummm i think i will just wait a bit on the 1.6 trial ... :wink5:

    DISCLAIMER !!!... this was a dramitization ... no KVM switch was actually harmed during the making of this forum post!!!

    merlyn
  5. mdot New Member


    Same here...
  6. wardmundy Nerd Uno

    Well, there were a couple of problems. Thanks for the feedback. Log into your server as root and issue the command: ldconfig

    Next, that damn WordPress treatment of quotes bit us in the butt again. Fancy quotes are not the same as regular quotes, nor is the fancy apostrophe the same. So issue these commands:
    Code:
    sed -i 's|David-8kHz|Allison-8kHz|' /etc/asterisk/swift.conf
    amportal restart
    asterisk -rx "core show application swift"
    
    If you still have problems, post another message. Thanks again for feedback.
  7. mdot New Member

    SUCCESS!!

    Thanks Uncle Ward.

    Instead of doing the whole thing over again I did the 'ldconfig' then I did this:

    Code:
    cp /usr/src/app_swift-0.9.1/swift.conf.sample /etc/asterisk/swift.conf
    
    Just to reset the config file before re-running the 'sed' command.
  8. tfunk New Member

    That worked just fine for me.

    You know your the greatest, right Ward?
  9. wardmundy Nerd Uno

    Allison just keeps telling me that over and over. What a great girl. :yesnod:
  10. cvschleich Member

    Anyone know how I could make swift read a file on disk from the dialplan? I'd like to be able to edit the spoken text from a webpage.
    (without the danger of breaking the dialplan... )
  11. wardmundy Nerd Uno

    It's not supported real-time in the Asterisk implementation. Because of the licensing scheme, you will be better served by generating the .wav file on the fly from the web site and then letting Asterisk play back the file. You can write out a .wav file in under one second. Playing a text file with Cepstral over the telephone ties up your license for the entire time its playing. :idea:
  12. Do I need to use the 8k voices?

    This is a great addition, but I was wondering if I really need to use the 8k voices, or can I use the normal voice so I can use the voice in other situations like home automation? I'd rather not buy a license just for Asterisk.

    I know the regular voice works with Asterisk...I've already tried that. But does using the 8k voice as opposed to the normal voice buy me anything?
  13. cvschleich Member

    <slaps forehead>

    Thanks, Ward. I should have though of that. I'll just generate the .wav with the command line swift and link to that.
  14. wardmundy Nerd Uno

    What it buys you is .wav files that work with Asterisk without conversion. I don't think you're going to notice a difference for home automation projects.
  15. jrglass Guru

    How do I generate the .wav file on the fly from the website?

    Thanks,

    Jeff
  16. wardmundy Nerd Uno

    PHP has a system() function to execute Linux commands, e.g.

    swift -f inputfile -o outputfile
  17. Ok, I've looked in the source code for app-swift, and it sets the swift voice engine to output at 8kHz. In fact, it is setting the swift engine to output 8kHz ulaw raw output. So I would think that the 16kHz desktop voices would also work fine and generate the same output that the 8kHz voice does.
  18. wardmundy Nerd Uno

    Only one way to find out. :wink5: Let us know how it goes.
  19. I did the following:

    #swift -n Allison -o test.wav "hello world"
    #aplay test.wav
    Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 16000 Hz, Mono

    Then I did this one:
    #swift -n Allison -o test.wav -p audio/sampling-rate=8000 "hello world"
    #aplay test.wav
    Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 8000 Hz, Mono

    So the standard 16kHz desktop voice generated a 8kHz sample.

    Finally, with the Allison 8k voice:
    #swift -n Allison-8kHz -o test2.wav "hello world"
    #aplay test2.wav
    Playing WAVE 'test2.wav' : Signed 16 bit Little Endian, Rate 8000 Hz, Mono

    The WAV file generated by the 8K voice is exactly 200 bytes larger than the other one.

    According to voip-info.org, 16bit 8kHz mono is optimal for Asterisk.
  20. gurvy New Member

    :( "Your application(s) is (are) not registered"

    Can anyone else see where I am going wrong, If I only installed Allison do I need to type David-8kHz as well?
    history..
    First I Installed Cepstral
    Tested it >> "the computer speaks"
    Intstalled app_swift-0.9.1 make..and make install.

    Very Carefully Typed the following from a root prompt first using ldconfig here is a copy/paste of the routine:

    root@pbx:~ $ ldconfig
    root@pbx:~ $ sed -i 's|David-8kHz|Allison-8kHz|' /etc/asterisk/swift.conf
    root@pbx:~ $ amportal restart
    STOPPING ASTERISK
    <snip> asterisk reload routine. <snip>
    FOP Server Started
    root@pbx:~ $ asterisk -rx "core show application swift"
    Your application(s) is (are) not registered

    what am i missing?

Share This Page