1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Incredible PBX Bugs/Fixes

Discussion in 'Bug Reporting and Fixes' started by wardmundy, Apr 18, 2010.

  1. wardmundy Nerd Uno

  2. wardmundy Nerd Uno

    If you were one of the early pioneers today, check the password for extension 705 and make certain it is not blank. There was a rounding error for the password for this extension that could have resulted in a blank password entry in some cases.

    The risk to your system is minimal provided you have installed the hardware-based firewall as outlined in the tutorial since no one has access to your SIP extensions from outside your firewall.
  3. MisterQ Member

    OK< I am coming across a number of glitches with the incredible PBX.

    1. Using ipkall, and google voice, I am getting a message that the destination number is already in use. Apparently, this is "common" when numbers have been used by others, but expired on IPKALL, but not on GoogleVoice. Google are unresponsive on this. I have tried getting a new number from IPKALL (First attempt gave me the exact same number again - second time I tried for a different area code) I have tried plugging this info in - changes at the end of /etc/asterisk/extensions_custom.conf and also on the inbound routes. call is not getting through...


    2. The instructions at nerdvittles.com call about initial setup in ipkall as a SIP connection, and then changing to IAX2. I did that, and then ran the configure-gv specifying IPKALL - a sip show peers and iax2 show peers from the console, show a sipgate connection/registration but no IAX2 registration with IPKall - should that exist?
  4. wardmundy Nerd Uno


    1. Not a problem. Just reclaim the number using the option provided in Google Voice. If no one else owns the IPkall number, you'll be fine.

    2. The IPkall connection is made on the fly. That's why you need the hole in the firewall since there is never a permanent registration. I think this is explained in the article... or the last one. :wink5:
  5. wardmundy Nerd Uno

    SIP Security Vulnerability

    There is a very serious security vulnerability that needs to be patched by loading the very latest version of FreePBX Framework as soon as it becomes available for your version of FreePBX. Just displaying a call report in the FreePBX browser could compromise your system.

    The 2.6 patch (which is what you need with The Incredible PBX) already has been released. Load this patch IMMEDIATELY by opening FreePBX with a browser and...

    Setup, Module Admin, Check for Updates on Line, Upgrade All

    2.5.2.3: #4223 Security Vulnerability
    2.6.0.2: #3805, #3707, #4188, #4223 Security Vulnerability
  6. HavocStyles New Member

    Need pointed in the right direction, my old setup (still in use and working) I have a callcentric account which I have two DID's and I'm routing each DID to a different destination. i.e. one to a IVR and one to an extension.

    And here is my context how I get the CID for callcentric out of the SIP headers, so I can route them properly.

    Code:
    [from-sip-external-custom]
    exten => _.,1,NoOp(Received incoming SIP connection from unknown peer to ${EXTEN})
    exten => _.,n,Set(DID=${IF($["${EXTEN:1:2}"=""]?s:${EXTEN})})
    exten => _.,n,Goto(s,1)
    ; CallCentric Check
    exten => s,1,GotoIf($["${DID}"="1777XXXXXXX"]?callcentric)
    ; Regular Check
    exten => s,n,GotoIf($["${ALLOW_SIP_ANON}"="yes"]?checklang:noanonymous)
    ; CallCentric DID Code
    exten => s,n(callcentric),Set(Var_FROM_DOMAIN=${CUT(CUT(SIP_HEADER(TO),@,2),>,1)})
    exten => s,n,GotoIF($["${Var_FROM_DOMAIN}" = "callcentric.com"]?callcentric-next)
    exten => s,n,GotoIF($["${Var_FROM_DOMAIN}" = "ss.callcentric.com"]?callcentric-next)
    exten => s,n,GotoIF($["${Var_FROM_DOMAIN}" = "66.193.176.35"]?callcentric-next:checklang)
    exten => s,n(callcentric-next),Set(Var_TO_DID=${CUT(CUT(SIP_HEADER(TO),@,1) ,:,2)})
    exten => s,n,GotoIF($["${Var_TO_DID}" = ""]?checklang)
    exten => s,n,Set(DID=${Var_TO_DID})
    ; Regular script continues
    exten => s,n(checklang),GotoIf($["${SIPLANG}"!=""]?setlanguage:from-trunk,${DID},1)
    exten => s,n(setlanguage),Set(CHANNEL(language)=${SIPLANG})
    exten => s,n,Goto(from-trunk,${DID},1)
    exten => s,n(noanonymous),Set(TIMEOUT(absolute)=15)
    exten => s,n,Answer
    exten => s,n,Wait(2)
    exten => s,n,Playback(ss-noservice)
    exten => s,n,Playtones(congestion)
    exten => s,n,Congestion(5)
    exten => h,1,Hangup
    exten => i,1,Hangup
    exten => t,1,Hangup
    Problem is on this new system "The Incredible PBX" Which I have setup just like my old system. But when a call comes in it automatically routes to the context from-sip-external in which that context is only to error on congestion then hang up. Here is the context in /etc/asterisk/extensions_override_freepbx.conf

    Not sure if "This is _really_ meant to be" if your routing by DID, and grabbing the true caller ID from the SIP headers? In other words now I'm really confused.

    I did try setting the DID with my callcentric ID with the CID set to my phone number and with CID priority checked, but still routes to the from-sip-external context, which is not correct and should be routing to my [from-sip-external-custom context.

    Any help would be great. Thanks in advance,

    Eric

    ***Update***

    Anyway I commented out "from-sip-external" from

    /etc/asterisk/extensions.conf
    /etc/asterisk/extensions_override_freepbx.conf

    and changed the context in /etc/asterisk/sip_general_additional.conf

    to "from-sip-external-custom"

    Inbound calls are now being picked up by the right context and routing appropriately. So my question is, is there any security risk in doing this? Because I can't think of any at the moment and have anonymous SIP turned off.

    Cheers,
    E
  7. wardmundy Nerd Uno

    Incredible PBX Reminders

    Incredible PBX Reminders: A bug was discovered that caused scheduling of some reminders to fail because of 2 missing directories. The fix is here: http://nerd.bz/dwO0fd

    Our apologies.
  8. wardmundy Nerd Uno

    If you installed the Incredible PBX with Asterisk 1.6 before the date of this message, log into your server as root and issue the following commands after running configure-gv.x script to assure that Google Voice outbound calling works correctly:

    Code:
     sed -i 's/|/,/g' /etc/asterisk/extensions_custom.conf
     amportal restart
  9. Severian New Member

    Adding Your Credentials to The Incredible PBX.

    There is an error in this description. It says "You'll also need to reenter your passwd-master password". You have never entered it, so it is hard to reenter it. Worse, it is hard to know that the password is currently set to. I think I see where this error comes from. In the recipe for installing pbxinaflash on another page on the website, you run this script after running update-fixes. Did you mean to do that in the IncrediblePBX install procedure?

    I entered this report once before, but it disappeared. Why would that happen?
  10. wardmundy Nerd Uno

    The very first step in running configure-gv.x is setting the passwd-master password. So... you not only know what the password is, you've just set it. :crazy:
  11. Severian New Member

    I will assume you are right and I missed that. I started the install again to see if I can get it working this time.

    I was installing The Incredible PBX tonight. The installer could not retrieve one file. I saw this as it tried:
    --2010-07-15 03:40:15-- (try:20) http://pbxinaflash.net/source/fax/cmake-2.4.8-3.el5.i386.rpm
    Connecting to pbxinaflash.net|216.239.128.70|:80... connected.
    HTTP request sent, awaiting response... 206 Partial Content
    Giving up.

    The installer went on, and I see there was a cmake already in /usr/bin.
    So, should I be concerned about some subtle problem? Should I try again tomorrow? Or, should I just assume everything is OK?
  12. wardmundy Nerd Uno

    DreamHost moved our repository to a new server, and it has had intermittent problems with "partial downloads." We opened a trouble ticket this morning, and it seems to be fixed. To get the faxing to work, you'll probably have to start over. Sorry.

    P.S. In case you ever run into this on your own servers, the answer is to set EnableSendfile to off in httpd.conf. Linux processes file requests directly from disk to network card (skipping the CPU) without this setting. When it works, it's much faster and reduces processor load, but...
  13. wardmundy Nerd Uno

    There's another Asterisk 1.6 syntax quirk that causes a problem with ODBC lookups if you happen to be using Incredible PBX with Asterisk 1.6.

    Those that installed systems before 3:00 pm (EDT) on 9-18-2010 should apply the following patches. Log into your server as root and issue the following 5 commands:

    Code:
     sed -i 's/|/,/g' /etc/asterisk/odbc.conf
     echo " " >> /etc/asterisk/asterisk.conf
     echo "[options]" >> /etc/asterisk/asterisk.conf
     echo "app_set=1.6" >> /etc/asterisk/asterisk.conf
     amportal restart
    
  14. wardmundy Nerd Uno

    An issue has been reported with CDR reporting in FreePBX. If you installed Incredible PBX before today, here’s the fix. Log into your server as root and issue the following commands:



    Special thanks to krzykat for debugging this.
  15. wardmundy Nerd Uno

    Nov.2 Bug Fixes for Incredible PBX 1.8 ONLY

    A couple of bug fixes have been released for Incredible PBX 1.8 version only. If you installed Incredible PBX 1.8 before 2:15 pm EDT today, read the Quirks & Bugs section of the original article for the patches.
  16. wardmundy Nerd Uno

    All remaining Quirks & Bugs have been addressed in this morning's release. CallerID works. IVR works. KeepAlive works to avoid losing inbound calls due to Gtalk timeout. FreePBX modules have been updated. Thanks to everyone for the suggestions and fixes. Come join the party!

    :party::party::party::party:
  17. wardmundy Nerd Uno

    except this one...

    A few of you may not have the current version of iptables. Do a directory listing of /tmp. If you see an iptables file, you have the problem. Here’s the fix:


  18. RXWatcher New Member

    I'm getting one way audio on dialouts(edit..it seems to happen on inbound calls too..same on both).. I can hear them but they cant hear me. Any ideas?

    This was caused by my headset(no..not the mute button)..thanks anyway
  19. wardmundy Nerd Uno

  20. wardmundy Nerd Uno

    Dictation bug reported elsewhere in this forum. The fix has now been incorporated into Incredible PBX 1.8 only. It will be addressed in update-fixes shortly for other apps.

    Here's the manual patch once you've logged into your server as root. No harm if it is run more than once.

Share This Page