1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.
  4. Critical FreePBX vulnerability! Update your server immediately. Details here.

HOW-TO Install Cepstral

Discussion in 'Add-On Install Instructions' started by MrBostn, Jan 22, 2009.

  1. MrBostn Guru

    hi running piaf 1.3 32bit.
    trying to install cepstral via webmin command line

    right after I type in ./install.sh the screen freezes. I tried it on the console but junk flashes ont hes screen. Any Ideas? Wrong version maybe?

    Thanks
    Scott
  2. wardmundy Nerd Uno

    Try this script to install 32-bit Cepstral on Asterisk 1.4 systems.

    Or you can add it directly to your system after logging in as root. And then run the script: install-cepstral

    HTML:
    cd /usr/local/sbin
    wget http://nerdvittles.dreamhosters.com/pbxinaflash/source/cepstral/install-cepstral
    
  3. MrBostn Guru

    Thank you Ward. I'm still having issues but I'll work through it.
  4. MrBostn Guru

    (I'm installing Callie), by the way.

    I do this:
    cd /root
    wget http://downloads.cepstral.com/cepstral/i386-linux/Cepstral_Callie-8kHz_i386-linux_5.1.0.tar.gz
    tar -zxvf Cepstral*
    cd Cepstral_Callie-8kHz_i386-linux_5.1.0
    ./install.sh

    Right after I type in ./install.sh in webmin I get nothing.

    I wasn't sure how to run the entire script so I saved your script to a text file, changed Allison to Callie saved it as a .sh file uploaded it to the PIAF server and tried to run it but I got permission denied.
  5. jroper Guru

    Hi

    It may be helpful if you read Conversational Linux - http://pbxinaflash.net/Conversational_Linux.pdf

    Meanwhile to make a script executable - type the following

    chmod +x filename.sh

    Then to run it type ./filename.sh

    the +x says that the script has the right to be executed

    Joe
  6. MrBostn Guru

    Thank you very much.
  7. MrBostn Guru

    Still nothing. This is what I did.

    I copy Ward's script to a text file on a windows pc. I save as cepstral.sh

    I then open IE7 and login to webmin of the piaf server.
    I then upload cepstral.sh to /root
    Then while in webmin I go to the command line. I type cd /root and type chmod +x cepstral.sh
    Then I type in ./cepstral.sh

    and nothing really happens. No output nothing. I can navigate around, nothing is frozen..

    Any thoughts?
  8. tshif Guru

    I would suggest that you try a tool like putty.exe to work at the command line on your pbx. Webmin's command line interface may be getting in the way a bit.
  9. MrBostn Guru

    Using putty worked. Thank you for the tip.

Share This Page