1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Check out the 6 new Certified Incredible PBX Builds for Asterisk 11 and 13 featuring CentOS 6, Ubuntu 14, Raspberry Pi 2, and Asterisk-NOW.
    Dismiss Notice

SOLVED gvoice Stopped Working

Discussion in 'Bug Reporting and Fixes' started by wardmundy, Feb 18, 2012.

  1. wardmundy

    wardmundy Nerd Uno

    If you're experiencing problems (login failed errors) with the gvoice command line utility for Google Voice that includes support for sending SMS messages, here is the fix. Log into your server as root and...

    cd /root
    wget http://nerdvittles.dreamhosters.com/pbxinaflash/source/gvoice/gvoicefix.tar.gz
    tar zxvf gvoicefix.tar.gz
    cd bwpayne-pygooglevoice-auth-fix
    python setup.py install
    Then you can run a simple test:

    gvoice -e yourname@gmail.com -p yourpassword send_sms 8431234567 "How are you?"
    Our thanks to bwpayne for the fix.
  2. MisterQ

    MisterQ Member

    THere would be a wget or curl command at the being of the second line of the instructions...
  3. wardmundy

    wardmundy Nerd Uno


    I'm still testing this but... one reason you might like this command is that I've found that adding an hourly SMS message to yourself (like the above example) as a cron job seems to solve the problem with Google Voice numbers not answering calls 100% of the time.

    It's starting to look like there is some sort of keep-alive activity that goes on with Google. Stay tuned. :rolleyes:

    gvoice -e youremail@gmail.com -p yourpassword send_sms your-gv-phone-number "How are you?"

    /etc/crontab entry:
    59 * * * * root /root/smstest
  4. alauppe

    alauppe Member

    I can't make this work. I've tried it on several platforms. I get "Login failed: '', Retry?[Y/n]"

    Still working for you Ward?
  5. wardmundy

    wardmundy Nerd Uno

    Just sent one from new machine. Worked great.
  6. rossiv

    rossiv Guru

    When did you install your box? There was an update for the GVoice command that fixed a login error not that long ago.

Share This Page