1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

FreePBX Setup for sip2sip.info

Discussion in 'Help' started by rchalk, Oct 13, 2010.

  1. rchalk Member

    Can someone help me with the full trunk configuration details for both inbound and outbound settings, or point me to a thread with the information? Thanks. Richard
  2. wardmundy Nerd Uno

    I'm Not Very Good At This, But...

    Here's what I'm using for the trunk settings...

    Dial rules:
    223NXXXXXX

    In Outgoing Settings...

    Trunk Name: sip2sip
    username=223343xxxx
    type=peer
    canreinvite=no
    secret=xxxx
    qualify=yes
    nat=yes
    insecure=invite,port
    host=proxy.sipthor.net
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    allow=ulaw&gsm

    Leave Incoming Settings Blank!

    Register: 223343xxxx:xxxx@sip2sip.info/223343xxxx

    Next create an Inbound Route for your DID using the 223343xxxx number you put on the end of the register string. Point this DID to wherever you want to answer the calls. NOTE: GSM is required or you'll have problems.

    Some have reported that the above didn't work for outbound calls so here's a workaround.

    Create a custom trunk that looks like this:

    Set your CallerID

    Dial Rules:
    223NXXXXXX
    001NXXNXXXXXX <- only if you want to pay for calls

    Custom DialString: SIP/$OUTNUM$@sip2sip.info

    Then create an Outbound Route called sip2sip with...

    Dial Rules:
    same as above

    Trunk: SIP/$OUTNUM$@sip2sip.info
  3. rchalk Member

    Thanks, Ward. I appreciate the help!
    Richard
  4. warraich Member

    Thank you Ward
  5. warraich Member

    Didn't work outbound call for sip2sip

    Didn't work outbound call for sip2sip. I did as ward said,
    Create a custom trunk that looks like this:

    Set your CallerID

    Dial Rules:
    223NXXXXXX
    001NXXNXXXXXX <- only if you want to pay for calls

    Custom DialString: SIP/$OUTNUM$@sip2sip.info

    Then create an Outbound Route called sip2sip with...

    Dial Rules:
    same as above

    Trunk: SIP/$OUTNUM$@sip2sip.info

    but it will just dial out from GV.
    can anyone help.
    Thanks,
  6. wardmundy Nerd Uno

    Dialout is in Trunk order. If your new trunk is below your default (or some other) trunk, then it never gets used if there is a dial string match on another trunk.

    So... move it on up.

    [IMG]
  7. warraich Member

    Thanks Ward. I tried moving the trunk up but it did not work. I will try again maybe I did some thing wrong.
  8. warraich Member

    Thanks ward I moved it up above default and also changed 223NXXXXXX to 2233XXXXXX and now it is working.
  9. atlpbxguy New Member

    outgoing calls failing

    Ok I have setup the system asterisk with two nortel phones. one is extension inside and the other is on sip2sip directly.

    when I call in from sip2sip it works fine and the video/audio is perfect.

    when I call out from the asterisk I see the call ring in on sip2sip phone but if I click to answer either by green button, pick up rec, or video button it still show call. the buttons at bottom are still ignore and decline.

    when I do hang up it shows missed call.

    all the time it is sending video and audio. the asterisk phone is seeing the video fine and audio is two ways. any ideas?

    my setup is as follows

    I have three trunks - one for each of the ips on the sip2sip proxy.
    username=22334xxxxx
    type=peer
    canreinvite=yes
    secret=xxx
    qualify=yes
    nat=yes
    insecure=invite,port
    host=81.23.228.150
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    allow=ulaw&gsm&h263


    then I added an outgoing as you stated above with custom trunk.

    If I remove the custom outbound I end up with network congested error.

    any thoughts would be appreciated as I am still fairly new.

    thank you.
  10. rossiv Guru

    :( This isn't registering for me...
    In sip show registry:
    Code:
    piaf-home*CLI> sip show registry
    Host                            Username       Refresh State                Reg.Time                 
    sipgate.com:5060                3932765e0          105 Registered           Thu, 04 Nov 2010 20:50:55
    proxy.sipthor.net:5060          2233442659         120 Request Sent 
    
  11. warraich Member

    [I changed host=proxy.sipthor.net to host=sip2sip.info and it worked for me.]
  12. rossiv Guru

    Doesn't work for me.:(
  13. warraich Member

    My trunk looks like this it is working with Video.

    username=2233439xxx
    type=peer
    canreinvite=no
    secret=xxxxxx
    qualify=yes
    nat=yes
    insecure=invite,port
    host=sip2sip.info
    dtmfmode=rfc2833
    disallow=all
    context=from-trunk
    allow=h263&ulaw&gsm

    Sip registry

    sip2sip.info:5060 223343xxx 105 Registered Sun, 07 Nov 2010 16:15:05
  14. rossiv Guru

    What domain do you have in your reg string?
  15. warraich Member

    2233439xxx:xxxxxx@sip2sip.info/2233439xxx
  16. jcusick New Member

    I've tried every combination of:

    host=proxy.sipthor.net and proxy.sipthor.net

    register string with either sip2sip.info or proxy.sipthor.net

    and no luck, can't register.

    tcpdump gives me either udp port sip unreachable or other errors.

    I have to assume the site is down this weekend or I'm doing something really wrong that I just cant see. I even did a nslookup and tried all the ip addesses, no luck.

    Is this group reliable or am I just screwing up?
  17. ojthecat New Member

    Post your trunk settings and register string for your sip2sip trunk you have something incorrect in there.
  18. jcusick New Member

    PEER Details:
    username=223344xxxx
    secret=xxxxxxxx
    type=peer
    canreinvite=no
    qualify=yes
    nat=yes
    insecure=invite,port
    host=sip2sip.info
    dtmfmode=rfc2833
    disallow=all
    allow=h323&ulaw&gsm
    context=from-trunk

    I have also tried this with and without:
    outboundproxy=proxy.sipthor.net

    in the PEER settings

    Register String:
    223344xxxx:xxxxxxxx@sip2sip.info/223344xxxx

    Thanks in advance for the help :smile5:

    JC
  19. jcusick New Member

    By the way, when I asked if this group was reliable, I meant sip2sip, not anyone here on this forum. I hope it wasn't taken the wrong way.

    JC
  20. ojthecat New Member

    I dont use outboundproxy

    i use
    host=proxy.sipthor.net

    everything else looks the same

Share This Page