1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you had a PIAF Forum account in the vBulletin days, log in with your old credentials. Otherwise, sign up again and we'll get you back in business as soon as we can.
  3. A serious FreePBX vulnerability has been reported. Update your Framework Module immediately. Click here for details.

Difficulty Setting IP Address with NetConfig

Discussion in 'Help' started by wardmundy, Nov 13, 2007.

  1. wardmundy Nerd Uno

    Be aware that there is a rare CentOS 5 quirk on some systems when manually setting an IP address with netconfig. The reported solution is to enter the static IP once, reboot, enter it twice more, and then issue the command service network restart.
  2. tfunk New Member

    this was a life saver! Thanks for posting this info...it was kicking my butt!!!!!
  3. jono New Member

    This did not work for me, I had to disable kudzu in order to set a static address.

    Edit: sorry for double post.
  4. jono New Member

    Am I using the same OS....?

    NetConfig doesn't work; I have to use system-config-network.

    Ward's suggestion for setting a static IP doesn't work for me, either; I had to disable kudzu in order to set a static address.
  5. darmock PIAF Developer

    from the cli type help-pbx

    you should see on first page 3rd choice install-netconfig

    if you don't have this then you have a version of piaf that does not have the upgrades installed. You will need to do the following to install the latest scripts and associated files.

    1. Log in as root into the cli

    2. type update-scripts and then tap the ENTER key

    3. If this does not work follow the instructions on
    http://www.pbxinaflash-scripts.com/update_scripts.htm
    this will install the latest scripts and stuff

    4. from the cli type:
    cd /var/pbx_load

    ls netconfig*

    You should have the rpm in this folder if not you need to download it by
    doing the wget command below

    wget ftp://ftp.nluug.nl/pub/os/Linux/dis...artCom/RPMS/netconfig-0.8.24-1.2.2.1.i386.rpm

    5. Once this has downloaded type install-netconfig and then tap the ENTER key


    CentOS in it's infinite wisdom decided to remove netconfig when you upgraded from 5.0 to 5.1 . Unfortunately the replacement does not allow you to set the DNS


    Tom
  6. jono New Member

    Thanks for your help.

    install-netconfig worked, even though it wasn't listed as an option with help-pbx.

    Somewhere to put the DNS addresses is very useful!

    I still have to disable kudzu to get the static address to stick...

    Now to work out why they've decided to leave out smbmount.
  7. Nope still cant get it

    I have installed PBX, given it a ip address from my DHCP server,
    i can access the server thro firefox but it wont ping any computer on my internal or the www.

    I assume this would also be effecting why i cant use softphones to connect to the server?
  8. darmock PIAF Developer

    what is your hardware and is it an AMD processor?

    Are you using an onboard NIC card?

    Either of these may be a show stopper unless the proper drivers are loaded.

    what does ifconfig say?

    have you ran disable-iptables?

    Tom
  9. Hardware:
    P4 2.66ghz with 2gb ram and 40gb hd, onboard NIC 1gb and a cd drive.

    using the onboard NIC, standard Intel NIC drivers seem to load as normal as i can access the net from the machine and access the machine from web browsers.

    if config says i have been issued with an IP address
    not tried disabling IPtables. what should I expect if it works?

    Thanks Tom, Mathew
  10. darmock PIAF Developer

    I suspect you should do the following first

    1. type update-scripts
    2. type update-fixes

    both scripts should be there. This will also update the help-pbx file

    After this simply type disable-iptables

    you can always re-enable iptables by typing enable-iptables

    iptables sometimes causes problems at times for some. Once it is disabled see if you can connect etc

    If not then I suspect you should disable the onboard nic and drop in a cheap realtek or 3com and see what happens..

    what is the output from ifconfig?

    Tom
  11. 1. update scripts - done
    2. type update-fixes - done
    disable-iptables - done

    do I want to restart the network service now?

    if not, i tried to connect - nothing

    How do i disable the NIC? or if i just put a NIC card in the machine it will just use that to connect?

    ifconfig - shows that i have an IP address, shows the macaddress, shows number of RX packets (0 errors, no dropped, no overruns etc)
    same with TX packets

    Thanks Mathew
  12. darmock PIAF Developer

    reboot the machine after disabling iptables and see what happens

    You disable the onboard nic in the bios. Sorry beyond that you will have to experiment,

    once you disable the onboard nic card put in the nic card and see what happens.

    Tom
  13. ok, thanks

    here is a dump of the diagnostic file from xlite:

    [07-12-27]20:02:00.640 | Info | AbstractPhone | "[test@192.168.1.85]::EnableAccount" |
    [07-12-27]20:02:00.670 | Info | DNS | "DNS [query:192.168.1.85]" |
    [07-12-27]20:02:00.690 | Info | DNS | "DNS-Lookup performed: '_sip._udp.' '192.168.1.85' [default-port:5060][fallback to A/QA:T] - Results:" |
    [07-12-27]20:02:00.690 | Info | DNS | " 0 - [ip:192.168.1.85:5060][ttl:4294967295][P:0][W:0][query-name:192.168.1.85]" |
    [07-12-27]20:02:00.700 | Info | DNS | "DNS [query:192.168.1.85]" |
    [07-12-27]20:02:00.700 | Info | DNS | "DNS-Lookup performed: '_sip._tcp.' '192.168.1.85' [default-port:5060][fallback to A/QA:T] - Results:" |
    [07-12-27]20:02:00.700 | Info | DNS | " 0 - [ip:192.168.1.85:5060][ttl:4294967295][P:0][W:0][query-name:192.168.1.85]" |
    [07-12-27]20:02:00.710 | Info | AbstractPhone | "Receiving notification about firewall IP address: 0.0.0.0, voip always possible: 0" |
    [07-12-27]20:02:00.880 | Info | CCM | "Creating transport... [URI:test@192.168.1.85]" |
    [07-12-27]20:02:00.880 | Info | CCM | "Not using firewall SIP proxy. Reasons: [URI:test@192.168.1.85]" |
    [07-12-27]20:02:00.890 | Info | RESIP:TRANSPORT | "Creating UDP transport host= port=44590 ipv4=1" |
    [07-12-27]20:02:00.890 | Info | CCM | "DSCP marking is set for SIP or DNS signaling socket, where socket=22, where transport type=3, where resip file is /Volumes/Coding/CpsiSvn/SUA/Library/sipfoundry/Projects/resiprocate/Mac/../../../main/resip/stack/InternalTransport.cxx, where resip line # is 120, where DSCP value=24" |
    [07-12-27]20:02:00.930 | Info | RESIP:TRANSPORT | "Creating TCP transport host= port=44590 ipv4=1" |
    [07-12-27]20:02:00.285 | Info | RESIP:DUM | "Got: SipResp: 404 tid=7a0a381d161dabc5 cseq=REGISTER / 1 from(wire)" |
    [07-12-27]20:02:00.287 | Info | CCM | "Response code to SIP request did not match any entry specified in retry-response-list. Response: 404[URI:test@192.168.1.85]" |
    [07-12-27]20:02:00.455 | Info | Addressbook | "FILTER: Recreate list with entries=0" |
    [07-12-27]20:02:43.326 | Info | DNS | "DNS [query:192.168.1.85]" |
    [07-12-27]20:02:43.327 | Info | DNS | "DNS-Lookup performed: '_sip._udp.' '192.168.1.85' [default-port:5060][fallback to A/QA:T] - Results:" |
    [07-12-27]20:02:43.327 | Info | DNS | " 0 - [ip:192.168.1.85:5060][ttl:4294967295][P:0][W:0][query-name:192.168.1.85]" |
    [07-12-27]20:02:43.327 | Info | DNS | "DNS [query:192.168.1.85]" |
    [07-12-27]20:02:43.327 | Info | DNS | "DNS-Lookup performed: '_sip._tcp.' '192.168.1.85' [default-port:5060][fallback to A/QA:T] - Results:" |
    [07-12-27]20:02:43.327 | Info | DNS | " 0 - [ip:192.168.1.85:5060][ttl:4294967295][P:0][W:0][query-name:192.168.1.85]" |
    [07-12-27]20:02:43.328 | Info | AbstractPhone | "Receiving notification about firewall IP address: 0.0.0.0, voip always possible: 0" |
    [07-12-27]20:03:00.880 | Info | RESIP:TRANSACTION | "Stats message " |
    [07-12-27]20:03:00.890 | Warning | RESIP:STATS | "RESIP:TRANSACTION
    TU summary: 0 TRANSPORT 0 TRANSACTION 0 CLIENTTX 0 SERVERTX 0 TIMERS 0
    Transaction summary: reqi 0 reqo 1 rspi 1 rspo 0
    Details: INVi 0/S0/F0 INVo 0/S0/F0 ACKi 0 ACKo 0 BYEi 0/S0/F0 BYEo 0/S0/F0 CANi 0/S0/F0 CANo 0/S0/F0 MSGi 0/S0/F0 MSGo 0/S0/F0 OPTi 0/S0/F0 OPTo 0/S0/F0 REGi 0/S0/F0 REGo 1/S0/F1 PUBi 0/S0/F0 PUBo 0/S0/F0 SUBi 0/S0/F0 SUBo 0/S0/F0 NOTi 0/S0/F0 NOTo 0/S0/F0
    Retransmissions: INVx 0 BYEx 0 CANx 0 MSGx 0 OPTx 0 REGx 0 finx 0 nonx 0 PUBx 0 SUBx 0 NOTx 0" |


    any of it look helpful to you?

    Mathew
  14. jono New Member

    Hi Ward,

    Am getting to grips with this great creation of yours, thanks.

    Anyway, with regards to your instructions above, when you say "enter it twice more," do you mean netconfig, add IP, reboot, netconfig, add IP, reboot, netconfig, add IP, service network restart....

    or

    netconfig, add IP, reboot, netconfig, add IP, netconfig, add IP, service network restart....?

    or

    am I being thick?

    The ONLY thing that keeps my IP static is disabling kudzu.
  15. darmock PIAF Developer

    In actual fact I am the one that discovered this. The sequence is

    netconfig - enter everything and use and outside DNS for best results. This is the nameserver your ISP provides and NOT the address of your router. Generally this information can be obtained from your router web pages.

    reboot

    netconfig - enter the same information again using the nameserver address for dns your ISP provides and not your router IP address.

    Test it by pinging www. nerdvittle.com if you get a response all is well if you don't get a response then do

    service network restart

    and try pinging again.

    As for the kudzu does it come up each time you reboot? If so it may not have a correct entry for the nic you are using. My office PIAF has this come up every time it reboots with it's digium tdm400 card. I just disable kudzu and no problems. Once you box is stable just disable kudzu using webmin and it will be well

    Tom

Share This Page